AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: MLAT  (Read 29886 times)

0 Members and 5 Guests are viewing this topic.

Amameric

  • New Member
  • *
  • Posts: 5
Re: MLAT
« Reply #90 on: January 20, 2021, 03:29:39 PM »
So following the best practice and adding a # in front of the line
do I need to move the --results to a new line ????

The line below is how my .ini file reads at present
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30104

i'm using a Airspy2 as my Rx

Thanks
Mark

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30359
Re: MLAT
« Reply #91 on: January 20, 2021, 03:37:21 PM »
Not as far as I am aware but hopefully someone with more knowleadge can advise

Alan
« Last Edit: January 20, 2021, 03:42:55 PM by Runway 31 »

derOlli

  • New Member
  • *
  • Posts: 6
Re: MLAT
« Reply #92 on: January 20, 2021, 03:43:51 PM »
Tried everything but it doesn't work quite well.
The MLAT status swich between:
-Active but not synched
-Active and synched with....(few Stations)
-dissapear completely

Code: [Select]
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxxxxxxxxx

sn=EXTRPI021224

lat=52.xxxx

lon=10.xxxx

alt=117

sat_used=0

sat_visible=0

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

Do i have to add something like "--results beast,listen,30104" ?
Thanks for alle the help!
Olli

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30359
Re: MLAT
« Reply #93 on: January 20, 2021, 03:46:51 PM »
It will only sync with stations if they are available to sync with and this will change as staton go on and offline

I have no idea regarding Listen

Alan
« Last Edit: January 20, 2021, 03:57:20 PM by Runway 31 »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30359
Re: MLAT
« Reply #94 on: January 20, 2021, 03:52:23 PM »
[email protected] may be able to advise further

Alan

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30359
Re: MLAT
« Reply #95 on: January 20, 2021, 04:00:09 PM »
Hopefully abcd will note the posts and come online later

Alan

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30359
Re: MLAT
« Reply #96 on: January 20, 2021, 04:04:04 PM »
Ollj

I see you have 38 stations synced at this time.  I have no idea why the syncing comes and goes, maybe someone with more knowledge can anser

Alan
« Last Edit: January 20, 2021, 04:06:10 PM by Runway 31 »

abcd567

  • Sr. Member
  • ****
  • Posts: 447
  • CYYZ - Toronto
Re: MLAT
« Reply #97 on: January 20, 2021, 10:52:06 PM »

Do i have to add something like "--results beast,listen,30104" ?


No, it is not necessary, and RB24 mlat works perfectly well even without it..

However if you are using dump1090-fa or dump1090-mutability, adding above to mlat_cmd  will make RB24's mlat plane also to be displayed on map of dump1090-fa/dump1090-mutability

Amameric

  • New Member
  • *
  • Posts: 5
Re: MLAT
« Reply #98 on: January 21, 2021, 07:11:23 AM »
Thanks  @abcd567,
bit confused as yes I am using dump1090-fa so is that a bad thing as i'm also feeding a few other feeders at the same time?
guess i # the line out in the .ini file i will see less aircraft on my map right?

abcd567

  • Sr. Member
  • ****
  • Posts: 447
  • CYYZ - Toronto
Re: MLAT
« Reply #99 on: January 21, 2021, 09:38:00 AM »
So following the best practice and adding a # in front of the line
do I need to move the --results to a new line ????

The line below is how my .ini file reads at present
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30104

i'm using a Airspy2 as my Rx

Thanks
Mark

Your current configuration is Good, keep it as it is (i.e. keep mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30104)

Mlat setting will be same for generic dongles and AirSpy.

Amameric

  • New Member
  • *
  • Posts: 5
Re: MLAT
« Reply #100 on: January 21, 2021, 09:50:55 AM »
Thanks @abc567
you are a true gentleman with all your support you give us

AnthonyHunt

  • New Member
  • *
  • Posts: 13
Re: MLAT
« Reply #101 on: January 26, 2021, 02:40:13 PM »
Tried everything but it doesn't work quite well.
The MLAT status swich between:
-Active but not synched
-Active and synched with....(few Stations)
-dissapear completely


I have the same problem.  Looking through the rbfeeder status is appears that it's not receiving replies from RadarBox?

Code: [Select]
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Disconnecting from mlat1.rb24.com:40900: No data (not even keepalives) received for 60 seconds
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Connected to multilateration server at mlat1.rb24.com:40900, handshaking

The startup config looks okay though?

Code: [Select]
   CGroup: /system.slice/rbfeeder.service
           ├─4118 /usr/bin/rbfeeder
           └─4129 /usr/bin/python3.7 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --lat 5x.xxxxxx --lon -2.xxxxxx --alt xx --user EXTRPIxxxxxx


any thoughts?

derOlli

  • New Member
  • *
  • Posts: 6
Re: MLAT
« Reply #102 on: January 27, 2021, 01:49:59 PM »
Tried everything but it doesn't work quite well.
The MLAT status swich between:
-Active but not synched
-Active and synched with....(few Stations)
-dissapear completely


I have the same problem.  Looking through the rbfeeder status is appears that it's not receiving replies from RadarBox?

Code: [Select]
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Disconnecting from mlat1.rb24.com:40900: No data (not even keepalives) received for 60 seconds
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Connected to multilateration server at mlat1.rb24.com:40900, handshaking

The startup config looks okay though?

Code: [Select]
   CGroup: /system.slice/rbfeeder.service
           ├─4118 /usr/bin/rbfeeder
           └─4129 /usr/bin/python3.7 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --lat 5x.xxxxxx --lon -2.xxxxxx --alt xx --user EXTRPIxxxxxx


any thoughts?

Did you already asked the support? I only got a standard answer
That’s ok don’t worry, it will only sync when there is more than 3 stations nearby with MLAT as well.

still have the same problem and no answer.

olli

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30359
Re: MLAT
« Reply #103 on: January 27, 2021, 04:09:39 PM »
I contacted the Development team who has advised me that following me raising the issue they have discovered a performance issue on some of the MLAT servers which they are now resolving.  Should take 1 to 2 hours to resolve

Alan
« Last Edit: January 27, 2021, 04:11:46 PM by Runway 31 »

Amameric

  • New Member
  • *
  • Posts: 5
Re: MLAT
« Reply #104 on: January 27, 2021, 05:23:45 PM »
This is good news
As I’ve also been seeing the same problem for months since I started feeding RB MLAT
Do we expect to see fairly constant synced stations from now ?