AirNav Systems Forum

AirNav RadarBox and RadarBox24.com => AirNav RadarBox and RadarBox24.com Discussion => Topic started by: wiedehopf on March 27, 2019, 04:45:09 PM

Title: MLAT
Post by: wiedehopf on March 27, 2019, 04:45:09 PM
I didn't even know you need to install the package mlat-client on the RPi.

This is new i presume as it's not in the install script?
Title: Re: MLAT
Post by: abcd567 on March 27, 2019, 05:03:46 PM
STEP-1: Update & install mlat-client
Code: [Select]
sudo apt-get update
sudo apt-get install mlat-client -y
sudo reboot

IMPORTANT NOTE:
Above method to install mlat-client may fail. If this happens, then use method given in the following post:
https://www.airnavsystems.com/forum/index.php?topic=101771.msg407051#msg407051

STEP-2: Edit file /etc/rbfeeder.ini, and ADD lines shown in RED to enable mlat
Note:
Use actual values in place of:
xx.xxxxxx (latitude)
yy.yyyyyy (longitude)
zzz  (antenna height, in meters, above sea level)

Code: [Select]
sudo nano /etc/rbfeeder.ini


Quote
[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
sn=EXTRPI000nnn
lat=xx.xxxxxx
lon=yy.yyyyyy
alt=zzz

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true


STEP-3: Restart rbfeeder
Code: [Select]
sudo systemctl restart rbfeeder

STEP-4: Check page: 
radarbox24.com/stations/EXTRPInnnnnn
(replace nnnnnn by your station number)
IF MLAT IS OK, it will be like attached screenshot.

========================================================
Alternate to STEP-2 (all other steps remain same)
========================================================
Instead of editing file /etc/rbfeeder.ini and adding lat, lon & alt manually, you can set these from RB24 web interface as shown below:
1. Go to following web page (replace xxxxxx by your station number)
radarbox24.com/stations/EXTRPIxxxxxx
2. Login to your account.
3. After login, on top left of web page, at the end of the line showing your city, Edit will appear, as shown by red arrow in attached screenshot.
Click Edit. This will open lat/lon setting box. Set your lat, lon & alt there.
4. Go to STEP-3 (restart rbfeeder)



Title: Re: MLAT
Post by: wiedehopf on March 27, 2019, 05:12:57 PM
If you provide the exact position on the website, the position will be automatically placed in the configuration file ;)

(At least i don't remember putting my coordinates into that file)
Title: Re: MLAT
Post by: Runway 31 on March 27, 2019, 06:15:18 PM
Its new and has not been announced officially yet.  The X-Range 2 and X-Range, maybe other receivers as well but I don't know, are getting new firmware installed for MLAT capability.  Once they all have their firmware updated an email will be sent to all feeders asking them where necessary to update their Pi and/or to update their exact lat/lon to enable MLAT across the board

Alan
Title: Re: MLAT
Post by: ea2ip on March 27, 2019, 06:49:35 PM
(Used actual values in place of xxxxxxxxxxxx, xx.xxxxxx, yy.yyyyyy, zzz (antenna height in meters)

Antenna height from ground or sea level?

Title: Re: MLAT
Post by: abcd567 on March 27, 2019, 06:56:44 PM
(Used actual values in place of xxxxxxxxxxxx, xx.xxxxxx, yy.yyyyyy, zzz (antenna height in meters)

Antenna height from ground or sea level?
Antenna Height Above Sea Level.
Sorry forgot to write in last post, will correct now.
Title: Re: MLAT
Post by: MDA on March 27, 2019, 08:20:35 PM
First in neighborhood :-)
Title: Re: MLAT
Post by: ea2ip on March 27, 2019, 09:43:18 PM
Not problem, working

Title: Re: MLAT
Post by: wiedehopf on March 30, 2019, 05:36:55 PM
We have liftoff, MLAT is working :)

Note that per default the MLAT results from the rbfeeder MLAT are not visible in the local dump1090 map.

Hopefully when the feature is stable the feeder will have an option to enable forwarding the results to the local dump1090.

(https://www.airnavsystems.com/forum/index.php?action=dlattach;topic=101771.0;attach=51661)
Title: Re: MLAT
Post by: Aerotower on March 31, 2019, 09:30:26 AM
Here you see that map?

thanks
Title: Re: MLAT
Post by: wiedehopf on March 31, 2019, 10:12:15 AM
That's the dump1090-fa webinterface with the wikipedia map tiles.

The layers.js can be modified to accept different tiles:
https://github.com/wiedehopf/dev-webview/blob/master/layers.js


But as i said those MLAT results are currently not visible.

If you have a Raspberry Pi getting that map shouldn't be too complicated.

Do the radarbox and xrange offer beast or AVR data via TCP?
It's not too hard to run a dump1090-fa in net-only mode and display beast data from the web:
https://github.com/wiedehopf/combine1090#combine1090

If it is AVR and not beast you will have to modify the target port.
Title: Re: MLAT
Post by: neroon79 on April 19, 2019, 03:10:22 PM
If trying to install mlat-client im getting the following:

Some packages could not be installed. That may mean that
You have requested an impossible situation or if you have the
Unstable distribution still use some required packages
have not been created or have not yet left Incoming.
The following information may help you to resolve the situation:

The following packages have unmet dependencies:
  mlat-client: Depends on: python3 (> = 3.5 ~) but 3.4.2-2 should be installed
                Depends on: python3.5: any is not installable
E: Problems can not be corrected, you have retained defective packages.

Ingo
Title: Re: MLAT
Post by: wiedehopf on April 19, 2019, 03:54:20 PM
Run
sudo apt-get update
sudo apt-get upgrade

If that doesn't help you might be on Raspbian Jessie and need an upgrade to Stretch.

Depending on which sd-card image you started from that isn't too hard.
Title: Re: MLAT
Post by: flygpagen on April 19, 2019, 05:50:55 PM
Hello there,

I put up a new antenna on the roof today, and then went and enabled MLAT on my Pi according to the instructions above. However I suspect that something is wrong, seeing that the coverage has expanded all the way to GB (the antenna is no way that good). Also MLAT does not show on the station as your examples in this thread.
https://www.radarbox24.com/stations/EXTRPI001593

Will return to the field and do some error probing but ideas are welcome...
Title: Re: MLAT
Post by: Runway 31 on April 19, 2019, 06:35:41 PM
It looks like the feeder is updated correctly as you are showing the correct firmware version.  However now edit your location with the exact lat/lon in decimal then save.  Once that's done you should show MLAT active,

The spurious coverage shown over to the UK will wear off over the next week so I wouldn't bother with it

Alan
Title: Re: MLAT
Post by: abcd567 on April 19, 2019, 11:41:22 PM
If trying to install mlat-client im getting the following:

Please post output of following command
Code: [Select]
cat /etc/os-release
Title: Re: MLAT
Post by: wiedehopf on April 20, 2019, 12:09:08 AM
However I suspect that something is wrong, seeing that the coverage has expanded all the way to GB (the antenna is no way that good).

Something is indeed wrong, somehow the positions of aircraft above you are displayed way to the west.

I really have no clue how that could be happening.
Can you provide a screenshot of your local map, does it look like this as well?

Just in case you didn't already, do a reboot.
Title: Re: MLAT
Post by: neroon79 on April 20, 2019, 05:55:26 AM
Run
sudo apt-get update
sudo apt-get upgrade

If that doesn't help you might be on Raspbian Jessie and need an upgrade to Stretch.

Depending on which sd-card image you started from that isn't too hard.
I just wanted you to know:

I waited as long as I could to do the Jessie -> Stretch migration due to the rule "never touch a running/working system". Anyway, migration worked without any severe impact or problem. After the migration the install mlat-client was of course working without any problem.

Thanks Ingo
Title: Re: MLAT
Post by: wiedehopf on April 20, 2019, 07:49:16 AM
Will return to the field and do some error probing but ideas are welcome...

Can you check if lat and lon are correct in /etc/rbfeeder.ini?

sudo nano /etc/rbfeeder.ini

Fix them :)
(Press Ctrl-O and enter to save, then Ctrl-X to exit)

(That's about the only possibility i can imagine.)
I checked locally, putting in a position about 10 longitude to the west of your own position produces bogus positions.

After fixing the location you also need to stop rbfeeder or switch off the RPi for a couple of minutes, otherwise the feeder continues to be confused.
Using receiver local CPR is really a bad idea for feeding, just in case a developer is reading here :)

Stopping rbfeeder:

sudo systemctl stop rbfeeder

starting it again after a couple of minutes:

sudo systemctl restart rbfeeder
Title: Re: MLAT
Post by: flygpagen on April 20, 2019, 10:12:38 AM
The station is at my airfield, I live appr. 25 kilometers away... Will install VNC server so that it will hopefully be easier to manage. :)

Anyway, I have updated the rbfeeder.ini with the following;
lat=56.131217 (was 56.131200)
long=13.879246 (was 13.879200)
That is the position I get when positioning using the radarbox webpage map localizer. Now powered Pi of, see if this helps. I have been trying to use the radarbox localization tool but it usually gives me this error;

We couldn't get your location!
Please ensure you have inserted decimal degrees or contact us at [email protected] to manually update



Title: Re: MLAT
Post by: wiedehopf on April 20, 2019, 10:17:15 AM
The rbfeeder.ini needs this:

lon=13.879246

long has an extra g in your version!
But the abbreviation for the config is lon not long.

(this could have resulted in the program using 0 as longitude/lon which looks exactly like your problem)
Title: Re: MLAT
Post by: flygpagen on April 20, 2019, 10:25:36 AM
Well... I blush. Thank you for seeing this error! Corrected & restarted!
Title: Re: MLAT
Post by: wiedehopf on April 20, 2019, 10:30:49 AM
Thank you for seeing this error! Corrected & restarted!

Good that you put it in your post, otherwise i would have been out of luck.

Anyway long is a perfectly valid abbreviation, just not the one commonly used it seems :)

Your station looks better already!
Title: Re: MLAT
Post by: Runway 31 on April 20, 2019, 11:46:11 AM
Well done

Alan
Title: Re: MLAT
Post by: glennblum on May 21, 2019, 10:49:06 PM
Got it installed. Thanks. No MLAT synched as of right now but I don't know how much coverage RB24 has in Texas.
Title: Re: MLAT
Post by: Runway 31 on May 22, 2019, 08:26:51 AM
I think at this stage the issue may well be that the majority of users are not set up for MALT yet

Alan
Title: Re: MLAT
Post by: abcd567 on May 22, 2019, 11:52:50 PM
....the majority of users are not set up for MALT yet

... because majority of users do NOT know that they can enable malat. :)
Title: Re: MLAT
Post by: Runway 31 on May 23, 2019, 09:11:30 AM
I have been waiting on a email going out to users to advise.  A new firmware to enable for x-range units is due out by the weekend, maybe after it is out they will broadcast

Alan
Title: Re: MLAT
Post by: SoNic67 on June 02, 2019, 02:44:09 PM
I think at this stage the issue may well be that the majority of users are not set up for MALT yet

Alan
Yeah, I found out only by accident, looking at my feed webpage, it was saying "MLAT not enabled" and had instructions how to enable it.
Now I am synced with 5 receivers.

For comparation, on the FlightAware side I am "synchronized with 185 nearby receivers".
Title: Re: MLAT
Post by: Aerotower on June 02, 2019, 02:58:53 PM
I think at this stage the issue may well be that the majority of users are not set up for MALT yet

Alan
Yeah, I found out only by accident, looking at my feed webpage, it was saying "MLAT not enabled" and had instructions how to enable it.
Now I am synced with 5 receivers.

For comparation, on the FlightAware side I am "synchronized with 185 nearby receivers".

Hi, What is your feeder "alias"?

Thanks
Title: Re: MLAT
Post by: abcd567 on July 02, 2019, 03:16:14 AM
Today I wrote latest Raspbian image (Buster) to microSD card and installed rbfeeder.
All went ok and the feeder is working fine.

However when I tried to install mlat-client by following command, it failed:

Code: [Select]
[email protected]:~ $ sudo apt-get install mlat-client

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mlat-client : Depends: python3 (< 3.6) but 3.7.3-1 is to be installed
E: Unable to correct problems, you have held broken packages.


I solved this problem by building the mlat-client package from source code as follows:

Code: [Select]
## Installed required packages (dependencies and build tools)
sudo apt update -y
sudo apt-get install -y git curl build-essential debhelper python-dev python3-dev

## Downloaded source code
cd /home/pi/
git clone https://github.com/mutability/mlat-client.git

## Built mlat-client's installation package
cd /home/pi/mlat-client
sudo dpkg-buildpackage -b -uc

## Above command took some time to build package
## After the package was built, installed it by following command
cd /home/pi/
sudo dpkg -i mlat-client_*.deb




ALTERNATE to building mlat-client from source code as above, you can now install pre-built package available at my Github site. Please see this post for details:

https://forum.radarbox24.com/index.php?topic=101771.msg433591#msg433591


.
Title: Re: MLAT
Post by: whome82 on July 02, 2019, 10:29:39 PM
I too have had the same problem however tried running the code as provided and now get the following error-

error: cannot access archive 'mlat-client_*.deb': no such file or directory.

Any ideas? thanks
Title: Re: MLAT
Post by: abcd567 on July 03, 2019, 01:34:04 AM
I too have had the same problem however tried running the code as provided and now get the following error-

error: cannot access archive 'mlat-client_*.deb': no such file or directory.

Any ideas? thanks

Sorry, there was a mistake in the second last line.
It was wrongly written "cd /home/pi/mlat-client".
The correct command is "cd /home/pi/"

The last two commands should be like below. I have now corrected it in my original post also
Code: [Select]
cd /home/pi/
sudo dpkg -i mlat-client_*.deb
Title: Re: MLAT
Post by: whome82 on July 03, 2019, 05:30:58 PM
Thank you, Perfect now working with MLAT on my Pi also!

Great stuff
Title: Re: MLAT
Post by: kan84 on July 16, 2019, 06:15:46 PM
Thanks was able to get MLAT issue resolved for both my feeders. I had autostart_mlat set as true but that did not help, I had to put in the coordinates in the ini file for it to work.
Title: Re: MLAT
Post by: Runway 31 on July 16, 2019, 06:19:08 PM
That's correct, Pi's require the lat/lon to be set for MLAT

Alan
Title: Re: MLAT
Post by: anirbansen on November 28, 2019, 07:31:10 AM
In my new installation with Buster, I faced the same problem and recreated "mlat-client_0.2.10_armhf.deb". After I ran dpkg -i, I copied the fa-mlat-client to /usr/bin and radarbox24 feeder picked it up and started MLAT.  I then removed the packages  build-essential debhelper python-dev python3-dev and the mlat-client folder.

But sudo apt-get update is again displaying the error:
The following packages have unmet dependencies:
 mlat-client : Depends: python3 (< 3.6) but 3.7.3-1 is to be installed
E: Unable to correct problems, you have held broken packages.


The above packages have several dependencies which I did not want to keep in the system.  I have kept git and curl though.

Its worth mentioning that mlat-client_0.2.10_armhf.deb package is also there under /home/pi/adsb-exchange and the sub folder adsb-exchange also contains another folder "mlat-client" but which may be a different version as judged by file size of fa-mlat-client:
1) /user/bin/fa-mlat-client * 2147bytes
2) /home/pi/adsb-exchange/mlat-client/fa-mlat-client * 2149 bytes
Title: Re: MLAT
Post by: wiedehopf on December 01, 2019, 02:23:37 PM
You need python3 for mlat.

Just install it with apt install.
Title: Re: MLAT
Post by: Nigelrich on February 25, 2020, 07:54:35 PM
I've tried this build for the MLAT client but still inactive. I'm running Buster Lite and dump1090-fa

Any suggestions of what else I could try?

Thanks
Title: Re: MLAT
Post by: abcd567 on February 25, 2020, 10:07:16 PM
(1) Have you added your latitude, longitude and altitude (lat, lon, alt) in settings?
Please see STEP-2 (or Alternate to STEP-2) in this post:

https://forum.radarbox24.com/index.php?topic=101771.msg389571#msg389571

(2) To make sure mlat-client is installed and working ok, post output of these two commands

Code: [Select]
apt-cache policy mlat-client

sudo systemctl status mlat-client

.
Title: Re: MLAT
Post by: Nigelrich on February 25, 2020, 10:50:09 PM
Yes, all the site details are input.

This is what I get from the two commands you requested:

[email protected]:~ $ apt-cache policy mlat-client
mlat-client:
  Installed: 0.2.11
  Candidate: 0.2.11
  Version table:
 *** 0.2.11 100
        100 /var/lib/dpkg/status

[email protected]:~ $ sudo systemctl status mlat-client
● mlat-client.service - LSB: Multilateration client
   Loaded: loaded (/etc/init.d/mlat-client; generated)
   Active: active (exited) since Tue 2020-02-25 19:44:49 GMT; 3h 1min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 320 ExecStart=/etc/init.d/mlat-client start (code=exited, status=0/SUCCESS)

Feb 25 19:44:48 raspberrypi systemd[1]: Starting LSB: Multilateration client...
Feb 25 19:44:49 raspberrypi mlat-client[320]: Not starting mlat-client daemon, disabled via /etc/default/mlat-client ... (warning).
Feb 25 19:44:49 raspberrypi systemd[1]: Started LSB: Multilateration client.

Thanks
Title: Re: MLAT
Post by: Nigelrich on February 25, 2020, 10:56:32 PM
After inputting those two commands that you suggested, it appears to be working now

Have they triggered it into action?

Many thanks
Title: Re: MLAT
Post by: abcd567 on February 25, 2020, 11:34:33 PM
After inputting those two commands that you suggested, it appears to be working now

Have they triggered it into action?

Many thanks

When you go to following page, do you see "Mlat active (xx stations synced)", as shown in screenshot below.

http://www.radarbox24.com/stations/EXTRPIxxxxxx
(Replace xxxxxx by your station number)

Title: Re: MLAT
Post by: Nigelrich on February 26, 2020, 12:57:52 AM
Yes I do. I did exactly the same re-build on another Pi and didn't have any problems, which puzzled me why one didn't work and another did. Anyway they are sorted now.

Many thanks for your help
Title: Re: MLAT
Post by: abcd567 on February 26, 2020, 01:27:16 AM
As an interim measure, I have built two mlat-client packages, one for Raspbian STRETCH and other for Raspbian BUSTER, and uploaded to my Github site.

These can be easily installed by following commands:

To install on RPi with Raspbian BUSTER:
Code: [Select]
## Download mlat-client package for BUSTER
wget https://github.com/abcd567a/mlat-client-package/releases/download/v1/mlat-client_0.2.11_BUSTER_armhf.deb   

## Install downloaded package
sudo dpkg -i mlat-client_0.2.11_BUSTER_armhf.deb   


To install on RPi with Raspbian STRETCH
Code: [Select]
## Download mlat-client package for STRETCH
wget https://github.com/abcd567a/mlat-client-package/releases/download/v1/mlat-client_0.2.11_STRETCH_armhf.deb 

## Install downloaded package
sudo dpkg -i mlat-client_0.2.11_STRETCH_armhf.deb 


If you are not sure your Raspbian is Stretch or Buster, issue this command to find out
Code: [Select]
lsb_release -sc


Instructions here:

https://github.com/abcd567a/mlat-client-package/blob/master/README.md


.
Title: Re: MLAT
Post by: ddolbel on April 30, 2020, 04:06:40 AM
Hi Everyone,

apologies in advance incase this has been asked several times before,
I have searched this forum but can't seem to find an answer

I have a feeder currently running piaware and I have just installed Radarbox
all in all the installation went well no errors YAY

however I don't seem to be getting any mlat results on the Radarbox site where as i am on the piware site..

I have seen some mention on the forum of installation of a mlat client for radar box, do i still need to do that even know i already have piaware installed ?

Thank you once again for your time and effort looking forward to your reply
Title: Re: MLAT
Post by: Runway 31 on April 30, 2020, 07:25:02 AM
I don't know anything regarding Pi's but I would think that the MLAT client is specific to each provider i.e Radarbox, Flightaware etc and each will need their own client as the data will not be shared between providers.  Hopefully someone can advise if this is correct

For MLAT to work however you need to edit your location with your exact lat/lon and suggest that if you have not already done so to do this as a first step.  Use Edit next to your location  on the status grid top left of the MyStation screen

Alan
Title: Re: MLAT
Post by: abcd567 on April 30, 2020, 08:26:06 AM
@ddolbel:

(A) To enable mlat, you have t do following TWO things:
(1) Install mlat-client
(2) Enter your latitude, longitude and elevation above sea level.

Please see this post for details:
https://forum.radarbox24.com/index.php?topic=101771.msg389571#msg389571


(B) To see mlat results plane on dump1090-fa (SkyView) map:


Code: [Select]
sudo nano /etc/rbfeeder.ini

Edit this line:

Original Line:
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

After Editing:
Note: Dont forget to remove # at start of the original line

For Raspbian Stretch:
mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client --results beast,connect,127.0.0.1:30104 

For Raspbian Buster:
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,connect,127.0.0.1:30104 

If you are not sure your Raspbian is Stretch or Buster, issue this command to find out

Code: [Select]
lsb_release -sc


Contents of file /etc/rbfeeder.ini

Quote

[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxxxxxxxxxxxxxxxxxx

sn=EXTRPI00xxxx

lat=xx.xxxx
lon=yy.yyyy
alt=zzz

sat_used=0
sat_visible=0

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,connect,127.0.0.1:30104 

[dump978]
#dump978_enabled=true



Code: [Select]
sudo systemctl restart rbfeeder


.
Title: Re: MLAT
Post by: ddolbel on April 30, 2020, 09:02:57 AM
@abcd567

Thank you for the update....

ok just to reconfirm my piaware is working and mlat is being reported for piaware..

what i'm checking is that do i need to install another mlat-updater just for radarbox?
Title: Re: MLAT
Post by: abcd567 on April 30, 2020, 03:24:15 PM
@ddolbel:

From user's point of view, enabling mlat on one site is enough, but enabling mlat on more than one site does not hurt. It however benefits the sites for which mlat is enabled


The FlightAware mlat:
(1) The mlat calculations are done at FlightAware servers.
(2) Used by flightaware on the map served by Flightaware server.
(3) Fed back to the feeder'Pi and by default displayed on SkyView map. User does mot have to make any configuration for this.

The RadarBox24 mlat:
(1) The mlat calculations are done a Radarbox24 servers.
(2) Used by flightaware on the map served by Radarbox server.
(3) Results are fed back to the feeder's Pi and can be displayed on SkyView or VRS. However unlike Flightaware mlat, this is not by default and user has to modify config as I have shown in my above post.

The FlightRadar24 mlat:
(1) The mlat calculations are done a FlightRadar24 servers.
(2) Used by flightaware on the map served by Radarbox server.
(3) Results are NOT fed back to the feeder's Pi



.
Title: Re: MLAT
Post by: ddolbel on April 30, 2020, 08:55:48 PM
@abcd567

thank you for your response

I have just tried to install the mlat-client however unable to locate the package

Code: [Select]

[email protected]:~$ sudo apt-get install mlat-client
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package mlat-client

Title: Re: MLAT
Post by: abcd567 on April 30, 2020, 09:21:46 PM
@abcd567
I have just tried to install the mlat-client however unable to locate the package

This means you missed to read the NOTE in my first post and did not go to link given in my first post.
Below is the quote from my first post, which contains the link. Please visit it and follow instructions there:

NOTE:
Above method to install mlat-client may fail for Raspbian Buster. If this happens, then use method given in the following post:
https://www.airnavsystems.com/forum/index.php?topic=101771.msg407051#msg407051


.
Title: Re: MLAT
Post by: ddolbel on April 30, 2020, 09:24:49 PM
sorry i missed that, will give it a go

ps the piaware image is running jessie

i don't have python 3.5 installed only 3.4

i changed mlat in the rbfeeder.ini
mlat_cmd=/usr/bin/python3.4 /usr/bin/mlat-client --results beast,listen,30104

Title: Re: MLAT
Post by: abcd567 on May 01, 2020, 02:56:57 AM
Jessie is too old. You will start facing lot of compatibality and upgrade problems soon.

Better format microSD card and write latest piaware image ver 3.8.1, which is Buster, then install rbfeeder and mlat-client.
Title: Re: MLAT
Post by: ddolbel on May 01, 2020, 03:01:15 AM
I have ordered a new pi 4b will hang off till it arrives..

Thanks for your time and effort.
Title: Re: MLAT
Post by: MrNobody on May 13, 2020, 09:18:47 PM
Hello Everybody,

Since re-installing my pi from jessie to buster, I also encounter problems with mlat-client.
I have installed dump1090-mutability and feed five sites, on most of them MLAT is working fine. I now installed the compiled version from @abcd567 using this hint: https://forum.radarbox24.com/index.php?topic=101771.msg433591#msg433591 (https://forum.radarbox24.com/index.php?topic=101771.msg433591#msg433591)
but mlat-client does not work.
using
Code: [Select]
sudo systemctl status mlat-client, the result is :

● mlat-client.service - LSB: Multilateration client
   Loaded: loaded (/etc/init.d/mlat-client; generated)
   Active: active (exited) since Tue 2020-05-12 21:33:37 CEST; 1 day 1h ago
     Docs: man:systemd-sysv-generator(8)
  Process: 292 ExecStart=/etc/init.d/mlat-client start (code=exited, status=0/SUCCESS)

Mai 12 21:33:37 myPiADSB systemd[1]: Starting LSB: Multilateration client...
Mai 12 21:33:37 myPiADSB mlat-client[292]: Not starting mlat-client daemon, disabled via /etc/default/mlat-client ...
Mai 12 21:33:37 myPiADSB systemd[1]: Started LSB: Multilateration client.



What could be the reason therefore? The Radarbox Site says no MLAT active...
Thank you in advance.
Title: Re: MLAT
Post by: abcd567 on May 14, 2020, 12:17:54 AM
There are two things required to be done:
(1) Install mlat-client, which you have done
(2) Set your latitude, longitude and antenna elevation. Did you do it? If not it can be done in any one of the two ways:
(a) Add these in file /etc/rbfeeder.ini
OR
(b) Go to your RB24 map on internet and add it there.

Both the above methods are described in STEP-2 of this post:
https://forum.radarbox24.com/index.php?topic=101771.msg389571#msg389571

Title: Re: MLAT
Post by: MrNobody on May 14, 2020, 06:37:33 PM
Thank you for the very quick answer.
I had written these lines to the rbfeeder.ini, but there was a mistyping: I wrote 1at=xx.xxxxxx instead of lat=xx.xxxxxx but I didn't recognize this difference in the terminal view.
Thank you very much, problem is solved, MLAT is working fine now :-)
Title: Re: MLAT
Post by: abcd567 on May 14, 2020, 07:55:24 PM
1at instead of lat :(
Copy-paste from post (instead of typing) avoids typing mistakes.
Glad to know you could spot the typo, and now your system is up and running :)
Title: Re: MLAT
Post by: Kirill on May 18, 2020, 04:37:40 PM
Hello. I need some help with MLAT.
I use consol version dump1090 under win10 x64
I feed to RB24 from Data Sharer 1.20 win10 x64
I want feed MLAT
I feed to 12 serves from my VRS, and to FR and FA from ubuntu under hyper-V win10 x64 support/
Mlat work on FA, how feed Mlat to RB?
Mlat client in my ubuntu install and work by command:
mlat-client --input-type dump1090 --input-connect localhost:30005 --lat 52.35957 --lon 31.02599 --alt 126.1 --user UMGG --server feed.adsbexchange.com:31090 --no-udp --results beast,connect,localhost:30005
Maybe i can use second command mlat client.
Kirill EXTSHA193428 UMGG
 
Title: Re: MLAT
Post by: Runway 31 on May 18, 2020, 04:59:36 PM
Kirill
Try by clicking on Edit next to your location on the right of your MyStation map and enter your exact decimal lat/lot.  This may not work using the data sharer software though and you may need to use the Pi method as detailed by abcd567

Alan
Title: Re: MLAT
Post by: abcd567 on May 19, 2020, 12:26:50 PM
Like Adsbexchange, Radarbox24 also uses mlat-client, but control & configuration is through its feeder. The only version of RadarBox24 feeder which is mlat capable is the RPi (armv7) version. It wont work on Ubuntu x64.

As the source code is now available, you may try to build Ubuntu version of rbfeeder from source code. Please see this thread:

rbfeeder for x86_64 or i386 (https://forum.radarbox24.com/index.php?topic=102921.0)
Title: Re: MLAT
Post by: Kirill on May 19, 2020, 08:12:25 PM
Thank! I am ready to run on ubuntu, but I do not know Linux at all and do not know how to collect packages. Maybe you can collect for me?
Title: Re: MLAT
Post by: abcd567 on May 19, 2020, 10:41:14 PM
Kirill:
Sorry, I tried, but could not succeed.
Some info needed to compile installation package, but the info is not made public by Radarbox24 software developers.
Title: Re: MLAT
Post by: abcd567 on December 16, 2020, 03:10:43 AM
Flow Chart
(https://i.postimg.cc/QdpYV310/RB24-feeder-Flow-Chart.png)



Default Config (Without Mlat)
(https://i.postimg.cc/C1KcvntQ/RB24-Config-Default.png)



Config Mlat Enabled
(https://i.postimg.cc/bvpCtBR8/RB24-feeder-Config-MLAT-Enabled.png)

Title: Re: MLAT
Post by: streety66 on January 05, 2021, 04:26:29 PM
Hi guys,

I have followed the instructions to the letter for for RPi setup - EXTRPI010051

The lat/lon/alt are setup OK in rbfeeder.ini, along with the autostart_mlat=true.

The packages installed OK with no errors - I have restarted the RPi numerous times.

I have edited the site location via the map giving the same co-ordinates as listed in the rbfeeder.

I have stopped the service, waited until all my flights disappear, then restarted.

I just cannot seem to get MLAT working.

I have now run out of ideas and would welcome any input from the experts, please?

Thanks in advance,

Paul.

Edit - sorry - it's a Pi3 running Buster, also feeding FR24, FA, PF and PP.
Title: Re: MLAT
Post by: Runway 31 on January 05, 2021, 04:39:40 PM
Hi Paul

In addition to the RB feeder software did you install the MLAT client per Reply 1 of this thread

From a message by abcd on the previous page

(A) To enable mlat, you have to do following TWO things:
(1) Install mlat-client
(2) Enter your latitude, longitude and elevation above sea level.

Alan
Title: Re: MLAT
Post by: streety66 on January 05, 2021, 05:44:18 PM
Hi,

Thanks Alan - I have performed those steps - yes.

My rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=Removed
sn=EXTRPI010051
lat=53.1nnnnn
lon=-1.2nnnnn
alt=150

sat_used=0

sat_visible=0

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

Output from sudo systemctl status mlat-client
(is the warning message important?)

mlat-client.service - LSB: Multilateration client
   Loaded: loaded (/etc/init.d/mlat-client; generated)
   Active: active (exited) since Sun 2021-01-03 14:28:32 GMT; 2 days ago
     Docs: man:systemd-sysv-generator(8)
  Process: 349 ExecStart=/etc/init.d/mlat-client start (code=exited, status=0/SUCCESS)

Jan 03 14:28:29 RPi3ADSB systemd[1]: Starting LSB: Multilateration client...
Jan 03 14:28:32 RPi3ADSB mlat-client[349]: Not starting mlat-client daemon, disabled via /etc/default/mlat-client ... (warning).
Jan 03 14:28:32 RPi3ADSB systemd[1]: Started LSB: Multilateration client.


Many thanks,
Paul.
Title: Re: MLAT
Post by: streety66 on January 05, 2021, 05:48:59 PM
Further investigation shows this:- (could there be a conflict with the other feeders, FR24, FA, PP and PF?)

[email protected]:/etc/default $ more mlat-client
# mlat-client configuration file
# This is a POSIX shell fragment.
# You can edit this file directly, or use
# "dpkg-reconfigure mlat-client"

# Start the client?
START_CLIENT="no"

# System user to run as.
RUN_AS_USER="mlat"

# User to log into the server as
SERVER_USER=""

# Logfile to log to
LOGFILE="/var/log/mlat-client.log"

# Input receiver type (dump1090, beast, radarcape_12mhz, radarcape_gps, sbs)
INPUT_TYPE="dump1090"

# Input host:port to connect to for Beast-format messages
INPUT_HOSTPORT="localhost:30005"

# Multilateration server host:port to provide data to
SERVER_HOSTPORT="mlat.mutability.co.uk:40147"

# Latitude of the receiver, in decimal degrees
LAT=""

# Longitude of the receiver, in decimal degrees
LON=""

# Altitude of the receiver, in metres
ALT=""

# List of result connections/listeners to establish.
# This should be a space-separated list of values suitable for passing to
# the --results option (see mlat-client --help for syntax)
RESULTS="basestation,listen,31003"

# Other arguments to pass to mlat-client
EXTRA_ARGS=""
Title: Re: MLAT
Post by: Runway 31 on January 05, 2021, 06:49:05 PM
Paul

Am out of my depth here and will leave it to abcd to come on and work his magic

Alan
Title: Re: MLAT
Post by: abcd567 on January 05, 2021, 10:57:34 PM

[mlat]
autostart_mlat=true
mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client



mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

The cause of failure is wrong version of python in above line of the file  /etc/rbfeeder.ini
The python3.5 was for Raspbian Stretch.
The current version is Buster, which requires python3.7

To fix the problem:
Either change 3.5 to 3.7
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client

OR BETTER

Comment out this line by placing a # at start of line
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

Placing a # at start of line will change line's color from white to blue. Please see screenshot below.

After making and Saving changes,  reboot Pi

sudo reboot


(https://i.postimg.cc/bvpCtBR8/RB24-feeder-Config-MLAT-Enabled.png)

.
Title: Re: MLAT
Post by: abcd567 on January 06, 2021, 10:03:46 AM
Paul

Am out of my depth here and will leave it to abcd to come on and work his magic

Alan

Take the plunge. Buy a RPi and start playing with it.
That is how everybody learns RPi and Linux.
When I purchased my first Pi about 5 years ago, my knowledge of Pi and Linux was ZERO.
Title: Re: MLAT
Post by: Runway 31 on January 06, 2021, 10:12:39 AM
Am thinking of it

Alan
Title: Re: MLAT
Post by: streety66 on January 06, 2021, 10:56:04 AM
Mr ABCD567, you Sir, are a true gent - I'm so grateful, thank you.

Now feeding MLAT.

Thanks also to Alan for his assistance.

May I ask what the mlat_cmd= line actually does and the implication of commenting it out? For now, I made the 3.5 to 3.7 change but if commenting the line is better, would like to understand why, please?

Cheers,
Paul.
Title: Re: MLAT
Post by: abcd567 on January 06, 2021, 01:47:53 PM
The rbfeeder has this line built in, and provides it if this lines is commented out. This command starts the mlat-client

Commenting out is better from possible upgrade of rbfeeder in future which may require changing python3.7 to say python3.8 or 3.9 or 4. Commenting it out will force new version of rbfeeder to use correct version built into it.
Title: Re: MLAT
Post by: streety66 on January 06, 2021, 02:03:13 PM
Thanks once again - that makes sense when put like that and I have now commented it out and rebooted.

Much appreciated.

Paul.
Title: Re: MLAT
Post by: thechipman0 on January 14, 2021, 05:02:44 PM
On my pi mlat is active but just can't get it to sync with my station, have been working on this for days. Time to slit my wrist I think 😩
Title: Re: MLAT
Post by: anorak on January 14, 2021, 05:12:09 PM
While you`re waiting for ABCD to help, try a nice single malt from Spey side.
Dave.
Title: Re: MLAT
Post by: Runway 31 on January 14, 2021, 05:38:43 PM
chipman, what do you mean sync with your station?  If you mean why you are not seeing it showing as synced with other stations are you close enough to other MLAT stations.  If you are showing as MLAT any MLAT active stations active within your coverage are automatically synced you dont do anything

What is your station number?

Also whatever, go with the single malt anyway :-))

Alan
Title: Re: MLAT
Post by: thechipman0 on January 14, 2021, 06:37:13 PM
Lol the single malt will go down a treat. I never realised what mlat no sync meant, I do now thanks. I must have another problem as not showing any aircraft. When using same areal and same position when I used my laptop with the old rb box I was getting 200+miles coverage. Now with raspi and radarbox micro nothing.
Title: Re: MLAT
Post by: thechipman0 on January 14, 2021, 06:38:43 PM
Station number EXTRPI020882
Title: Re: MLAT
Post by: Runway 31 on January 14, 2021, 06:41:29 PM
Chipman did you set up as per https://forum.radarbox24.com/index.php?topic=10201.0 and also set up the MLAT client per earlier in this thread

Looking at your MyStation link, you dont appeat to have MLAT set up

If you have a micro RB that can be used on your computer with the V6 software installed no issues,.  You will also need to download and install the drivers for it http://www.airnavsystems.com/Download/ANRB/Drivers/microRadarbox-Drivers-20150411.exe  Note you wont get MLAT with this method though

Use the same log in details you used with your original box

Alan
Title: Re: MLAT
Post by: thechipman0 on January 15, 2021, 09:35:23 PM
Thank you for that. As far as I could work out I did set up mlat as per instructions from threads on rb. I shall go to the thread you have posted and try again.
Title: Re: MLAT
Post by: Runway 31 on January 16, 2021, 10:06:49 AM
The issue is more than MLAT chipman as you are not feeding data either see https://www.radarbox.com/stations/EXTRPI020882.  If you find the issue stopping you sending data the MLAT issue will probably be fixed as well

Alan
Title: Re: MLAT
Post by: derOlli on January 20, 2021, 11:34:28 AM
Hello,

I tried a few days but didn't managed to get MLAT sharing with Radarbox24.
Here is my rbfeeder.ini

Code: [Select]
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=2256b30xxxxxxxxxxxxxxxxxxxxxx

sn=EXTRPI021224

lat=52.1xxxxxx

lon=10.2xxxxx

alt=117

sat_used=0

sat_visible=0

[network]
mode=beast
external_port=30005
external_host=192.168.0.12

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

Any suggestions how I could activate it?
Thanks for your help!
Olli
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 12:01:25 PM
From an earlier post

mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

The cause of failure is wrong version of python in above line of the file  /etc/rbfeeder.ini
The python3.5 was for Raspbian Stretch.
The current version is Buster, which requires python3.7

To fix the problem:
Either change 3.5 to 3.7
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client

OR BETTER

Comment out this line by placing a # at start of line
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

Alan
Title: Re: MLAT
Post by: derOlli on January 20, 2021, 12:58:47 PM
Hey Alan,

thanks for helping me.
I have already tried to command out it with the # (see my code above).
But changing 3.5 to 3.7 seems to working for me.....I´ll check this a few hours.

Thank you
olli
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 01:51:15 PM
Olli

Per reply 74

The rbfeeder has this line built in, and provides it if this lines is commented out. This command starts the mlat-client

Commenting out is better from possible upgrade of rbfeeder in future which may require changing python3.7 to say python3.8 or 3.9 or 4. Commenting it out will force new version of rbfeeder to use correct version built into it.

Alan
Title: Re: MLAT
Post by: derOlli on January 20, 2021, 02:17:05 PM
Thank you Alan, i will change it back to 3.5 and comment it out and check the MLAT status.
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 02:52:19 PM
I suggest you leave it at 3.7 and commented out per Reply 74

Alan
Title: Re: MLAT
Post by: Amameric on January 20, 2021, 03:29:39 PM
So following the best practice and adding a # in front of the line
do I need to move the --results to a new line ????

The line below is how my .ini file reads at present
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30104

i'm using a Airspy2 as my Rx

Thanks
Mark
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 03:37:21 PM
Not as far as I am aware but hopefully someone with more knowleadge can advise

Alan
Title: Re: MLAT
Post by: derOlli on January 20, 2021, 03:43:51 PM
Tried everything but it doesn't work quite well.
The MLAT status swich between:
-Active but not synched
-Active and synched with....(few Stations)
-dissapear completely

Code: [Select]
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxxxxxxxxx

sn=EXTRPI021224

lat=52.xxxx

lon=10.xxxx

alt=117

sat_used=0

sat_visible=0

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

Do i have to add something like "--results beast,listen,30104" ?
Thanks for alle the help!
Olli
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 03:46:51 PM
It will only sync with stations if they are available to sync with and this will change as staton go on and offline

I have no idea regarding Listen

Alan
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 03:52:23 PM
[email protected] may be able to advise further

Alan
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 04:00:09 PM
Hopefully abcd will note the posts and come online later

Alan
Title: Re: MLAT
Post by: Runway 31 on January 20, 2021, 04:04:04 PM
Ollj

I see you have 38 stations synced at this time.  I have no idea why the syncing comes and goes, maybe someone with more knowledge can anser

Alan
Title: Re: MLAT
Post by: abcd567 on January 20, 2021, 10:52:06 PM

Do i have to add something like "--results beast,listen,30104" ?


No, it is not necessary, and RB24 mlat works perfectly well even without it..

However if you are using dump1090-fa or dump1090-mutability, adding above to mlat_cmd  will make RB24's mlat plane also to be displayed on map of dump1090-fa/dump1090-mutability
Title: Re: MLAT
Post by: Amameric on January 21, 2021, 07:11:23 AM
Thanks  @abcd567,
bit confused as yes I am using dump1090-fa so is that a bad thing as i'm also feeding a few other feeders at the same time?
guess i # the line out in the .ini file i will see less aircraft on my map right?
Title: Re: MLAT
Post by: abcd567 on January 21, 2021, 09:38:00 AM
So following the best practice and adding a # in front of the line
do I need to move the --results to a new line ????

The line below is how my .ini file reads at present
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30104

i'm using a Airspy2 as my Rx

Thanks
Mark

Your current configuration is Good, keep it as it is (i.e. keep mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30104)

Mlat setting will be same for generic dongles and AirSpy.
Title: Re: MLAT
Post by: Amameric on January 21, 2021, 09:50:55 AM
Thanks @abc567
you are a true gentleman with all your support you give us
Title: Re: MLAT
Post by: AnthonyHunt on January 26, 2021, 02:40:13 PM
Tried everything but it doesn't work quite well.
The MLAT status swich between:
-Active but not synched
-Active and synched with....(few Stations)
-dissapear completely


I have the same problem.  Looking through the rbfeeder status is appears that it's not receiving replies from RadarBox?

Code: [Select]
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Disconnecting from mlat1.rb24.com:40900: No data (not even keepalives) received for 60 seconds
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Connected to multilateration server at mlat1.rb24.com:40900, handshaking

The startup config looks okay though?

Code: [Select]
   CGroup: /system.slice/rbfeeder.service
           ├─4118 /usr/bin/rbfeeder
           └─4129 /usr/bin/python3.7 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --lat 5x.xxxxxx --lon -2.xxxxxx --alt xx --user EXTRPIxxxxxx


any thoughts?
Title: Re: MLAT
Post by: derOlli on January 27, 2021, 01:49:59 PM
Tried everything but it doesn't work quite well.
The MLAT status swich between:
-Active but not synched
-Active and synched with....(few Stations)
-dissapear completely


I have the same problem.  Looking through the rbfeeder status is appears that it's not receiving replies from RadarBox?

Code: [Select]
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Disconnecting from mlat1.rb24.com:40900: No data (not even keepalives) received for 60 seconds
Jan 26 14:30:13 raspberrypi rbfeeder[4118]: Tue Jan 26 14:30:13 2021 Connected to multilateration server at mlat1.rb24.com:40900, handshaking

The startup config looks okay though?

Code: [Select]
   CGroup: /system.slice/rbfeeder.service
           ├─4118 /usr/bin/rbfeeder
           └─4129 /usr/bin/python3.7 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --lat 5x.xxxxxx --lon -2.xxxxxx --alt xx --user EXTRPIxxxxxx


any thoughts?

Did you already asked the support? I only got a standard answer
That’s ok don’t worry, it will only sync when there is more than 3 stations nearby with MLAT as well.

still have the same problem and no answer.

olli
Title: Re: MLAT
Post by: Runway 31 on January 27, 2021, 04:09:39 PM
I contacted the Development team who has advised me that following me raising the issue they have discovered a performance issue on some of the MLAT servers which they are now resolving.  Should take 1 to 2 hours to resolve

Alan
Title: Re: MLAT
Post by: Amameric on January 27, 2021, 05:23:45 PM
This is good news
As I’ve also been seeing the same problem for months since I started feeding RB MLAT
Do we expect to see fairly constant synced stations from now ?
Title: Re: MLAT
Post by: AnthonyHunt on January 27, 2021, 05:38:35 PM
I contacted the Development team who has advised me that following me raising the issue they have discovered a performance issue on some of the MLAT servers which they are now resolving.  Should take 1 to 2 hours to resolve

Alan

Oh Brilliant. I didn't get that far as I'd assumed that it must be a config issue? As when I was just feeding RB it was fine but as soon as I went FA/PA to RB it failed. was quite surprised when FR, OS & ADSX were working fine.

I'll keep my fingers crossed and keep my eyes on it during the evening.
Title: Re: MLAT
Post by: Runway 31 on January 27, 2021, 06:11:40 PM
I have no idea, like you  I am only a user and I have no idea if it will resolve your specific issue

Alan
Title: Re: MLAT
Post by: AnthonyHunt on January 27, 2021, 07:03:13 PM
Funnily enough, my FA/PA MLAT is glitching tonight. Going up and down like RB.  My status on ADSX seems to be fairly constant.

I know it needs at least three receivers, but RB (when its working) gets 90-100, FA/PA 230? That bit doesn't seem to be a problem!
Title: Re: MLAT
Post by: Runway 31 on January 27, 2021, 07:14:59 PM
Where are you located

Alan
Title: Re: MLAT
Post by: AnthonyHunt on January 27, 2021, 08:20:36 PM
Midlands in the UK.
Title: Re: MLAT
Post by: Runway 31 on January 27, 2021, 08:26:17 PM
You will be seeing a huge reduction in traffic there, I am seeing even less here in central Scotland

Alan
Title: Re: MLAT
Post by: AnthonyHunt on January 27, 2021, 08:48:20 PM
Tell me about it! Although quite enjoying sitting on the flight path of the vaccine run between Brize and Preswick!

Actually why I'd like to get MLAT up and running as a fair amount of low level military (one which squark and ones that don't) and Air Ambulance passes me.

RB MLAT hasn't stabilised yet, still disconnecting. FA/PA (320 stations last time i looked) doing it every hour or so.
Title: Re: MLAT
Post by: Runway 31 on January 28, 2021, 02:41:34 PM
Ollj, your post on the silhouette thread was removed, you may want to add it here

Alan
Title: Re: MLAT
Post by: Amameric on January 28, 2021, 02:48:27 PM
Not seeing any difference in my MLAT station reports, still going from no stations sync to 100's of synced stations!
Title: Re: MLAT
Post by: Runway 31 on January 28, 2021, 03:06:50 PM
There is an ongoing issue with RB at this time I am unable to get online and I have not been able to contact the developers due to this.  There has been a server migration taking place with some stability issues now but work is ongoing to smooth out the issue.  I dont know how this will be affecting your issue

Alan
Title: Re: MLAT
Post by: AnthonyHunt on January 28, 2021, 03:46:26 PM
Mine hasn't stabalised fully. Both FA/PA & RB, everytime I loose aircraft it drops connection and resyncs. RB has just come back up for me so I'll see whar happens.

Update : It's gone back to how it was previsouly, which is a shame as it had been fairly stable most of the day. Maybe they rolled back the changes they made yesterday?
Title: Re: MLAT
Post by: derOlli on January 28, 2021, 04:12:02 PM
Hi,

I asked the support because of my MLAT problem and got a answer but I´m afraid to break my configuration:

Code: [Select]
## Installed required packages (dependencies and build tools)
sudo apt update -y
sudo apt-get install -y git curl build-essential debhelper python-dev python3-dev
 
## Downloaded source code
cd /home/pi/
git clone https://github.com/mutability/mlat-client.git
 
## Built mlat-client's installation package
cd /home/pi/mlat-client
sudo dpkg-buildpackage -b -uc
 
## Above command took some time to build package
## After the package was built, installed it by following command
cd /home/pi/
sudo dpkg -i mlat-client_*.deb
Title: Re: MLAT
Post by: AnthonyHunt on January 28, 2021, 04:25:43 PM
I don't see how that's any different to the version already installed? I checked the version I had and it was already the latest mutability build?

Happy to give it a go...

report back soon.


UPDATE: no change stayed sync'd for about 5m then dropped with the same error in the log. I havd at least 5 aircraft the whole time.
Title: Re: MLAT
Post by: Runway 31 on January 28, 2021, 04:49:35 PM
Until they resolve the issue you wont get a fix

Alan
Title: Re: MLAT
Post by: GlynH on January 29, 2021, 10:49:53 PM
Tell me about it! Although quite enjoying sitting on the flight path of the vaccine run between Brize and Preswick!

Is that why I've been seeing & hearing a lot more A400M than usual flying past my house @10k feet these past few days?

-=Glyn=-
Title: Re: MLAT
Post by: Runway 31 on January 30, 2021, 09:17:35 AM
Nope the Covid flights arrive at Prestwick around 0200 as NPT037K/037F B733 and I believe they are from East Midlands not Brize

Alan
Title: Re: MLAT
Post by: AnthonyHunt on January 31, 2021, 12:14:54 AM
One of the reasons. A few C130 J's doing drops of supplies too.  From what I hear, and could be wrong, they are doing "Hands off" combat type drops - using every opportunity for combat practice.
Title: Re: MLAT
Post by: AnthonyHunt on January 31, 2021, 12:19:12 AM
Nope the Covid flights arrive at Prestwick around 0200 as NPT037K/037F B733 and I believe they are from East Midlands not Brize

Alan

There's a bit more going on. Yes, vacinne itself is being delivered in "landed" flights. Depends on which of the two manufactoring sites. Brize is obviously next door to Oxford plant. Other supplies are arriving as my prvious post. Although I'm only informed by the RT that i hear.

Out of interest and totally OT... Pfizer has been arriving from Belgium to Liverpool on an Antonov AN-26 (circa 10pm?) followed by a Typhoon flypast. Seen it a few times now.
Title: Re: MLAT
Post by: Runway 31 on January 31, 2021, 01:21:05 PM
Ah the NPT flights are covid samples being delivered to the lighthouse lab for processing.  I am not aware of any RAF A400 or C30J flights into Prestwick or Glasgow, none appearing on the movements anyway apart from the odd A400 doing overshoots training

Alan
Title: Re: MLAT
Post by: AnthonyHunt on February 01, 2021, 08:38:37 PM
Still no change with the MLAT YoYo'ing... There was an update to mlat-client yesterday but that didn't help anything.  Guess the folks at AirNav are working on sorting their migration problem first.
Title: Re: MLAT
Post by: Runway 31 on February 01, 2021, 09:49:36 PM
They are trying to find a fix, no timescale given.  Not linked to the migration issue which is now fixed

Alan