AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Windows 8  (Read 7264 times)

0 Members and 1 Guest are viewing this topic.

FraserSoft

  • New Member
  • *
  • Posts: 11
    • Alec's Place
Windows 8
« on: June 01, 2012, 12:57:03 PM »
Has anyone got Airnav Radarbox working in the latest build of Windows 8 Release Preview Build 8400 ? I have installed the updates but it will not let me install the 64 bit drivers and the program doesn't work. I realise that this is a pre release version of Windows 8 but all my other programs work okay including 2 Winradio SDR boxes.
Thanks
Alec
« Last Edit: June 01, 2012, 04:58:06 PM by FraserSoft »

BadWolf

  • New Member
  • *
  • Posts: 23
Re: Windows 8
« Reply #1 on: June 02, 2012, 03:09:01 AM »
Alec, I have  my RB running on the 32 bit version (build 8250), but like you I have had no success loading the drivers for the 64 bit version. Frankly, I would not recommend anyone try it unless you put it on a separate partition. My primary laptop cannot run the R now.

pjm

  • RadarBox Beta Testers
  • Sr. Member
  • *
  • Posts: 477
Re: Windows 8
« Reply #2 on: June 02, 2012, 04:54:01 AM »
Has anyone got Airnav Radarbox working in the latest build of Windows 8 Release Preview Build 8400 ? I have installed the updates but it will not let me install the 64 bit drivers and the program doesn't work.

I'm running 64bit Win8 Release Preview it in a Virtual Machine, and can install and run ANRB, it recognises the hardware Radarbox, but I get no flights displayed. YMMV.

If you have some real hardware it may work.

You can load the 64 bit drivers if you disable driver signing first.
This allowed me to load the drivers for ANRB

to disable driver signing:

  • From the Metro Start Screen, open Settings (move your mouse to the bottom-right-corner of the screen and wait for the pop-out bar to appear, then click the Gear icon).
  • Click ‘Change PC Settings’.
  • Click ‘General’.
  • Scroll down, and click ‘Restart now’ under ‘Advanced startup’.
  • Click ‘Troubleshoot’.
  • Click ‘Advanced Options’
  • Click ‘Startup Settings’
  • Click Restart.
  • When Win8 restarts type the number next to "Disable driver signature enforcement"
(Its number 7 on my virtual machine)

Then you can install the 64 bit driver.













BadWolf

  • New Member
  • *
  • Posts: 23
Re: Windows 8
« Reply #3 on: June 02, 2012, 11:44:21 AM »
Thanks, that did the track and I am receiving flights as well.

pjm

  • RadarBox Beta Testers
  • Sr. Member
  • *
  • Posts: 477
Re: Windows 8
« Reply #4 on: June 02, 2012, 11:45:43 AM »
Thanks, that did the track and I am receiving flights as well.

nw - I got it "sort of" working in a VM using a different USB port as well :)


FraserSoft

  • New Member
  • *
  • Posts: 11
    • Alec's Place
Re: Windows 8
« Reply #5 on: June 03, 2012, 06:49:15 PM »
Thanks for the suggestions, I am not sure what build you are using so for now I have swapped drives and got back to Windows 7.

FraserSoft

  • New Member
  • *
  • Posts: 11
    • Alec's Place
Re: Windows 8
« Reply #6 on: June 05, 2012, 06:57:44 PM »
Now back playing with Windows 8 Build 8400 and many thanks to pjm I followed the instructions and Radar Box is now working properly.