anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: RBFeeder Update Fails  (Read 3739 times)

0 Members and 1 Guest are viewing this topic.

bigchin67

  • New Member
  • *
  • Posts: 8
RBFeeder Update Fails
« on: February 09, 2024, 08:10:33 AM »
When I check my rbfeed site https://www.radarbox.com/stations/EXTRPI004512 I get a message that my RBFeed needs updating on my Raspberry Pi.
When I run sudo apt-get update I see the following error:

Hit:5 https://apt.rb24.com buster InRelease
Err:5 https://apt.rb24.com buster InRelease
  The following signatures were invalid: EXPKEYSIG F2A8428D3C354953 AirNav Systems <[email protected]>
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://apt.rb24.com buster InRelease: The following signatures were invalid: EXPKEYSIG F2A8428D3C354953 AirNav Systems <jceara @  airnavsystems.com>
W: Failed to fetch https://apt.rb24.com/dists/buster/InRelease  The following signatures were invalid: EXPKEYSIG F2A8428D3C354953 AirNav Systems <jceara  @  airnavsystems.com>
W: Some index files failed to download. They have been ignored, or old ones used instead.


I can't update and my feed seems to be down. Anyone got ideas?

Patrius

  • New Member
  • *
  • Posts: 4
Re: RBFeeder Update Fails
« Reply #1 on: February 09, 2024, 10:38:53 AM »
Got the same messages

abcd567

  • Hero Member
  • *****
  • Posts: 862
  • CYYZ - Toronto
Re: RBFeeder Update Fails
« Reply #2 on: February 09, 2024, 01:38:14 PM »

When I run sudo apt-get update I see the following error:

Hit:5 https://apt.rb24.com buster InRelease
Err:5 https://apt.rb24.com buster InRelease
  The following signatures were invalid: EXPKEYSIG F2A8428D3C354953 AirNav Systems <[email protected]>

I can't update and my feed seems to be down. Anyone got ideas?


Try this

Code: [Select]
gpg --keyserver keyserver.ubuntu.com --recv-keys F2A8428D3C354953   

gpg --export --armor F2A8428D3C354953 | sudo apt-key add -   


CAUTION: In the last command above, do not miss the minus ( - ) sign at the end after word "add"

NEXT:
Code: [Select]

sudo apt-get update   

sudo apt-get install rbfeeder   










« Last Edit: February 09, 2024, 06:34:43 PM by abcd567 »

G6LSD

  • New Member
  • *
  • Posts: 3
Re: RBFeeder Update Fails
« Reply #3 on: February 10, 2024, 05:30:57 PM »
Hi,

It worked for me!

Thank you

bigchin67

  • New Member
  • *
  • Posts: 8
Re: RBFeeder Update Fails
« Reply #4 on: February 12, 2024, 05:30:46 AM »
I ended up doing a complete rebuild of my Pi OS and installed Bookworm after Radarbox support told me that buster is old and should be upgraded.

PiAware installed on Bookworm no problem.
FR24Feed works OK, taking the network feed from dump1090-fa

When installing RBFeeder I still needed to follow abcd567's instructions above to get the gpg key fix but after that it worked.
RadarBox doesn't have a Bookworm package so I followed instructions again from abcd567 here to install a bullseye build: https://forum.radarbox24.com/index.php?topic=107991.0

Now all 3 feeds are up and running on Bookworm. Kudos to @abcd567

Patrius

  • New Member
  • *
  • Posts: 4
Re: RBFeeder Update Fails
« Reply #5 on: February 14, 2024, 09:38:53 AM »
Thank you that worked.
(I cannot quote message says something like forbidden  install javascript ???)

Popeye

  • New Member
  • *
  • Posts: 4
Re: RBFeeder Update Fails
« Reply #6 on: May 12, 2024, 06:49:52 PM »
Hi,

It worked for me!

Thank you
Perfect Worked like a charm!!!Thank you .
Needed also  to do systemctl daemon-reload and all worked well!