AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM  (Read 3638 times)

0 Members and 1 Guest are viewing this topic.

abcd567

  • Hero Member
  • *****
  • Posts: 844
  • CYYZ - Toronto
Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« on: December 28, 2023, 09:37:55 AM »
EDIT: March 02, 2024
This workaround is no more required.

Click Here to see details

======================================================
======================================================


It is quiet some time that Raspberry Pi Organization has released its OS Bookworm, but the Radarbox24 Software Developers have not yet released rbfeeder and mlat-client for it.

==================================
(A) Installing rbfeeder on Bookworm
==================================

As the Bullseye version of rbfeeder works perfectly OK on Bookworm, I have used following workaround to install the Bullseye version of rbfeeder on Bookworm. This workaround is to do a very simple modification in the installation script, which makes the script believe that your OS is bullseye, and consequently it installs rbfeeder package for Bullseye on your Bookworm.

(1) Download the installation script by following command:
Code: [Select]
wget http://apt.rb24.com/inst_rbfeeder.sh 


(2) Open the downloaded file by following command
Code: [Select]
sudo nano inst_rbfeeder.sh


In the file opened, scroll down to the line starting with VERS=
Please see screenshot below



Just below the line starting with VERS=, add following new line
VERS=bullseye
Please see screenshot below



Save file (Ctrl + O) and Close file (Ctrl+X)

Issue following command to run the installer and complete installation.
Code: [Select]

sudo bash inst_rbfeeder.sh



NOTE: Sometimes it may happen that the script runs and at the end showa that rbfeeder has been installed, while actually rbfeeder is not installed

This is caused by RB24's unsigned repository.
E: The repository 'https://apt.rb24.com bullseye InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
sudo: rbfeeder: command not found

If you face above noted problem, then work-around is as follows

(1) Open file rb24.list by following command:
Code: [Select]

sudo nano /etc/apt/sources.list.d/rb24.list 


In the file opened you will see following:



(2) There is only one line starting with word deb and followed by https.
Between deb and https, add following:
[trusted=yes]
The file will become like below:



(3) Save and Close file. Next run following commands. The rbfeeder will now be installed successfully.

Code: [Select]

sudo apt install rbfeeder   

sudo rbfeeder --setkey xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

##Replace xxxxxxxxxxxxxxxxxxxxx by your actual key

## Above command will makes rbfeeder to start and announce key is accepted
## Next press Ctrl and C Keys together to get comand prompt
 
sudo systemctl restart rbfeeder   



=============================================
(B) Building and Installing mlat-client on Bookworm
=============================================


System wide Installation (Recommended Standard Method)

Code: [Select]

sudo apt install -y git debhelper dh-python python3-dev python3-setuptools 

git clone https://github.com/mutability/mlat-client 

cd mlat-client   

sudo dpkg-buildpackage -b  --no-sign   

cd ../ 

sudo dpkg -i mlat-client_0.2.13_*.deb 

sudo apt-mark hold mlat-client 



NOTE:
For mlat to work, you must do following:

(1) Open file rbfeeder.ini for editing
Code: [Select]

sudo nano /etc/rbfeeder.ini   


(2) Add following lines under [client] in above file

lat=xx.xxxx
lon=yy.yyyy
alt=zzz


Replace xx.xxxx, yy.yyyy, and zzz by their actual values.
The zzz is elevation above sea level in meters.

Save file, then Reboot Pi

Please see screenshot attached below.
.
« Last Edit: March 02, 2024, 01:24:09 PM by abcd567 »

ramon.cutanda

  • New Member
  • *
  • Posts: 3
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #1 on: January 31, 2024, 09:38:49 PM »
Thanks a lot! I has holding the update to Bookworm on my Raspberry Pi 4 because OS upgrades are never smooth. Reading this post encouraged me to try and after following the detailed instructions it worked like a charm. Thank you once again.
Regards,
« Last Edit: January 31, 2024, 09:40:44 PM by ramon.cutanda »

abcd567

  • Hero Member
  • *****
  • Posts: 844
  • CYYZ - Toronto
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #2 on: March 02, 2024, 01:09:25 PM »
Today (March 02, 2024), I checked and found that the Radarbox24 has added following to their BOOKWORM repository

(1) rbfeeder ver 1:1.0.10+bullseye
(2) mlat-client ver 0.2.13

Please see attached screenshot below.

As a result, the work-around in First post of this thread is no more required.
Now on RaspberryPi OS Bookworm, the rbfeeder and mlat-client can be installed by following normal commands:

(1) To install rbfeeder:
Code: [Select]

sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"


(2) AFTER running above script, install mlat-client
Code: [Select]

sudo apt install mlat-client


« Last Edit: March 07, 2024, 02:23:49 PM by abcd567 »

Oldfella

  • New Member
  • *
  • Posts: 1
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #3 on: March 22, 2024, 10:52:27 PM »
Many thanks once again ABCD567 for all your input in the various software programmes that helps to make us enjoy this hobby.

I have been waiting for some announcement from Radarbox to run this on Bookworm OS and you with your 2nd March post, has fixed this situation. Nice to be up and running once again.

Best wishes,

Oldfella