AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Sharing stats shows "offline"  (Read 4482 times)

0 Members and 2 Guests are viewing this topic.

glen4cindy2

  • New Member
  • *
  • Posts: 17
Sharing stats shows "offline"
« on: August 05, 2023, 03:20:58 PM »
I'm having an issue where my sharing status has been showing as a red line for several hours.

When I browse to my station URL I am seeing planes. My account status is still showing as "business" and I am not receiving email messages indicating they are not receiving data.

I've restarted my Raspberry Pi, and I've restarted rbfeeder as well.

If I ssh into the Pi and issue the command: sudo systemctl status rbfeeder this is my output:

● rbfeeder.service - RBFeeder Service
     Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2023-08-05 10:04:12 CDT; 2min 29s ago
    Process: 7614 ExecStartPre=/bin/mkdir /var/run/rbfeeder (code=exited, status=1/FAILURE)
    Process: 7615 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 7616 ExecStartPre=/bin/touch /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 7617 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 7618 ExecStartPre=/bin/chown rbfeeder:rbfeeder /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
    Process: 7619 ExecStartPre=/bin/setfacl -m u:www-data:rwx /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
   Main PID: 7620 (rbfeeder)
      Tasks: 9 (limit: 1598)
        CPU: 1.495s
     CGroup: /system.slice/rbfeeder.service
             └─7620 /usr/bin/rbfeeder

Aug 05 10:05:12 raspberrypi rbfeeder[7620]: [2023-08-05 10:05:12]  Data sent: 67 B
Aug 05 10:05:12 raspberrypi rbfeeder[7620]: [2023-08-05 10:05:12]  Data received: 28 B
Aug 05 10:05:23 raspberrypi rbfeeder[7620]: [2023-08-05 10:05:23]  Connection established.
Aug 05 10:05:23 raspberrypi rbfeeder[7620]: [2023-08-05 10:05:23]  Client type: Raspberry Pi
Aug 05 10:05:23 raspberrypi rbfeeder[7620]: [2023-08-05 10:05:23]  Connection with RadarBox24 server OK! Key accepted by server.
Aug 05 10:05:23 raspberrypi rbfeeder[7620]: [2023-08-05 10:05:23]  This is your station serial number: EXTRPI001018
Aug 05 10:06:13 raspberrypi rbfeeder[7620]: [2023-08-05 10:06:13]  ******** Statistics updated every 60 seconds ********
Aug 05 10:06:13 raspberrypi rbfeeder[7620]: [2023-08-05 10:06:13]  Packets sent in the last 60 seconds: 670, Total packets sent since sta>
Aug 05 10:06:13 raspberrypi rbfeeder[7620]: [2023-08-05 10:06:13]  Data sent: 23.0 KB
Aug 05 10:06:13 raspberrypi rbfeeder[7620]: [2023-08-05 10:06:13]  Data received: 59 B

Do I need to be concerned about this or is there some issue going on?

Thanks in advance.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33841
Re: Sharing stats shows "offline"
« Reply #1 on: August 06, 2023, 01:45:11 PM »
I presume that it is an issue at the server end with the statistic script.  That fact that you are seeing aircraft on your feed shows that you are online so nothing to worry about.  It will be fixed and all will be ok

Just looked at your station, all ok, no red so I presume that it has already been fixed

Alan
« Last Edit: August 06, 2023, 01:50:50 PM by Runway 31 »

pedrão18

  • New Member
  • *
  • Posts: 18
Re: Sharing stats shows "offline"
« Reply #2 on: August 06, 2023, 04:52:25 PM »
I am also having this same problem.
My station shows offline since yesterday, however nothing in the logs shows any connection errors and it is sending data normally
« Last Edit: August 06, 2023, 08:05:56 PM by pedrão18 »

glen4cindy2

  • New Member
  • *
  • Posts: 17
Re: Sharing stats shows "offline"
« Reply #3 on: August 06, 2023, 07:38:57 PM »
I presume that it is an issue at the server end with the statistic script.  That fact that you are seeing aircraft on your feed shows that you are online so nothing to worry about.  It will be fixed and all will be ok

Just looked at your station, all ok, no red so I presume that it has already been fixed

Alan

Thanks Alan.

I'm still red but I appreciate you looking into this for me.

Glen

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33841
Re: Sharing stats shows "offline"
« Reply #4 on: August 06, 2023, 08:22:40 PM »
Dont know where its red Glen its all green here, see attached

Where are you seeing red?

Alan

glen4cindy2

  • New Member
  • *
  • Posts: 17
Re: Sharing stats shows "offline"
« Reply #5 on: August 10, 2023, 09:17:16 PM »
Dont know where its red Glen its all green here, see attached

Where are you seeing red?

Alan

It's not showing red anymore. It was when I posted this issue.

The bottom row had a small blip of red that grew longer and longer.

All of a sudden it was all green again.

It must have been a glitch.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33841
Re: Sharing stats shows "offline"
« Reply #6 on: August 11, 2023, 09:25:46 AM »
When the script has an issue and goes red, after it is fixed it goes green

Alan