AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Raspberry Pi RadarBox installation woes - help appreciated  (Read 1234 times)

0 Members and 1 Guest are viewing this topic.

tgo

  • New Member
  • *
  • Posts: 9
Raspberry Pi RadarBox installation woes - help appreciated
« on: February 24, 2020, 01:53:42 PM »
Hi,
I feed to a number of sites using the FlightAware pro dongle and piaware as my 1090 base.

I've attempted to set up RBox and only been semi successful.

I have a share code and receiver name/no
https://www.radarbox24.com/stations/EXTRPI007300

Only thing is...
I have 0nmiles range and no planes showing. I tried the RBox support but not really got anywhere, pretty sure its some sort of config error on my part.

Here is my rbfeeder.ini

[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=******

sn=EXTRPI007300

lat=52.387768

lon=-2.224405

alt=111

sat_used=0

sat_visible=0

[network]

mode=beast
external_port=32088
external_host=192.168.68.106

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

and here is some of my recent log output:
[2020-02-24 13:49:25]  Starting RBFeeder Version 0.3.3 (build 20200203195559)
[2020-02-24 13:49:25]  Using configuration file: /etc/rbfeeder.ini
[2020-02-24 13:49:25]  Network-mode enabled.
[2020-02-24 13:49:25]        Remote host to fetch data: 192.168.68.107
[2020-02-24 13:49:25]        Remote port: 32088
[2020-02-24 13:49:25]        Remote protocol: BEAST
[2020-02-24 13:49:25]  Could not start service Raw TCP input: no port specified.
[2020-02-24 13:49:25]  System: raspberry
[2020-02-24 13:49:25]  Start date/time: 2020-02-24 13:49:25
[2020-02-24 13:49:25]  Socket for ANRB created. Waiting for connections on port 32088
[2020-02-24 13:49:26]  Connection established.
[2020-02-24 13:49:28]  TCP Client (ANRB) requesting to connect...
[2020-02-24 13:49:28]  [Slot 0] New ANRB connection from IP 192.168.68.107, remote port 47308, socket: 10

Anyone able to help?

I've tried using RAW, beast, tried changing various port no's. It just isn't sending data up to RBox.

I'm also a bit unclear why I need to specify current raspberry local ip, other configs let me put in 127.0.0.1 which is good as my ip will change on each router reboot.

« Last Edit: February 24, 2020, 04:13:28 PM by Runway 31 »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 29478
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #1 on: February 24, 2020, 03:03:58 PM »
While you wait on someone who knows about Pi's have a read at https://forum.radarbox24.com/index.php?topic=10201.msg187831#msg187831

Also this one https://forum.radarbox24.com/index.php?topic=102881.0

abcd is the person to help and I am sure he will be along later

Alan
« Last Edit: February 24, 2020, 03:10:47 PM by Runway 31 »

tgo

  • New Member
  • *
  • Posts: 9
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #2 on: February 24, 2020, 04:07:56 PM »
Thanks for that.

I appear to have fixed it somehow however.

I installed (again) the rbfeeder
sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"

then edited the .ini to read the same as in the Bake a Pi thread so changed:

external_port                  = 30005
external_host                  = 127.0.0.1

then restarted the software.
sudo systemctl restart rbfeeder

now it's showing planes and a range, so somehow (God knows how) it's working :)
and it's not broken the other 3 sites I feed to as well, so hopefully all is well, maybe abcd can just cast an eye over it and see if it's good now.




Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 29478
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #3 on: February 24, 2020, 04:12:51 PM »
Yes see you up from Kidderminster, well done.  Building nicely.

BTW not a good idea to show your key so I have removed it from your post

Alan

tgo

  • New Member
  • *
  • Posts: 9
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #4 on: February 24, 2020, 05:08:48 PM »
OOPs, thanks for that.

abcd567

  • Sr. Member
  • ****
  • Posts: 344
  • CYYZ - Toronto
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #5 on: February 24, 2020, 05:42:25 PM »

[client]
network_mode=true


[network]
mode=beast
external_port=32088
external_host=192.168.68.106

Glad to know you found and fixed the configuration error yourself.

The wrong port number was the cause of problem.
With "network_mode=true", the rbfeeder uses output of dump1090-fa, which is available on port 30005, and not 32088.

Also do not use actual IP of Pi as it may change on reboot. Use 127.0.0.1 which loops back Pi to itself irrespective of its actual IP

tgo

  • New Member
  • *
  • Posts: 9
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #6 on: February 24, 2020, 07:41:29 PM »
Ah good, the RBox instructions were not terribly clear, good to know it's all done now.

tgo

  • New Member
  • *
  • Posts: 9
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #7 on: June 09, 2020, 09:08:10 AM »
Issues again.

After working superbly since February, its all just stopped. (Other sites are ok) it lost connection from yesterday, I don't even have anything in my rbfeeder.ini file anymore.

How the heck am I supposed to find my sharing key for station EXTRPI (or 1) 007300

This is the output from:apt policy rbfeeder

rbfeeder:
  Installed: 0.3.4-20200423004254
  Candidate: 0.3.4-20200423004254
  Version table:
 *** 0.3.4-20200423004254 500
        500 https://apt.rb24.com buster/main armhf Packages
        100 /var/lib/dpkg/status
[email protected]:~ $

and the output from: sudo systemctl status rbfeeder

* rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset:
   Active: failed (Result: exit-code) since Tue 2020-06-09 09:33:49 BST; 30min a
  Process: 701 ExecStart=/usr/bin/rbfeeder (code=exited, status=1/FAILURE)
 Main PID: 701 (code=exited, status=1/FAILURE)

Jun 09 09:33:49 raspberrypi systemd[1]: rbfeeder.service: Service RestartSec=100
Jun 09 09:33:49 raspberrypi systemd[1]: rbfeeder.service: Scheduled restart job,
Jun 09 09:33:49 raspberrypi systemd[1]: Stopped RBFeeder Service.
Jun 09 09:33:49 raspberrypi systemd[1]: rbfeeder.service: Start request repeated
Jun 09 09:33:49 raspberrypi systemd[1]: rbfeeder.service: Failed with result 'ex
Jun 09 09:33:49 raspberrypi systemd[1]: Failed to start RBFeeder Service.


cat /etc/rbfeeder.ini  shows:

nothing.

----

I figure I can most likely reinstall, but with no sharecode, that's going to cause an issue.

Any ideas?



tgo

  • New Member
  • *
  • Posts: 9
Re: Raspberry Pi RadarBox installation woes - help appreciated
« Reply #8 on: June 09, 2020, 09:23:47 AM »
OK, all fixed (phew) I got my sharecode from the original email, and I copied across my rbfeeder.ini from my comments here back up the thread, and it's working again.

Still curious as to why it stopped though (other sites are still ok) I have updated the pi a few times recently. Usual stuff

sudo apt-get update
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get upgrade

etc.

Strange.

I HAVE, HOWEVER, MADE A MANUAL BACKUP OF THE RBFEEDER.INI & SHARECODE - JUST IN CASE :D