AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Setting up Raspberry PI connecting to receiver and not the network.  (Read 307 times)

0 Members and 1 Guest are viewing this topic.

cigarsnvball

  • New Member
  • *
  • Posts: 3
I am trying to configure my PI to feed to this site but have not been able to configure it out. According to Alex at customer support my configuration is trying to connect to the receiver but it should be using the network. It is a Flight Aware Prostick plus receiver. I am successfully feeding to Flightradar24 and ADSB Exchange but can't get this one figured out. Any help would be appreciated.
« Last Edit: February 15, 2020, 03:33:38 AM by cigarsnvball »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 28633
Re: Setting up Raspberry PI connecting to receiver and not the network.
« Reply #1 on: February 15, 2020, 08:38:18 AM »
While waiting on someone who knows about Pi's, have a look at these threads for assistance

https://forum.radarbox24.com/index.php?topic=10201.msg187831#msg187831
https://forum.radarbox24.com/index.php?topic=101751.15

Alan

abcd567

  • Sr. Member
  • ****
  • Posts: 296
  • CYYZ - Toronto
Re: Setting up Raspberry PI connecting to receiver and not the network.
« Reply #2 on: February 21, 2020, 02:57:18 AM »
Which image you have written to your microSD card (Raspbian image, or Piaware sd card image, or Pi24 image)?

Irrespective of your image, as you are successfully feeding other sites, you already have one of the decoder installed (either dump1090-fa or dum1090-mutability). This decoder will grab the receiver (prostick) at boot.

The rbfeeder can be run in two modes
(1) network_mode=true, and in this case it uses data from already running dump1090
(2) network_mode=false, and in this case it starts its own integral dump1090 which tries to use receiver prostick.

As you already have a dump1090 running & using receiver, the setting network=false results in failure of rbfeeder's built-in dump1090.

Therefore in your case you must use setting network_mode=true.


Code: [Select]
sudo nano /etc/rbfeeder.ini

The bove command will open file whose contents are given below. Make sure your settings are same as those shown in red.


[client]
network_mode                   = true
log_file                       = /var/log/rbfeeder.log
key                            = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
sn                             = EXTRPIxxxxxx

[network]
mode                           = beast
external_port                  = 30005
external_host                  = 127.0.0.1

[mlat]

« Last Edit: February 21, 2020, 03:05:03 AM by abcd567 »

cigarsnvball

  • New Member
  • *
  • Posts: 3
Re: Setting up Raspberry PI connecting to receiver and not the network.
« Reply #3 on: February 21, 2020, 03:21:44 AM »
Wow great information. Thank you very much. I take that information and see what I can do.  Thanks again.

abcd567

  • Sr. Member
  • ****
  • Posts: 296
  • CYYZ - Toronto
Re: Setting up Raspberry PI connecting to receiver and not the network.
« Reply #4 on: February 21, 2020, 03:49:24 AM »
Wow great information. Thank you very much. I take that information and see what I can do.  Thanks again.

Configuration information is available in the  Bake a Pi thread. Moderator Runway31 has posted link to it in his above post.

It seems that either you did not visit it, or if you did visit it, you were not able to dig out required info from the heap of information there.

« Last Edit: February 21, 2020, 06:02:06 AM by abcd567 »

cigarsnvball

  • New Member
  • *
  • Posts: 3
Re: Setting up Raspberry PI connecting to receiver and not the network.
« Reply #5 on: February 21, 2020, 05:28:02 AM »
I a sure that I was just not able to interpret what I read. I purchased a preconfigured Flight Aware Pro Stick that had preloaded software. I have stumbled my way through to this point. I have never used Linux before. It took me a few weeks just to figure out how to SSH. I followed the steps to get it up and running. I think that I did it incorrectly and that I need to undue whatever I did.

abcd567

  • Sr. Member
  • ****
  • Posts: 296
  • CYYZ - Toronto
Re: Setting up Raspberry PI connecting to receiver and not the network.
« Reply #6 on: February 21, 2020, 12:43:05 PM »
I think that I did it incorrectly and that I need to undue whatever I did.

if it ain't broke, dont fix it.

If everything is working ok, dont redo.
However if you decide to redo, then I will recommend OPTION-2 of Bake a Pi thread:

https://forum.radarbox24.com/index.php?topic=10201.msg187851#msg187851

Next step is to install other feeders:

http://www.airnavsystems.com/forum/index.php?topic=10201.msg187901#msg187901

.
« Last Edit: February 21, 2020, 12:46:18 PM by abcd567 »