AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: MLAT - FR24+DUMP1090 to RadarBox24 FEEDER  (Read 308 times)

0 Members and 1 Guest are viewing this topic.

MatheusMoraes

  • New Member
  • *
  • Posts: 2
MLAT - FR24+DUMP1090 to RadarBox24 FEEDER
« on: October 09, 2020, 01:35:02 PM »
Guys help me!

I've a raspberry pi 3 A+ running a FR24 feed with dump1090 mutability. I recent installed RadarBox24 feeder with network mode off. It work for a while and MLAT was active and running. Some days later I got a issue, the rb24 was conflicting with fr24, so I turned rb24 network mode ON using the following:

sudo rbfeeder --set-network-mode on --set-network-host 192.168.0.101 --set-network-port 30005 --set-network-protocol raw --no-start

FR24 and RB24 are now working well since a while, but I notice that RB24 is no longer feeding MLAT even the option is ON:

[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxx

sn=EXTRPI013363

[network]
mode=raw
external_port=30005
external_host=192.168.0.101

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

Please is there a way to make MLAT work again????

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 29589
Re: MLAT - FR24+DUMP1090 to RadarBox24 FEEDER
« Reply #1 on: October 09, 2020, 02:27:29 PM »
Matheus

I know nothing about Pi's but from this thread the poster had the same issue https://forum.radarbox24.com/index.php?topic=103851.0  and he was advised

Change true by false as shown below

[mlat]
autostart_mlat=true  false
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

Save file.
Restart rbfeeder

sudo systemctl restart rbfeeder

Alan

MatheusMoraes

  • New Member
  • *
  • Posts: 2
Re: MLAT - FR24+DUMP1090 to RadarBox24 FEEDER
« Reply #2 on: October 09, 2020, 02:45:28 PM »
Thanks Runway31. But actually the post you mentioned is trying to unninstall/remove RB MLAT. In my case I am looking for a way to MLAT to work. It used to work nice when configured network mode OFF. Since I changed to network mode ON the feeder is just getting ADS-B data. I'd like to know if there is some configuration about using RB with network ON that makes MLAT to work again.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 29589
Re: MLAT - FR24+DUMP1090 to RadarBox24 FEEDER
« Reply #3 on: October 09, 2020, 03:03:28 PM »
Told you I didnt know anything regarding Pi's.  See https://forum.radarbox24.com/index.php?topic=101771.0  One of the later posts states

There are two things required to be done:
(1) Install mlat-client,
(2) Set your latitude, longitude and antenna elevation. Did you do it? If not it can be done in any one of the two ways:
(a) Add these in file /etc/rbfeeder.ini
OR
(b) Go to your RB24 map on internet and add it there.

Both the above methods are described in STEP-2 of this post:
https://forum.radarbox24.com/index.php?topic=101771.msg389571#msg389571

Alan

abcd567

  • Sr. Member
  • ****
  • Posts: 365
  • CYYZ - Toronto
Re: MLAT - FR24+DUMP1090 to RadarBox24 FEEDER
« Reply #4 on: October 09, 2020, 09:29:55 PM »
To enable MLAT, you have to:
(1) Make sure in file /etc/rbfeeder.ini :

(a) under [client] add your latitude, longitude and elevation (meters above sea level) as follows

lat=xx.xxxx
lon=yy.yyyy
alt=zzz

(b) the line autostart_mlat is set to true, as shown below:

[mlat]
autostart_mlat=true

(2) Install mlat-client
Code: [Select]

sudo apt install mlat-client 

sudo reboot 

« Last Edit: October 09, 2020, 09:38:13 PM by abcd567 »

Dutchy

  • New Member
  • *
  • Posts: 1
Re: MLAT - FR24+DUMP1090 to RadarBox24 FEEDER
« Reply #5 on: Today at 02:48:37 PM »
Hello all,

I am trying to install the Flat client. Read all posts here. This is my breeder.ini file:

[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxx

sn=EXTRPxxxxx

lat=52.509113

lon=6.110756

alt=20

sat_used=0

sat_visible=0

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client--results beast,listen,30104

[dump978]
#dump978_enabled=true

Added --results beast,listen,30104 in my file as suggested.

When I run the command python _V it gives me

Python 2.7.16

So my guess is, that something is not right.

Does anyone has an idea?  If I have to upgrade my buster to 3.7 how to do it, as I read there is already a version 3.8

In my flightless I can see the green Meat, but I do not see a line that I am sync to any MLAT feeders

Thanks
« Last Edit: Today at 02:51:02 PM by Dutchy »