AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: AirNav Box died... Again!  (Read 3525 times)

0 Members and 1 Guest are viewing this topic.

ukv1290

  • Jr. Member
  • **
  • Posts: 57
AirNav Box died... Again!
« on: August 26, 2010, 04:08:01 AM »
Hi All,

Wondering if anyone has had a similar problem I plug my airnav box into the PC and hear the windows ding dong to recognize its attached then the disconnect noise comes on then the connect then the disconnect and so on realize it looks like something is loose on the USB cable try it with a different one same issue! and another same issue! - Any ideas how much a repair is? - Over a year old but quite disappointing :-( - Any help/Advice would be amazing!

PS - The power light comes on and the blue light flashes about once a second

Thanks

Tom
« Last Edit: August 26, 2010, 04:12:32 AM by ukv1290 »

DaveReid

  • Hero Member
  • *****
  • Posts: 1815
    • Heathrow last 100 ADS-B arrivals
Re: AirNav Box died... Again!
« Reply #1 on: August 26, 2010, 06:39:18 AM »
Any help/Advice would be amazing!

I would try reinstalling the software, and if that doesn't work, try another PC if possible to see if the same thing happens.
This post has been scanned for any traces of negativity, bias, sarcasm and general anti-social behaviour

RobinB

  • Jr. Member
  • **
  • Posts: 69
Re: AirNav Box died... Again!
« Reply #2 on: August 26, 2010, 07:22:31 AM »
I would reinstall software as dave says.


They do offer a 2 year guarantee.

bearcat

  • Full Member
  • ***
  • Posts: 197
Re: AirNav Box died... Again!
« Reply #3 on: August 26, 2010, 07:49:03 AM »
When you reconnected your box to the pc did you use the same USB port as before or another one. If another one you will have to install the drivers again.

ukv1290

  • Jr. Member
  • **
  • Posts: 57
Re: AirNav Box died... Again!
« Reply #4 on: August 26, 2010, 07:51:59 AM »
Thanks guys, will try suggestions above and let you know how I get on :-)

Tom

ukv1290

  • Jr. Member
  • **
  • Posts: 57
Re: AirNav Box died... Again!
« Reply #5 on: August 27, 2010, 08:30:19 PM »
Hmm still no luck :-(

RobinB

  • Jr. Member
  • **
  • Posts: 69
Re: AirNav Box died... Again!
« Reply #6 on: August 27, 2010, 09:40:32 PM »
have you also reinstalled the drivers ?

(and latest version )

AirNav Support

  • AirNav Systems
  • Hero Member
  • *****
  • Posts: 4127
Re: AirNav Box died... Again!
« Reply #7 on: August 27, 2010, 09:47:54 PM »
Go through these steps

http://www.airnavsystems.com/RadarBox/help/hardware_connection.htm

It does sound like the drivers are not installed.
Contact Customer/Technical support via:
http://www.airnavsystems.com/contact.html
[email protected]