AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM  (Read 4843 times)

0 Members and 1 Guest are viewing this topic.

abcd567

  • Hero Member
  • *****
  • Posts: 857
  • CYYZ - Toronto
Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« on: December 28, 2023, 09:37:55 AM »
EDIT: March 02, 2024
This workaround is no more required.

Click Here to see details

======================================================
======================================================


It is quiet some time that Raspberry Pi Organization has released its OS Bookworm, but the Radarbox24 Software Developers have not yet released rbfeeder and mlat-client for it.

==================================
(A) Installing rbfeeder on Bookworm
==================================

As the Bullseye version of rbfeeder works perfectly OK on Bookworm, I have used following workaround to install the Bullseye version of rbfeeder on Bookworm. This workaround is to do a very simple modification in the installation script, which makes the script believe that your OS is bullseye, and consequently it installs rbfeeder package for Bullseye on your Bookworm.

(1) Download the installation script by following command:
Code: [Select]
wget http://apt.rb24.com/inst_rbfeeder.sh 


(2) Open the downloaded file by following command
Code: [Select]
sudo nano inst_rbfeeder.sh


In the file opened, scroll down to the line starting with VERS=
Please see screenshot below



Just below the line starting with VERS=, add following new line
VERS=bullseye
Please see screenshot below



Save file (Ctrl + O) and Close file (Ctrl+X)

Issue following command to run the installer and complete installation.
Code: [Select]

sudo bash inst_rbfeeder.sh



NOTE: Sometimes it may happen that the script runs and at the end showa that rbfeeder has been installed, while actually rbfeeder is not installed

This is caused by RB24's unsigned repository.
E: The repository 'https://apt.rb24.com bullseye InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
sudo: rbfeeder: command not found

If you face above noted problem, then work-around is as follows

(1) Open file rb24.list by following command:
Code: [Select]

sudo nano /etc/apt/sources.list.d/rb24.list 


In the file opened you will see following:



(2) There is only one line starting with word deb and followed by https.
Between deb and https, add following:
[trusted=yes]
The file will become like below:



(3) Save and Close file. Next run following commands. The rbfeeder will now be installed successfully.

Code: [Select]

sudo apt install rbfeeder   

sudo rbfeeder --setkey xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

##Replace xxxxxxxxxxxxxxxxxxxxx by your actual key

## Above command will makes rbfeeder to start and announce key is accepted
## Next press Ctrl and C Keys together to get comand prompt
 
sudo systemctl restart rbfeeder   



=============================================
(B) Building and Installing mlat-client on Bookworm
=============================================


System wide Installation (Recommended Standard Method)

Code: [Select]

sudo apt install -y git debhelper dh-python python3-dev python3-setuptools 

git clone https://github.com/mutability/mlat-client 

cd mlat-client   

sudo dpkg-buildpackage -b  --no-sign   

cd ../ 

sudo dpkg -i mlat-client_0.2.13_*.deb 

sudo apt-mark hold mlat-client 



NOTE:
For mlat to work, you must do following:

(1) Open file rbfeeder.ini for editing
Code: [Select]

sudo nano /etc/rbfeeder.ini   


(2) Add following lines under [client] in above file

lat=xx.xxxx
lon=yy.yyyy
alt=zzz


Replace xx.xxxx, yy.yyyy, and zzz by their actual values.
The zzz is elevation above sea level in meters.

Save file, then Reboot Pi

Please see screenshot attached below.
.
« Last Edit: March 02, 2024, 01:24:09 PM by abcd567 »

ramon.cutanda

  • New Member
  • *
  • Posts: 3
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #1 on: January 31, 2024, 09:38:49 PM »
Thanks a lot! I has holding the update to Bookworm on my Raspberry Pi 4 because OS upgrades are never smooth. Reading this post encouraged me to try and after following the detailed instructions it worked like a charm. Thank you once again.
Regards,
« Last Edit: January 31, 2024, 09:40:44 PM by ramon.cutanda »

abcd567

  • Hero Member
  • *****
  • Posts: 857
  • CYYZ - Toronto
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #2 on: March 02, 2024, 01:09:25 PM »
Today (March 02, 2024), I checked and found that the Radarbox24 has added following to their BOOKWORM repository

(1) rbfeeder ver 1:1.0.10+bullseye
(2) mlat-client ver 0.2.13

Please see attached screenshot below.

As a result, the work-around in First post of this thread is no more required.
Now on RaspberryPi OS Bookworm, the rbfeeder and mlat-client can be installed by following normal commands:

(1) To install rbfeeder:
Code: [Select]

sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"


(2) AFTER running above script, install mlat-client
Code: [Select]

sudo apt install mlat-client


« Last Edit: March 07, 2024, 02:23:49 PM by abcd567 »

Oldfella

  • New Member
  • *
  • Posts: 1
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #3 on: March 22, 2024, 10:52:27 PM »
Many thanks once again ABCD567 for all your input in the various software programmes that helps to make us enjoy this hobby.

I have been waiting for some announcement from Radarbox to run this on Bookworm OS and you with your 2nd March post, has fixed this situation. Nice to be up and running once again.

Best wishes,

Oldfella

Aviator56

  • New Member
  • *
  • Posts: 2
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #4 on: April 26, 2024, 04:02:35 PM »
Hi All,

I'm struggling to get MLAT working with RBFeeder
I'm running an RPi 4 on bookworm, have installed:-
Dump1090-fa and it runs
FR24Feed and it runs with MLAT enabled
RB24Feed and it runs but refuses to output MLAT

I've followed the great advice in this thread on installing both RBFeeder and MLAT repeatedly and have the correct Lat, Long and Alt entered in my rnfeeder.ini file thus:-

[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=0f07nnnnnnnnnnnnnnnn
sn=EXTRPI00nnnn
lat=50.75304
long=-2.00773
alt=60

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=false

Immediately after installing MLAT-client the status advises it is configured using /etc/default/mlat-client and is disabled by default, if I edit that mlat-client file to read "yes" on the START_CLIENT line and enter Lat, Long, Alt and my name on the SERVER-USER line and reboot, everything works EXCEPT MLAT on RBfeeder

Any advice gratefully accepted.  Regards  N

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33695
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #5 on: April 26, 2024, 04:54:21 PM »
Did you re-boot your Pi after instalation

Alan
« Last Edit: April 26, 2024, 04:56:58 PM by Runway 31 »

abcd567

  • Hero Member
  • *****
  • Posts: 857
  • CYYZ - Toronto
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #6 on: April 26, 2024, 07:19:40 PM »
@Aviator56

Please do NOT edit file /etc/default/mlat-client. It may not work properly if you edit it.

The mlat-client is NOT supposed to start automatically. It is started by rbfeeder when the rbfeeder starts.

To restore default configuration of mlat-client, please issue following commands:

sudo apt purge mlat-client 

sudo rm /etc/default/mlat-client   

sudo apt install mlat-client   

sudo reboot   

After reboot, check status
Code: [Select]
sudo systemctl status rbfeeder  | sed 's/ / /'

In output of above command, look at this portion of output. The presence of mlat-client in this line shows mlat is working ok.:

     CGroup: /system.slice/rbfeeder.service
             ├─105976 /usr/bin/rbfeeder
             └─105985 /usr/bin/python3 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --lat 43.5xxx --lon -79.6xxx --alt 1xx --user EXTRPI000008 --results beast,connect,127.0.0.1:32004
 

.
           
« Last Edit: April 26, 2024, 07:38:35 PM by abcd567 »

Aviator56

  • New Member
  • *
  • Posts: 2
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #7 on: April 29, 2024, 03:23:22 PM »
Thanks, ro the helpful response, here's the output from the rbfeeder status report:-
@RPiRB24:~ $ sudo systemctl status rbfeeder  | sed 's/ / /'
● rbfeeder.service - RBFeeder Service
     Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; preset: enabled)
     Active: active (running) since Mon 2024-04-29 16:14:40 BST; 2min 32s ago
    Process: 753 ExecStartPre=/bin/mkdir /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 760 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 762 ExecStartPre=/bin/touch /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 767 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 771 ExecStartPre=/bin/chown rbfeeder:rbfeeder /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
    Process: 779 ExecStartPre=/bin/setfacl -m u:www-data:rwx /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
   Main PID: 788 (rbfeeder)
      Tasks: 9 (limit: 763)
        CPU: 3.830s
     CGroup: /system.slice/rbfeeder.service
             └─788 /usr/bin/rbfeeder

No Mlat running indication.

Output from MLAT-client status:-

@RPiRB24:~ $ sudo systemctl status mlat-client
● mlat-client.service - LSB: Multilateration client
     Loaded: loaded (/etc/init.d/mlat-client; generated)
     Active: active (exited) since Mon 2024-04-29 16:14:30 BST; 7min ago
       Docs: man:systemd-sysv-generator(8)
    Process: 439 ExecStart=/etc/init.d/mlat-client start (code=exited, status=0/SUCCESS)
        CPU: 128ms

Apr 29 16:14:29 RPiRB24 systemd[1]: Starting mlat-client.service - LSB: Multilateration client...
Apr 29 16:14:30 RPiRB24 mlat-client[439]: Not starting mlat-client daemon, disabled via /etc/default/mlat-client ... (warning).
Apr 29 16:14:30 RPiRB24 systemd[1]: Started mlat-client.service - LSB: Multilateration client.


regards

Nigel

abcd567

  • Hero Member
  • *****
  • Posts: 857
  • CYYZ - Toronto
Re: Install rbfeeder and mlat-client on Raspberry Pi OS BOOKWORM
« Reply #8 on: April 29, 2024, 04:24:11 PM »
@Aviator56
Please do following. Issue commands in the order these are listed.

1. Delete mlat-client's config file
2. Purge mlat-client,
3. Clean apt cache (to remove corrupted mlat-client package so that the corrupted package is not reused for fresh install by the apt install command given below)
4. Reinstall mlat-client.
5. Reboot
6. Check status

sudo rm /etc/default/mlat-client 

sudo apt purge mlat-client 

sudo apt clean

sudo apt install mlat-client 

sudo reboot 

sudo systemctl status rbfeeder 


.
« Last Edit: April 29, 2024, 05:40:47 PM by abcd567 »