anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: What happened?  (Read 544 times)

0 Members and 1 Guest are viewing this topic.

skptrsn

  • New Member
  • *
  • Posts: 18
What happened?
« on: June 11, 2024, 03:03:07 AM »
Have two stations running off of the same pi and antenna setup. One Radarbox, and one Piaware. About 7 hours ago, my radarbox station went off line for no reason. The piaware station still feeds flightaware just fine, and I haven't changed any of my settings... it's been running fine for weeks - my Pi is fully updated, at least according to what the terminal says.. any ideas? I don't have a clue how to trouble shoot this thing, was thrilled to get it running.. maybe that's a part of my past, the way it feels now.Any suggestions?

« Last Edit: June 11, 2024, 05:40:57 AM by skptrsn »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33776
Re: What happened?
« Reply #1 on: June 11, 2024, 01:28:38 PM »
I suggest you reboot the Pi

Alan

skptrsn

  • New Member
  • *
  • Posts: 18
Re: What happened?
« Reply #2 on: June 11, 2024, 02:02:58 PM »
Hi, thanks Alan - "reboot" was my part of my first few independent efforts to rectify. When I noticed it was down, I did "apt update", "apt upgrade", and the same with "apt-get", changing the upgrade to "full-upgrade". It initially took something like 15 upgrades, which isn't too unusual from what I've observed - rebooted, and still no-go.
To verify whether it was my setup, or my process, I checked the flight aware feeder running on the same pi and it was functioning normally, reading aircraft near and far.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33776
Re: What happened?
« Reply #3 on: June 11, 2024, 03:56:07 PM »
Whats your station number

Alan

skptrsn

  • New Member
  • *
  • Posts: 18
Re: What happened?
« Reply #4 on: June 11, 2024, 04:13:09 PM »
Thanks, again! My station is EXTRPI590043. I notice that it isn't appearing in the list of local stations anymore, as well. It was reading somewhere around #18, disappeared at the same time my station went off-line.

skptrsn

  • New Member
  • *
  • Posts: 18
Re: What happened?
« Reply #5 on: June 11, 2024, 04:30:34 PM »
This is a screenshot of my station's output screen

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33776
Re: What happened?
« Reply #6 on: June 11, 2024, 05:03:20 PM »
There may be issues at the server end, mines has been going up and down all afternoon

Can you post your ini file with your details hidden

Alan
« Last Edit: June 11, 2024, 05:13:22 PM by Runway 31 »

skptrsn

  • New Member
  • *
  • Posts: 18
Re: What happened?
« Reply #7 on: June 11, 2024, 05:19:00 PM »
That's better than something I  have to figure out, I guess. lol Thanks, again - best wishes.

skptrsn

  • New Member
  • *
  • Posts: 18
Re: What happened?
« Reply #8 on: June 15, 2024, 12:36:49 AM »
RESOLVED. This issue was resolved by completely powering off the Pi, unplugging it, and then rebooting. This is (at least close to) the process prescribed in the "trouble shooting" area.. my error seems to have been attempting to just reboot the system via the "reboot" command in the terminal.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33776
Re: What happened?
« Reply #9 on: June 15, 2024, 06:26:13 PM »
Yes when I suggested reboot I meant to power down and restart

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 862
  • CYYZ - Toronto
Re: What happened?
« Reply #10 on: June 16, 2024, 02:58:18 PM »
@Alan
There are two ways to reboot:

(1) Simple Reboot:
Isuues following command, and Pi will shutdown then restart

sudo reboot

(2) Shutdown, followed by Power-off then Power-on

Step-2.1: Shutdown Pi by following command

sudo shutdown now

Step-2.2: Disconnect 220v or 110v AC power by pulling out the power plug from wall socket.

Step-2.3: Wait for a minute, then insert the AC power plug into wall socket. The Pi will restart, and will be ready within 30 to 60 seconds.


.
« Last Edit: June 16, 2024, 03:08:46 PM by abcd567 »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33776
Re: What happened?
« Reply #11 on: June 16, 2024, 07:31:25 PM »
Thanks abcd

Alan