anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: MLAT inactive  (Read 3726 times)

0 Members and 1 Guest are viewing this topic.

Pocokomulama

  • New Member
  • *
  • Posts: 2
MLAT inactive
« on: November 01, 2023, 10:51:34 AM »
Hello.
I am not able to run MLAT for RadarBox in any way I have found.
When I try to run mlat-client manually on my PI I get the following error.
Code: [Select]
mlat-client
Traceback (most recent call last):
  File "/usr/bin/mlat-client", line 108, in <module>
    open(pidfile, 'w').write(pid)
PermissionError: [Errno 13] Permission denied: '/run/mlat-client.pid'

A while ago, I performed the following steps once again.

1. sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"
2. sudo apt-get install mlat-client -y
3. reboot
4. sudo apt update

Additional information:

uname -a
Code: [Select]
Linux raspberrypi 5.10.17+ #1421 Thu May 27 13:58:02 BST 2021 armv6l GNU/Linux
lsb_release -a
Code: [Select]
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

apt-cache policy rbfeeder
Code: [Select]
rbfeeder:
  Installed: 1:1.0.8+deb10
  Candidate: 1:1.0.8+deb10
  Version table:
 *** 1:1.0.8+deb10 500
        500 https://apt.rb24.com buster/main armhf Packages
        100 /var/lib/dpkg/status

apt-cache policy mlat-client
Code: [Select]
mlat-client:
  Installed: 0.2.11
  Candidate: 0.2.11
  Version table:
 *** 0.2.11 500
        500 https://apt.rb24.com buster/main armhf Packages
        100 /var/lib/dpkg/status

apt-cache policy python3   
Code: [Select]
python3:
  Installed: 3.7.3-1
  Candidate: 3.7.3-1
  Version table:
 *** 3.7.3-1 500
        500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
        100 /var/lib/dpkg/status

sudo systemctl status rbfeeder
Code: [Select]
rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2023-10-13 12:29:41 BST; 2 weeks 4 days ago
  Process: 15553 ExecStartPre=/bin/mkdir /var/run/rbfeeder (code=exited, status=1/FAILURE)
  Process: 15554 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/run/rbfeeder (code=exited, status=0/SUCCESS)
  Process: 15555 ExecStartPre=/bin/touch /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
  Process: 15556 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
  Process: 15557 ExecStartPre=/bin/chown rbfeeder:rbfeeder /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
  Process: 15558 ExecStartPre=/bin/setfacl -m u:www-data:rwx /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
 Main PID: 15559 (rbfeeder)
    Tasks: 10 (limit: 877)
   CGroup: /system.slice/rbfeeder.service
           ├─ 8700 /usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30007 --input-type dump1090 --input-co
           └─15559 /usr/bin/rbfeeder

Nov 01 10:49:03 raspberrypi rbfeeder[15559]:     open(pidfile, 'w').write(pid)
Nov 01 10:49:03 raspberrypi rbfeeder[15559]: PermissionError: [Errno 13] Permission denied: '/run/mlat-client.pid'
Nov 01 10:49:34 raspberrypi rbfeeder[15559]: Traceback (most recent call last):
Nov 01 10:49:34 raspberrypi rbfeeder[15559]:   File "/usr/bin/mlat-client", line 108, in <module>
Nov 01 10:49:34 raspberrypi rbfeeder[15559]:     open(pidfile, 'w').write(pid)
Nov 01 10:49:34 raspberrypi rbfeeder[15559]: PermissionError: [Errno 13] Permission denied: '/run/mlat-client.pid'
Nov 01 10:50:00 raspberrypi rbfeeder[15559]: [2023-11-01 10:50:00]  ******** Statistics updated every 60 seconds *******
Nov 01 10:50:00 raspberrypi rbfeeder[15559]: [2023-11-01 10:50:00]  Packets sent in the last 60 seconds: 105, Total pack
Nov 01 10:50:00 raspberrypi rbfeeder[15559]: [2023-11-01 10:50:00]  Data sent: 133.1 MB
Nov 01 10:50:00 raspberrypi rbfeeder[15559]: [2023-11-01 10:50:00]  Data received: 13.5 KB

cat /etc/rbfeeder.ini
Code: [Select]
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=XXXXX

sn=EXTRPI580893

lat=50.2197
lon=19.1591
alt=296

[mlat]
autostart_mlat=true
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30007

[dump978]
dump978_enabled=false

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

Pocokomulama

  • New Member
  • *
  • Posts: 2
Re: MLAT inactive
« Reply #1 on: November 01, 2023, 11:13:50 AM »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33830
Re: MLAT inactive
« Reply #2 on: November 01, 2023, 01:52:57 PM »
Yes you require to add your lat/lon

Alan