anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: RBFeeder sending data to FR24 but no Data on my RB Station  (Read 4203 times)

0 Members and 1 Guest are viewing this topic.

bigchin67

  • New Member
  • *
  • Posts: 8
RBFeeder sending data to FR24 but no Data on my RB Station
« on: April 19, 2023, 07:28:16 AM »
I'm new to this data sharing so apologise for any dumb questions.

I have set up a new Raspberry Pi and am running both Radarbox and FlightRadar24 Feeds from the box. The RBFeed is set to us the USB dongle (network off) and FR24Feeder take the data via Beast-TCP on port 30005.

The setup was working find for 1 week but I just rebooted the pi to move it and now the RBFeeder doesn't seem to upload data to my station online on AirNav Radarbox.

FR24Feeder is working fine and I can see aircraft in the logs
dump1090/gmap.html shows aircraft in the map - presumably coming from my antenna
RBFeeder.log shows no errors but my station EXTRPI004512
 has no recent data whereas FR24 does from the same feed.

It seems like the USB dongle is working and dump1090 is outputting to the correct port but rbfeeder isn't reading the feed directly.

I don't know what has changed as it was both working find until I rebooted.

Anyone got any tips for troubleshooting why rbfeeder has stopped feeding Radarbox?

.ini files for both feeds are below:

cat rbfeeder.ini
[client]
network_mode=false
log_file=/var/log/rbfeeder.log

key={hidden in this post}

sn=EXTRPI004512

lat=-33.801718000000001

lon=151.289669

alt=51

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client

[dump978]
dump978_enabled=false

cat fr24feed.ini
receiver="beast-tcp"
fr24key="{hidden in this post}"
host="127.0.0.1:30005"
path="/usr/bin/dump1090-rb"
bs="yes"
raw="yes"
logmode="2"
windowmode="0"
logpath="/var/log/fr24feed"
mpx="no"
mlat="yes"
mlat-without-gps="yes"

bigchin67

  • New Member
  • *
  • Posts: 8
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #1 on: April 19, 2023, 09:56:48 AM »
I can see that rbfeeder can't claim the usb dongle :
rbfeeder[603]: usb_claim_interface error -6
rbfeeder[603]: rtlsdr: error opening the RTLSDR device: Device or resource busy

How can I find out what is using the Dongle as the FR24Feed is definately using Beast-TCP mode

« Last Edit: April 19, 2023, 10:17:30 AM by bigchin67 »

abcd567

  • Hero Member
  • *****
  • Posts: 879
  • CYYZ - Toronto
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #2 on: April 19, 2023, 05:55:24 PM »
Plesse issue following commands and post their outputs. These outputs will show which version of dump1090 is using your dongle.

Code: [Select]

pgrep -af rtl   

pgrep -fa dump1090-mutability 

pgrep -fa dump1090-rb



EXPLAINATION
Your setup requires the rbfeeder's builtin "dump1090-rb" to start when rbfeeder is started. Once "dump1090-rb" is started, both the rbfeeder and fr24feed get data from it.

It seems that on reboot, the fr24feed started before rbfeeder could start and start "dump1090-rb". The fr24feed when did not find any dump1090 rumning, it triggered installation of "dump1090-mitability" which captured the dongle and started outputing data on port 30005. The FR24 therefore working properly using this data. However since Radsrbox is set to use its internal dump1090-rb, fails as its internal "dump1090-rb" has no dongle left to use and gives "rbfeeder[603]: rtlsdr: error opening the RTLSDR device: Device or resource busy".


SOLUTION
If output of any of the above noted 3 commands "pgrep -fa xxxxxx" contains "dump1090-mutability", then do following:

In file /etc/rbfeeder.ini, under [client], change "network_mode=false" to "network_mode=true".

Then restart rbfeeder OR reboot Pi

The above modification will set rbfeeder to get data from dump1090-mutability port 30005, same as fr24feed is doing.
« Last Edit: April 19, 2023, 11:44:26 PM by abcd567 »

bigchin67

  • New Member
  • *
  • Posts: 8
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #3 on: April 20, 2023, 12:18:47 AM »
Thanks ABCD
Only the dump1090-mutability returned anything:
pgrep -af dump1090-mutability
554 /usr/bin/dump1090-mutability --net --ppm 0 --fix --max-range 300 --net-ri-port 30001 --net-ro-port 30002 --net-bi-port 30004,30104 --net-bo-port 30005 --net-sbs-port 30003 --net-heartbeat 60 --net-ro-size 500 --net-ro-interval 1 --net-buffer 2 --net-bind-address 127.0.0.1 --stats-every 3600 --write-json /run/dump1090-mutability --write-json-every 1 --json-location-accuracy 1 --quiet


I switched RBFeeder to network mode and now both RB and FR24 receive the feed via the 30005 Port. I do notice the FR24 does not show MLAT but the RB Feed does. As part of my trouble-shooting I set FR24 mode to avr-tcp instead of ModeS Beast TCP, is this correct?
 Not sure why my dump1090 changed as I set it up for rbfeeder to use the dongle and didn't make any changes before reboot.

Thanks for your help

abcd567

  • Hero Member
  • *****
  • Posts: 879
  • CYYZ - Toronto
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #4 on: April 20, 2023, 02:22:09 AM »
Both the following settings of FR24 are OK

(1) Works OK, and recommended by FR24
receiver="avr-tcp"
host="127.0.0.1:30002"


(2) Works OK
receiver="beast-tcp"
host="127.0.0.1:30005"


ADDITIONAL IMPROVEMENT:
Give following command
Code: [Select]

sudo nano /etc/default/dump1090-mutability 



In the file opened, check that following line is "yes".

START_DUMP1090="yes"

If it is "no", change "no" to "yes", save file and reboot.


EXPLANATION:
The "yes" will ensure independent start of dump1090-mutability at boot.
The "no" will enslave dump1090-mutability to fr24feed. It will NOT start automatically at boot. It will be started only when fr24feed starts and issues a command to start dump1090-mutability.


.
« Last Edit: April 20, 2023, 03:31:07 AM by abcd567 »

bigchin67

  • New Member
  • *
  • Posts: 8
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #5 on: April 20, 2023, 03:52:39 AM »
When using FR24 in Beast-TCP, MLAT is enabled but switching to avp-TCP shows MLAT as "not running" even when set to YES in settings. FR24 recommend disabling MLAT when sharing with other feeds so maybe it's an over-ride in their code.

Other than that, everything is working OK.

abcd567

  • Hero Member
  • *****
  • Posts: 879
  • CYYZ - Toronto
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #6 on: April 20, 2023, 04:01:19 AM »
Did you ensure that in file "/etc/default/dump1090-mutability", the setting is as follows?

START_DUMP1090="yes"

.
« Last Edit: April 20, 2023, 04:05:27 AM by abcd567 »

bigchin67

  • New Member
  • *
  • Posts: 8
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #7 on: April 20, 2023, 05:10:12 AM »
Yes, "/etc/default/dump1090-mutability", has START_DUMP1090="yes" and it starts on reboot

abcd567

  • Hero Member
  • *****
  • Posts: 879
  • CYYZ - Toronto
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #8 on: April 20, 2023, 08:00:38 AM »
ANOTHER ENHANCEMENT:
Show Site Location and Range Rings on dump1090/gmap.html

Code: [Select]

sudo nano /usr/share/dump1090-mutability/html/config.js   


In the file opened, scroll down till you see followin code

Code: [Select]
SiteShow    = false;           // true to show a center marker
SiteLat     = 45.0;            // position of the marker
SiteLon     = 9.0;
SiteName    = "My Radar Site"; // tooltip of the marker


(1) Change SiteShow = false; to SiteShow = true;
(2) Change "SiteLat = 45.0;" and "SiteLon = 9.0;" values to the Latitude and Longitude values of your location.

Save and close file

In your Browser, go to page IP-of-Pi/dump1090/gmap.html and reload Browser Ctrl+F5.
The site marker and range rings will appear on the map. Please click on gmap.html screenshot attached to see range rings on larger size screenshot.
« Last Edit: April 20, 2023, 09:43:10 AM by abcd567 »

bigchin67

  • New Member
  • *
  • Posts: 8
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #9 on: April 21, 2023, 05:16:44 AM »
Thanks for that. I made the changes and the rings appear when I view it in Microsft Edge but Chrome doesn't seem to read any of the config changes. I even renamed the page name and it shows up in Edge but shows default "DUMP 1090" in Chrome. I checked and there is only one config.js file on the system. Looks like chrome doesn't read the config file. Javascript is enabled in chrome.

abcd567

  • Hero Member
  • *****
  • Posts: 879
  • CYYZ - Toronto
Re: RBFeeder sending data to FR24 but no Data on my RB Station
« Reply #10 on: April 21, 2023, 06:29:06 AM »
Thanks for that. I made the changes and the rings appear when I view it in Microsft Edge but Chrome doesn't seem to read any of the config changes. I even renamed the page name and it shows up in Edge but shows default "DUMP 1090" in Chrome. I checked and there is only one config.js file on the system. Looks like chrome doesn't read the config file. Javascript is enabled in chrome.

For a stubborn browser, which insists on using old cached files, do this:

(1) Reload Browser (Ctrl + F5 ) - If once not sufficient try multiple times

(2) If Reloading is not sufficient, then Clear Browser Cache (Ctrl + Shift + Delete ), and after that reload browser (Ctrl + F5).
« Last Edit: April 21, 2023, 06:33:07 AM by abcd567 »