AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Radarbox switch to Bullseye ok, but issue with VHF stick.  (Read 2081 times)

0 Members and 1 Guest are viewing this topic.

RZEE

  • New Member
  • *
  • Posts: 24
Radarbox switch to Bullseye ok, but issue with VHF stick.
« on: October 29, 2022, 10:49:42 AM »
Hi, after 1.5 years of flawless running RB + Airband VHF on my Pi3+ i recently upgraded to bullseye [32bit]. I did a complete fresh install and RB working as it should,

[EXTRPI011916]

There however is a problem with the Airband VHF setup:

Code: [Select]
E: Unable to locate package rtl-airband-rb
Also, when plug in the airband VHF stick [and reboot] the number of reported planes drop from 70 to 2, even after a hour. If i unplug the VHF stick [and reboot] all is back to normal.


So, somthing goes wrong in the airband installation.The question is: is the Airband VHF not compatible to bulseye? or is there anything else i overlook. I assume it's related to the airband installation error, however i have no clue where to start troubleshooting.

Thanks in advance. 

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33203
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #1 on: October 29, 2022, 12:05:17 PM »
Suggest you ask support

Alan

[email protected]

  • New Member
  • *
  • Posts: 4
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #2 on: October 30, 2022, 07:56:27 AM »
Hi there Alan recently sent me a VHF stick and I can not  get it to work on a new installion on rasp pi, is there any help out there and how to contact support for something like this?

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33203
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #3 on: October 30, 2022, 09:08:39 AM »
[email protected] is their email

Alan

RZEE

  • New Member
  • *
  • Posts: 24
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #4 on: October 30, 2022, 05:16:06 PM »
Quote
Hi there Alan recently sent me a VHF stick and I can not  get it to work on a new installion on rasp pi, is there any help out there and how to contact support for something like this?

What os you run ? 

abcd567

  • Hero Member
  • *****
  • Posts: 783
  • CYYZ - Toronto
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #5 on: October 30, 2022, 11:48:49 PM »
i recently upgraded to bullseye [32bit]. I did a complete fresh install and RB working as it should,

[EXTRPI011916]

There however is a problem with the Airband VHF setup:

Code: [Select]
E: Unable to locate package rtl-airband-rb

Airban VHF installation script has packages for Stretch and Buster. There is no package for Bullseye. It therefore fails to install AIRband VHF on Bullseye as it detects the OS is neither Stretch not Buster.

The script can be CHEATED to think that your OS is Buster, and then it will install AIRBand VHF package for Buster on Bullseye. Most likely Buster package will work on Bullseye as well.

(A) Follow this procedure to install by CHEATING:
Download and edit installation file by following commands:
Code: [Select]
wget http://apt.rb24.com/inst_rtl-airband-rb.sh 

sudo nano inst_rtl-airband-rb.sh 

Scroll down to the line starting with word VERS, i.e. the line below
Code: [Select]
VERS=`lsb_release -c | awk -F ':' '{print $2}' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*$//'`

Add a new line VERS=buster Just BELOW the original line, so it becomes like this
Code: [Select]
VERS=`lsb_release -c | awk -F ':' '{print $2}' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*$//'`
VERS=buster


Save file (Press Ctrl and O keys together) and Close File (Press Ctrl and X keys together)

Now give following command, and it will install package rtl-airband-rb

Code: [Select]

sudo bash inst_rtl-airband-rb.sh   


After installation is completed and AIRBand VHF is running OK, REMOVE CHEAT by following procedure:

Open sources list file for editing by following command
Code: [Select]
sudo nano /etc/apt/sources.list.d/rb24.list 

You will see this line:
Code: [Select]
deb https://apt.rb24.com/ buster main

In above line, replace word buster by bullseye, so the line becomes as below:
Code: [Select]
deb https://apt.rb24.com/ bullseye main

Save file (Ctrl and O Keys together) and Close file (Ctrl and X keys together)

Now update apt
Code: [Select]

sudo apt update   

.
« Last Edit: October 30, 2022, 11:51:18 PM by abcd567 »

RZEE

  • New Member
  • *
  • Posts: 24
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #6 on: October 31, 2022, 08:06:15 PM »
Quote
(A) Follow this procedure to install by CHEATING:

Thanks for this. the Airband installation seems to work flawless  now, but still  no VHF reception possible.
Also, the initial problem remains: when both sticks are plugged in the PI, adsb reception drop from 99 planes to 3 planes. It goes back to normal after removing the VHF stick.

I assume there still is a issue the VHF stick got not recognized correctly causing the issues.

 

abcd567

  • Hero Member
  • *****
  • Posts: 783
  • CYYZ - Toronto
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #7 on: October 31, 2022, 09:17:18 PM »
Seems at startup, dump1090 grabs Yellow AirBand dongle, and Airband grabs Green 1090 Mhz dongle
You will need to Serialize both dongles with different serial numbers, and add this info in the respective config files of dump1090 and Airband.

(1) Please post output of last command below
Code: [Select]
sudo apt install rtl-sdr 
sudo systemctl stop rbfeeder piaware dump1090-rb dump1090-fa rtl-airband-rb
rtl_test -t


(2) Please post output of following commands
Code: [Select]
cat etc/rtl-airband-rb.conf 
cat /etc/rbfeeder.ini 


(3) Please serialize the Green (1090 MHz) and Yellow (AIRBand VHF) dongles to serial numbers below
Green (1090 MHz) Dongle Serial Number = 00001090  (Eight Digits)
Yellow (AirBand VHF) Dongle Serial Number = 00000118  (Eight Digits)

Plug one Dongle at a time, serialize it, unplug it.
Next plug second dongle, serialize, and unplug it.
Finally replug both dongles.

Use How-to here.
https://forum.radarbox24.com/index.php?topic=19831.0


After Serializing, give following command to find which dongle is device 0 and which is device 1.

Quote

pi@raspberrypi:~ $ rtl_test -t
Found 2 device(s):
  0:  Realtek, RTL2832U, SN: 00000118
  1:  Realtek, RTL2838UHIDIR, SN: 00001090

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.



In example above, the device 0 is the AirBand Yellow dongle (Serialized by me as 00000118). Therefore in AirBand config file I will use index = 0;.

Thr device 1 is the Green 1090 Mhz dongle (Serialized by me as 00001090), and therefore in file /etc/rbfeeder.ini, under [client], I will add line 
dump_device=1
OR better 
dump_device=00001090



AIRBAND CONFIG FILE

Quote

cat /etc/rtl-airband-rb.conf

# This is a minimalistic configuration file for rtl-airband
# Please change frequencies that you will use and other settings.
#
# Note: this configuration will use your second dongle attached
# to you raspberry, not the first one!
#
# index = 0     => First dongle
# index = 1     => Second dongle


devices:
({
  type = "rtlsdr";
  index = 0;
  gain = 28;
  correction = 0;
  mode = "scan";
  channels:
  (
    {
          #squelch = 35;  # Uncomment to set squelch manually
      freqs = ( 118000000, 119550000, 126000000 );
      labels = ( "Tower", "Ground", "Approach" );
      outputs: (
        {
          type = "icecast";
          server = "audio.rb24.com";
          port = 8000;
          mountpoint = "EXTVHFXXXXXX";
          name = "My Transmitter";
          genre = "ATC";
          username = "<RadarBox Login E-mail>";
          password = "<radarBox Password>";
          send_scan_freq_tags = true;
        }
                # If you need more outputs, put here

      );
    }
  );
 }
);









.
« Last Edit: November 02, 2022, 03:58:35 PM by abcd567 »

RZEE

  • New Member
  • *
  • Posts: 24
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #8 on: November 02, 2022, 06:38:32 PM »
Quote
Seems at startup, dump1090 grabs Yellow AirBand dongle, and Airband grabs Green 1090 Mhz dongle
You will need to Serialize both dongles with different serial numbers, and add this info in the respective config files of dump1090 and Airband.

Ok, thanks again! My dongles should be serialized from my previous setup, but i will check and report back asap. It might take a few days.

RZEE

  • New Member
  • *
  • Posts: 24
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #9 on: November 05, 2022, 12:23:46 PM »
Ok some more testing done, i added the device serial to the feeder config. this seems to fixed the dissapearing planes when connecting 2 The adsb aswell the VHF stick.

Quote
(1) Please post output of last command below
Code: [Select]
sudo apt install rtl-sdr
sudo systemctl stop rbfeeder piaware dump1090-rb dump1090-fa rtl-airband-rb
rtl_test -t

Result:
Code: [Select]
pi@raspberrypi:~ $ sudo apt install rtl-sdr
sudo systemctl stop rbfeeder piaware dump1090-rb dump1090-fa rtl-airband-rb
rtl_test -t
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
rtl-sdr is already the newest version (0.6.0-3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Failed to stop piaware.service: Unit piaware.service not loaded.
Failed to stop dump1090-rb.service: Unit dump1090-rb.service not loaded.
Failed to stop dump1090-fa.service: Unit dump1090-fa.service not loaded.
Found 2 device(s):
  0:  Realtek, ADSB, SN: 00001090
  1:  Realtek, VHF, SN: 00000118

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.

Quote
(2) Please post output of following commands
Code: [Select]
cat etc/rtl-airband-rb.conf
cat /etc/rbfeeder.ini

Code: [Select]
pi@raspberrypi:~ $ cat etc/rtl-airband-rb.conf
cat /etc/rbfeeder.ini
cat: etc/rtl-airband-rb.conf: No such file or directory
[client]
network_mode=false
log_file=/var/log/rbfeeder.log
dump_device=00001090
key=557248f783cfc1b6c364bd2d41f0fxxx

sn=EXTRPI011916

lat=52.244320999999999

lon=4.8257599999999998

alt=9

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true
pi@raspberrypi:~ $

Quote
(3) Please serialize the Green (1090 MHz) and Yellow (AIRBand VHF) dongles to serial numbers below
Green (1090 MHz) Dongle Serial Number = 00001090  (Eight Digits)
Yellow (AirBand VHF) Dongle Serial Number = 00000118  (Eight Digits)

Plug one Dongle at a time, serialize it, unplug it.
Next plug second dongle, serialize, and unplug it.
Finally replug both dongles.

Done:
Code: [Select]
Found 2 device(s):
  0:  Realtek, ADSB, SN: 00001090
  1:  Realtek, VHF, SN: 00000118

Airband config file:

Code: [Select]
pi@raspberrypi:~ $ cat /etc/rtl-airband-rb.conf
# This is a minimalistic configuration file for rtl-airband
# Please change frequencies that you will use and other settings.
#
# Note: this configuration will use your second dongle attached
# to you raspberry, not the first one!
#
# index = 0     => First dongle
# index = 1     => Second dongle


devices:
({
  type = "rtlsdr";
  index = 0;
  gain = 28;
  correction = 0;
  mode = "scan";
  channels:
  (
    {
          #squelch = 35;  # Uncomment to set squelch manually
      freqs = ( 118105000, 119550000, 126000000 );
      labels = ( "Tower", "Ground", "Approach" );
      outputs: (
        {
          type = "icecast";
          server = "audio.rb24.com";
          port = 8000;
          mountpoint = "EXTVHF000594";
          name = "Schiphol Tower";
          genre = "ATC";
          username = "[email protected]";
          password = "********";
          send_scan_freq_tags = true;
        }
                # If you need more outputs, put here

      );
    }
  );
 }
);
pi@raspberrypi:~ $

So the result now is:
ADSB dongle works fine, even with both ADSB & VHF dongles plugged in.
The VHF part still not functional

Any more suggestions ?








abcd567

  • Hero Member
  • *****
  • Posts: 783
  • CYYZ - Toronto
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #10 on: November 05, 2022, 01:12:10 PM »

Done:
Found 2 device(s):
  0:  Realtek, ADSB, SN: 00001090
  1:  Realtek, VHF, SN: 00000118

From above, the Airband dongle is device index 1
But in Airband config file you have used device index = 0;, (as shown in red below)

Quote
pi@raspberrypi:~ $ cat /etc/rtl-airband-rb.conf

devices:
({
  type = "rtlsdr";
  index = 0;
  gain = 28;
  correction = 0;
  mode = "scan";
  channels:
  (


Quote
   
The VHF part still not functional

Change index = 0; to index = 1; in Airband config file, Save file, and REBOOT Pi.


.
« Last Edit: November 05, 2022, 01:23:20 PM by abcd567 »

RZEE

  • New Member
  • *
  • Posts: 24
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #11 on: November 05, 2022, 04:09:23 PM »
Quote
Change index = 0; to index = 1; in Airband config file, Save file, and REBOOT Pi.

Ok thanks, done that:

Quote
# This is a minimalistic configuration file for rtl-airband
# Please change frequencies that you will use and other settings.
#
# Note: this configuration will use your second dongle attached
# to you raspberry, not the first one!
#
# index = 0     => First dongle
# index = 1     => Second dongle


devices:
({
  type = "rtlsdr";
  index = 1;
  gain = 28;
  correction = 0;
  mode = "scan";
  channels:
  (
    {
          #squelch = 35;  # Uncomment to set squelch manually
      freqs = ( 118105000, 119550000, 126000000 );
      labels = ( "Tower", "Ground", "Approach" );
      outputs: (
        {
          type = "icecast";
          server = "audio.rb24.com";
          port = 8000;
          mountpoint = "EXTVHF000594";
          name = "Schiphol Tower";
          genre = "ATC";
          username = "**********";
          password = "**********";
          send_scan_freq_tags = true;
        }
                # If you need more outputs, put here

      );
    }
  );
 }
);

No result for this, so checked the dongle config again. This however seems ok.

Code: [Select]
pi_raspberrypi:~ $ rtl_eeprom
Found 2 device(s):
  0:  Generic RTL2832U OEM
  1:  Generic RTL2832U OEM

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.
pi_raspberrypi:~ $ rtl_test
Found 2 device(s):
  0:  Realtek, ADSB, SN: 00001090
  1:  Realtek, VHF, SN: 00000118

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.
pi_raspberrypi:~ $

Additional test:
Sending a audio stream from the rocketbooster app  [from my windows machine] will show the player in the EXTVHF000594

abcd567

  • Hero Member
  • *****
  • Posts: 783
  • CYYZ - Toronto
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #12 on: November 05, 2022, 04:53:39 PM »
You can individually check health of rtl-airband-rb and rbfeeder by following commands
Code: [Select]
sudo systemctl status rtl-airband-rb   

sudo systemctl status rbfeeder   


You can check the health of each dongle by stopping rbfeeder and Airband software, then twice issue rtl_test -t command, once specifying device index 0 and next specifying device index 1 as follows:

(1) First stop rbfeeder and rtl-airband-rb to free the dongles for test.
Code: [Select]
sudo systemctl stop rbfeeder 

sudo systemctl stop rtl-airband-rb


(2) Test device with index 0 (test command rtl_test -t -d 0 )
Code: [Select]
rtl_test -t -d 0 

Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00001090

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.


(3) Test device with index 1 (test command rtl_test -t -d 1 )
Code: [Select]
rtl_test -t -d 1 
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000188

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.



(4) Restore rbfeeder and rtl-airband-rb, AND test their status
Code: [Select]
sudo systemctl restart rtl-airband-rb   
sudo systemctl status rtl-airband-rb   

sudo systemctl restart rbfeeder   
sudo systemctl status rbfeeder   


NOTE: In above tests, instead of using device index -d 0 and -d 1, you may use device serial -d 00001090 and -d 00000118

.
« Last Edit: November 05, 2022, 04:55:22 PM by abcd567 »

RZEE

  • New Member
  • *
  • Posts: 24
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #13 on: November 05, 2022, 06:52:59 PM »
As the ADSB runs good i focus on Airband config,

Running:
Code: [Select]
sudo systemctl status rtl-airband-rbresults in:

Quote
~ $ sudo systemctl status rtl-airband-rb
● rtl-airband-rb.service - SDR AM/NFM demodulator
     Loaded: loaded (/lib/systemd/system/rtl-airband-rb.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2022-11-05 18:16:34 CET; 8min ago
     Process: 1416 ExecStart=/usr/bin/rtl_airband -e -c /etc/rtl-airband-rb.conf (code=exited, status=0/SUCCESS)
   Main PID: 1418 (code=exited, status=1/FAILURE)
        CPU: 116ms

Nov 05 18:16:33 raspberrypi systemd[1]: Starting SDR AM/NFM demodulator...
Nov 05 18:16:33 raspberrypi systemd[1]: Started SDR AM/NFM demodulator.
Nov 05 18:16:34 raspberrypi systemd[1]: rtl-airband-rb.service: Main process exited, code=exited, status=1/FAILURE
Nov 05 18:16:34 raspberrypi systemd[1]: rtl-airband-rb.service: Failed with result 'exit-code'.

abcd567

  • Hero Member
  • *****
  • Posts: 783
  • CYYZ - Toronto
Re: Radarbox switch to Bullseye ok, but issue with VHF stick.
« Reply #14 on: November 05, 2022, 08:27:17 PM »

Nov 05 18:16:34 raspberrypi systemd[1]: rtl-airband-rb.service: Main process exited, code=exited, status=1/FAILURE
Nov 05 18:16:34 raspberrypi systemd[1]: rtl-airband-rb.service: Failed with result 'exit-code'.



The rtl-airband-rb has failed to start

What is the output of following command:

Code: [Select]
sudo journalctl -u rtl-airband-rb -n 30