anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: RB VHF usb  (Read 434 times)

0 Members and 1 Guest are viewing this topic.

D00B

  • New Member
  • *
  • Posts: 8
RB VHF usb
« on: September 26, 2022, 05:13:24 PM »
Hello everyone. I’ve recently bought a RB VHF stick and am using a Raspberry Pi 3B on Buster.
I have read the guide here https://www.radarbox.com/sharing-vhf

Something throwing me off is the bit about using RTL-SDR-Airband software. Clicking the link takes me to GitHub but I don’t know what to do there.
If I just go straight to trying sudo apt-get update -y && sudo apt-get install rtl-airband-rb -y via ssh on the pi, I get the response “E: Unable to locate package rtl-airband-rb”

Is anyone pi savvy able to offer some guidance for me?

Thanks in advance.

abcd567

  • Hero Member
  • *****
  • Posts: 712
  • CYYZ - Toronto
Re: RB VHF usb
« Reply #1 on: September 26, 2022, 07:53:48 PM »
You need to add Radarbox repository to your apt sources list.

(1) EASY AUTOMATED METHOD:
If you don't have RBFeeder installed, the following command will install both RBFeeder and the rtl-airband-rb package:

Code: [Select]
sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rtl-airband-rb.sh)"


(2) MANUAL METHOD (FOR ADVANCE USERS)
The screenshot you posted shows you have Raspbian BUSTER.
You can further confirm this by following command

Code: [Select]
lsb_release -sc 


Issue following command to add RB24's BUSTER repo to your apt sources list:
Code: [Select]
sudo touch /etc/apt/sources.list.d/rb24.list

sudo chmod 666 /etc/apt/sources.list.d/rb24.list

sudo echo 'deb https://apt.rb24.com/ buster main' > /etc/apt/sources.list.d/rb24.list 

sudo chmod 644 /etc/apt/sources.list.d/rb24.list

sudo apt update 



Now issue following command to install airband

Code: [Select]
sudo apt-get update -y && sudo apt-get install rtl-airband-rb -y

« Last Edit: September 26, 2022, 08:28:19 PM by abcd567 »

D00B

  • New Member
  • *
  • Posts: 8
Re: RB VHF usb
« Reply #2 on: September 26, 2022, 08:21:47 PM »
Thanks abcd! I was hoping you come good having read so many of your posts before.

I’ll have a go now and report back.

D00B

  • New Member
  • *
  • Posts: 8
Re: RB VHF usb
« Reply #3 on: September 26, 2022, 08:30:17 PM »
There seems to be an error with that

abcd567

  • Hero Member
  • *****
  • Posts: 712
  • CYYZ - Toronto
Re: RB VHF usb
« Reply #4 on: September 26, 2022, 08:37:27 PM »
Try this command:
If you don't have RBFeeder installed, the following command will install both RBFeeder and the rtl-airband-rb package:

Code: [Select]
sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rtl-airband-rb.sh)"


D00B

  • New Member
  • *
  • Posts: 8
Re: RB VHF usb
« Reply #5 on: September 26, 2022, 08:58:30 PM »
Ok, that’s done and the conf file is now populated with the information provided in the guide.

My issue now is restarting the service.

The service is not found.


D00B

  • New Member
  • *
  • Posts: 8
Re: RB VHF usb
« Reply #6 on: September 26, 2022, 08:59:09 PM »
Here’s the error

abcd567

  • Hero Member
  • *****
  • Posts: 712
  • CYYZ - Toronto
Re: RB VHF usb
« Reply #7 on: September 26, 2022, 09:12:02 PM »
Code: [Select]
Failed to restart rtl-airband-rb. Unit rtl-airband-rb.service not found

The airband did NOT get installed.
The problem is missing PUBLIC KEY F2A8428D3C354953 (see cutout from your first screenshot below)

Add missing key by following command
Code: [Select]
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys  F2A8428D3C354953



Now try again

Code: [Select]
sudo apt-get update -y && sudo apt-get install rtl-airband-rb -y


D00B

  • New Member
  • *
  • Posts: 8
Re: RB VHF usb
« Reply #8 on: September 27, 2022, 05:03:20 PM »
Thank you! All seems to have gone through correctly. Only issue now is it shows offline on the website which is a little odd

D00B

  • New Member
  • *
  • Posts: 8
Re: RB VHF usb
« Reply #9 on: September 30, 2022, 06:57:23 PM »
@abcd567

I seem to have another issue which is causing the service to fail.

If I issue the command
Code: [Select]
sudo systemctl restart rtl-airband-rb.service
I get the following error
Job for rtl-airband-rb.service failed because the control process exited with error code.
See "systemctl status rtl-airband-rb.service" and "journalctl -xe" for details.


Running this
Code: [Select]
systemctl status rtl-airband-rb.service
offers the response
● rtl-airband-rb.service - SDR AM/NFM demodulator
   Loaded: loaded (/lib/systemd/system/rtl-airband-rb.service; enabled; vendor preset: enable
   Active: failed (Result: exit-code) since Fri 2022-09-30 19:50:54 BST; 2min 18s ago
     Docs: https://github.com/szpajder/RTLSDR-Airband/wiki
  Process: 3564 ExecStart=/usr/bin/rtl_airband -e -c /etc/rtl-airband-rb.conf (code=exited, s

Sep 30 19:50:54 raspberrypi systemd[1]: Starting SDR AM/NFM demodulator...
Sep 30 19:50:54 raspberrypi rtl_airband[3564]: Error while parsing configuration file /etc/rt
Sep 30 19:50:54 raspberrypi systemd[1]: rtl-airband-rb.service: Control process exited, code=
Sep 30 19:50:54 raspberrypi systemd[1]: rtl-airband-rb.service: Failed with result 'exit-code
Sep 30 19:50:54 raspberrypi systemd[1]: Failed to start SDR AM/NFM demodulator.

Looking now at the code for the config using
Code: [Select]
sudo nano /etc/rtl-airband-rb.conf

shows the below which seems to relate to the 3 dots on line 6
The code was originally copied and edited where needed from here https://www.radarbox.com/sharing-vhf

Do you have any thoughts?



D00B

  • New Member
  • *
  • Posts: 8
Re: RB VHF usb
« Reply #10 on: September 30, 2022, 07:00:43 PM »
Here is the screenshot of the actual response