AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: mlat error  (Read 1077 times)

0 Members and 1 Guest are viewing this topic.

abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto
Re: mlat error
« Reply #30 on: July 18, 2022, 08:54:34 PM »
This is the correct format /etc/network/interfaces for wifi
Code: [Select]
source /etc/network/interfaces.d/*
# Network is managed by Network manager
auto lo
iface lo inet loopback

iface wlan0
  hwaddress ether xx:xx:xx:FC:76:3F
Are you using Wired connection Ethernet (eth0) or WiFi (wlan0)?



Try this:
Code: [Select]
sudo nmtui 

Go to "Edit a connection"
Choose "Ethernet" OR "Wi-Fi", whichever you are using, then highlight "Edit" and press Enter Key.
You will see MAC address under "Device"



.

Taxom

  • New Member
  • *
  • Posts: 17
Re: mlat error
« Reply #31 on: July 19, 2022, 09:21:25 PM »
Yes I'm using wifi connect to my pi.
At some point MAC started to change after every reboot. I would like MAC to stay default.
I found solution to delete NetworkManager but I'm not sure if it works and  doesn't break system.

My "device" field is empty.

Thanks in advance.

abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto
Re: mlat error
« Reply #32 on: July 19, 2022, 09:50:08 PM »
Yes I'm using wifi connect to my pi.
At some point MAC started to change after every reboot. I would like MAC to stay default.
I found solution to delete NetworkManager but I'm not sure if it works and  doesn't break system.

My "device" field is empty.

Thanks in advance.


Does your OrangePi has an integral WiFi or you have plugged-in a USB WiFi dongle?

https://forum.armbian.com/topic/4876-orange-pi-zero-random-mac-address-split-from-bpi-r1/

https://blogs.gnome.org/thaller/2016/08/26/mac-address-spoofing-in-networkmanager-1-4-0/


« Last Edit: July 19, 2022, 10:05:10 PM by abcd567 »

Taxom

  • New Member
  • *
  • Posts: 17
Re: mlat error
« Reply #33 on: July 20, 2022, 02:44:44 AM »
I have a problem again. ((
Now the mlat is working fine, but rbfeeder cannot connect to the server. Feeders for other services work fine.

I did not touch anything in the settings.

Yes my Pi has an integral WiFi.

abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto
Re: mlat error
« Reply #34 on: July 20, 2022, 02:55:35 AM »
(1) Reboot Pi, then after 10 minutes check if your station connected:
radarbox24.com/stations/EXTRPI014534

(2) You will have two (2) MAC addresses, one for wired connection (eth0) and other for WiFi (wlan0)
« Last Edit: July 20, 2022, 03:00:48 AM by abcd567 »