anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: MLAT not working after Raspi update and selecting yes instead of no for rbfeeder  (Read 6401 times)

0 Members and 1 Guest are viewing this topic.

jayant

  • New Member
  • *
  • Posts: 2
I can report that I had the same problem and fixed it by building the mlat-client from github.

Joejoe1

  • New Member
  • *
  • Posts: 1
I am here because of this issue. Your solution @abcd567 solved it for me, thank you very much!

RZEE

  • New Member
  • *
  • Posts: 24
Quote
When in future any update/upgrade command is run, it will replace healthy mlat-client (which you have built yourself) by the defective mlat-client from RB24 repository.

To prevent this, put your mlat-client on hold by following command
Code: [Select]
sudo apt-mark hold  mlat-client

The responce to above command will be:

mlat-client set on hold..

Can this made undone? if so what's the command for this?

Thanks in advance

abcd567

  • Hero Member
  • *****
  • Posts: 836
  • CYYZ - Toronto
Quote
Quote
When in future any update/upgrade command is run, it will replace healthy mlat-client (which you have built yourself) by the defective mlat-client from RB24 repository.

To prevent this, put your mlat-client on hold by following command
Code: [Select]
sudo apt-mark hold  mlat-client

The responce to above command will be:

mlat-client set on hold..

Can this made undone? if so what's the command for this?

Thanks in advance


Yes, it can be undone by following command

sudo apt-mark unhold mlat-client

Responce:
Canceled hold on mlat-client.


.
« Last Edit: December 12, 2022, 08:39:15 PM by abcd567 »

RZEE

  • New Member
  • *
  • Posts: 24
Quote
Yes, it can be undone by following command

sudo apt-mark unhold mlat-client

Responce:
Canceled hold on mlat-client.

Works! Many thanks again.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33388
Please note that I have been advised as follows that a new MLAT client is available which should fix the previous issue

Package mlat-client is updated in our repository using the latest published version from mutability (0.2.11), but ours is "1:0.2.13" just because we need to change version number to 'force' apt-get to understand that is a new version (the code is the same).
Should work for every new installation by now.

Note that the packages are updated only for the latest (current) version of raspbian OS (AKA Bullseye), not for older versions (buster). If we have A LOT of users running older OS's, we can create a package for that.....but my recommendation is to update the operating system.

Let me know if it is OK

Alan

RZEE

  • New Member
  • *
  • Posts: 24
The installation of the flight feeder works ok, there are still issues installing airband.

E: Unable to locate package rtl-airband-rb

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33388
Airband has nothing to do with ADSB mlat client totally seperate install, ask support to direct to Airband package

Alan

RZEE

  • New Member
  • *
  • Posts: 24
Hi Alan,

Quote
Airband has nothing to do with ADSB mlat client totally seperate install, ask support to direct to Airband package

I expect most of the users including me are aware of this. Your advice to update to bullseye i do not understand, as the transition to Bullseye will break many of the users setup if they have airband included. Radarbox should update their website and include a working airband for Bullseye. Remember Bullseye is released more than 1 year ago......

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33388
It is not my advice it comes from the developer responsible for Linux, if you dont want to do it dont do it.   His advice is based on ADSB requirement not VHF

Regarding your request for Bullseye airband I suggest you contact Airnav with that request as I previously suggested

Alan

ramon.cutanda

  • New Member
  • *
  • Posts: 3
SOLVED See my next message.

Hi,

I have been feeding for radarbox for several months now, but I had to reinstall my Rasperry OS and I decided to use the lastest (for the time being) Pi OS based on Bullseye instead of my previous Buster. The default install for MLAT never worked in my setup:

Code: [Select]
sudo apt-get install mlat-client -y
In order to have MLAT working I had to use the mlat-client_0.2.11_BUSTER_armhf.deb from this repo:

https://github.com/abcd567a/mlat-client-package/releases/

And then block the regular update:

Code: [Select]
sudo apt-mark hold  mlat-client
Now, with Bullseye however, I am completely unable to make MLAT works for radarbox. I have tried both the default install:

Code: [Select]
sudo apt-get install mlat-client -y
And also the mlat-client_0.2.11_BULLSEYE_armhf.deb package from https://github.com/abcd567a/mlat-client-package/releases.

This is my setup:

Code: [Select]
@raspberrypi:~ $ cat /sys/firmware/devicetree/base/model
Raspberry Pi 4 Model B Rev 1.2

Code: [Select]
@raspberrypi:~ $ uname -a
Linux raspberrypi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux

Code: [Select]
@raspberrypi:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 11 (bullseye)
Release:        11
Codename:       bullseye

Code: [Select]
@raspberrypi:~ $ apt-cache policy rbfeeder
rbfeeder:
  Installed: 1:1.0.8+deb11
  Candidate: 1:1.0.8+deb11
  Version table:
 *** 1:1.0.8+deb11 500
        500 https://apt.rb24.com bullseye/main armhf Packages
        100 /var/lib/dpkg/status

Code: [Select]
@raspberrypi:~ $ apt-cache policy mlat-client
mlat-client:
  Installed: 1:0.2.13+deb11
  Candidate: 1:0.2.13+deb11
  Version table:
 *** 1:0.2.13+deb11 500
        500 https://apt.rb24.com bullseye/main armhf Packages
        100 /var/lib/dpkg/status

Code: [Select]
@raspberrypi:~ $ apt-cache policy python3
python3:
  Installed: 3.9.2-3
  Candidate: 3.9.2-3
  Version table:
 *** 3.9.2-3 500
        500 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf Packages
        100 /var/lib/dpkg/status

Code: [Select]
@raspberrypi:~ $ sudo systemctl status rbfeeder
● rbfeeder.service - RBFeeder Service
     Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2023-08-28 12:31:56 CEST; 8min ago
    Process: 669 ExecStartPre=/bin/mkdir /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 682 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 690 ExecStartPre=/bin/touch /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 698 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 702 ExecStartPre=/bin/chown rbfeeder:rbfeeder /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
    Process: 708 ExecStartPre=/bin/setfacl -m u:www-data:rwx /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
   Main PID: 711 (rbfeeder)
      Tasks: 9 (limit: 1599)
        CPU: 1.784s
     CGroup: /system.slice/rbfeeder.service
             └─711 /usr/bin/rbfeeder

Aug 28 12:37:13 raspberrypi rbfeeder[711]: [2023-08-28 12:37:13]  Data sent: 14.6 KB
Aug 28 12:37:13 raspberrypi rbfeeder[711]: [2023-08-28 12:37:13]  Data received: 31 B
Aug 28 12:38:14 raspberrypi rbfeeder[711]: [2023-08-28 12:38:14]  ******** Statistics updated every 60 seconds ********
Aug 28 12:38:14 raspberrypi rbfeeder[711]: [2023-08-28 12:38:14]  Packets sent in the last 60 seconds: 58, Total packets sent since startup: 368
Aug 28 12:38:14 raspberrypi rbfeeder[711]: [2023-08-28 12:38:14]  Data sent: 17.0 KB
Aug 28 12:38:14 raspberrypi rbfeeder[711]: [2023-08-28 12:38:14]  Data received: 31 B
Aug 28 12:39:15 raspberrypi rbfeeder[711]: [2023-08-28 12:39:15]  ******** Statistics updated every 60 seconds ********
Aug 28 12:39:15 raspberrypi rbfeeder[711]: [2023-08-28 12:39:15]  Packets sent in the last 60 seconds: 58, Total packets sent since startup: 426
Aug 28 12:39:15 raspberrypi rbfeeder[711]: [2023-08-28 12:39:15]  Data sent: 19.3 KB
Aug 28 12:39:15 raspberrypi rbfeeder[711]: [2023-08-28 12:39:15]  Data received: 31 B

Code: [Select]
@raspberrypi:~ $ sudo systemctl status mlat-client
● mlat-client.service - LSB: Multilateration client
     Loaded: loaded (/etc/init.d/mlat-client; generated)
     Active: active (exited) since Mon 2023-08-28 12:31:42 CEST; 8min ago
       Docs: man:systemd-sysv-generator(8)
    Process: 379 ExecStart=/etc/init.d/mlat-client start (code=exited, status=0/SUCCESS)
        CPU: 98ms

Aug 28 12:31:41 raspberrypi systemd[1]: Starting LSB: Multilateration client...
Aug 28 12:31:42 raspberrypi mlat-client[379]: Not starting mlat-client daemon, disabled via /etc/default/mlat-client ...
Aug 28 12:31:42 raspberrypi mlat-client[465]:  (warning).
Aug 28 12:31:42 raspberrypi systemd[1]: Started LSB: Multilateration client.

Code: [Select]
@raspberrypi:~ $ cat /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=***********************

sn=EXTRPI005044

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
dump978_enabled=false

I am also feeding for FR24:

Code: [Select]
@raspberrypi:~ $ fr24feed-status
FR24 Feeder/Decoder Process: running.
FR24 Stats Timestamp: 2023-08-28 10:41:23.
FR24 Link: connected [UDP].
FR24 Radar: T-LEMI21.
FR24 Tracked AC: 3.
Receiver: connected (16773 MSGS/0 SYNC).
FR24 MLAT: not running ... failed!

Code: [Select]
@raspberrypi:~ $ sudo cat /etc/fr24feed.ini
receiver="beast-tcp"
fr24key="582b0713bf2f7221"
host="127.0.0.1:30005"
bs="no"
raw="no"
logmode="0"
logpath="/var/log/fr24feed"
mlat="no"
mlat-without-gps="no"

Any help will be greatly appreciated.

Kind regards,
« Last Edit: August 29, 2023, 03:19:31 PM by ramon.cutanda »

ramon.cutanda

  • New Member
  • *
  • Posts: 3
I found the solution to my problem here:

https://forum.radarbox24.com/index.php?topic=101771.msg389571#msg389571

The section [client] of my rbfeeder.ini lacked the info about latitude, longitude and altitude:

lat=xx.xxxxxx
lon=yy.yyyyyy
alt=zzz

I hope this info will be helpful for others, but perhaps you could consider adding this info into the official guide:

https://www.radarbox.com/sharing-data/guide

Kind regards,
« Last Edit: August 28, 2023, 11:34:35 AM by ramon.cutanda »

flygpagen

  • New Member
  • *
  • Posts: 22
Seems mlat-client installed from RB24 site (using command sudo apt install mlat-client) has some defect. Better purge it, then build & install from source code

(1) First purge existing package
Code: [Select]
sudo apt purge mlat-client


(2) Install dependencies and tools required to build package from source-code
Code: [Select]
sudo apt update -y
sudo apt install -y git curl build-essential debhelper python-dev python3-dev

(3) Downloaded source code and build mlat-client's installation package.
Code: [Select]
cd
git clone https://github.com/mutability/mlat-client.git

cd mlat-client
sudo apt install -y dh-python
sudo dpkg-buildpackage -b -uc


(4) Install newly built package by following command
Code: [Select]
cd
sudo dpkg -i mlat-client_*.deb 

Hi! Trying to get the mlat-client to work for my station on Buster following this process, however I get an error message when compiling.

Code: [Select]
dpkg-buildpackage: info: source package mlat-client
dpkg-buildpackage: info: source version 0.2.13
dpkg-buildpackage: info: source distribution stable
dpkg-buildpackage: info: source changed by Oliver Jowett <[email protected]>
dpkg-buildpackage: info: host architecture armhf
 dpkg-source --before-build .
 debian/rules clean
dh clean --with python3 --buildsystem=pybuild
   dh_auto_clean -O--buildsystem=pybuild
        pybuild --clean -i python{version} -p 3.7
I: pybuild base:217: python3.7 setup.py clean
Traceback (most recent call last):
  File "setup.py", line 19, in <module>
    from setuptools import setup, Extension
ModuleNotFoundError: No module named 'setuptools'
E: pybuild pybuild:341: clean: plugin distutils failed with: exit code=1: python3.7 setup.py clean
dh_auto_clean: error: pybuild --clean -i python{version} -p 3.7 returned exit code 13
make: *** [debian/rules:10: clean] Error 13
dpkg-buildpackage: error: debian/rules clean subprocess returned exit status 2

Since Radarbox also says I need to update my RBFeeder I did so, but it turned out it was already latest version. Am I doing something wrong when compiling?

abcd567

  • Hero Member
  • *****
  • Posts: 836
  • CYYZ - Toronto
@flygpagen:

For Buster, no need to compile from source-code. The mlat-client package for Buster is available in Radarbox24 repositories, and can very easily be installed by following commands:
Code: [Select]
sudo apt update   

sudo apt install mlat-client 



.
s
« Last Edit: December 16, 2023, 09:05:22 PM by abcd567 »

flygpagen

  • New Member
  • *
  • Posts: 22
Thanks for replying, but both my installs have MLAT-failure as reported in this thread also after update/re-install, so I tried the above.