anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: MLAT not working after Raspi update and selecting yes instead of no for rbfeeder  (Read 466 times)

0 Members and 1 Guest are viewing this topic.

DZpower

  • New Member
  • *
  • Posts: 25
My MLAT does not work since i did an update on my Raspi
i did re-install RBFEEDER via CLI  but still no luck with getting MLAT back

DZpower

  • New Member
  • *
  • Posts: 25
i can provide logs upon request and would appreciate any help or suggestion

abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto
(1) First run this command
Code: [Select]
sudo apt update

(2) Next issue following commands and post their output
Code: [Select]
uname -a   

lsb_release -a

apt-cache policy rbfeeder 

apt-cache policy mlat-client

apt-cache policy python3   

sudo systemctl status rbfeeder


(3) Also post output of following command (replace key by xxxxxx when posting)
Code: [Select]

cat /etc/rbfeeder.ini 

.

DZpower

  • New Member
  • *
  • Posts: 25
when i run the sudo apt  update it does show that it's all up to date

When i run the sudo nano command

[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxx

sn=EXTRPI026653

lat=42.381765999999999

lon=-71.097617

alt=41

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client

[dump978]
dump978_enabled=false

DZpower

  • New Member
  • *
  • Posts: 25
 Raspbian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

rbfeeder:
  Installed: 1:1.0.8+deb10
  Candidate: 1:1.0.8+deb10
  Version table:
 *** 1:1.0.8+deb10 500

mlat-client:
  Installed: 0.2.11
  Candidate: 0.2.11
  Version table:
 *** 0.2.11 500

DZpower

  • New Member
  • *
  • Posts: 25
it does not allow me to copy and past result of  the rbfeeder  this post bock it as spam or some filters

i see a a lot of errors

 PermissionError: [Errno 13] Permission denied: '/run/ml
  open(pidfile, 'w').write(pid)
usr/bin/mlat-client", line 108, in <module>
open(pidfile, 'w').write(pid)

DZpower

  • New Member
  • *
  • Posts: 25
i see some errors

"PermissionError: [Errno 13] Permission denied: '/run/mlat-client.pid"

File "/usr/bin/mlat-client", line 108, in <module>
open(pidfile, 'w').write(pid)
 PermissionError: [Errno 13] Permission denied: '/run/mlat-client.pid'
Traceback (most recent call last):
File "/usr/bin/mlat-client", line 108, in <module>"

DZpower

  • New Member
  • *
  • Posts: 25
(1) First run this command
Code: [Select]
sudo apt update

(2) Next issue following commands and post their output
Code: [Select]
uname -a   

lsb_release -a

apt-cache policy rbfeeder 

apt-cache policy mlat-client

apt-cache policy python3   

sudo systemctl status rbfeeder


(3) Also post output of following command (replace key by xxxxxx when posting)
Code: [Select]

cat /etc/rbfeeder.ini 

.please check your private message

abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto
Seems mlat-client installed from RB24 site (using command sudo apt install mlat-client) has some defect. Better purge it, then build & install from source code

(1) First purge existing package
Code: [Select]
sudo apt purge mlat-client


(2) Install dependencies and tools required to build package from source-code
Code: [Select]
sudo apt update -y
sudo apt install -y git curl build-essential debhelper python-dev python3-dev

(3) Downloaded source code and build mlat-client's installation package.
Code: [Select]
cd
git clone https://github.com/mutability/mlat-client.git

cd mlat-client
sudo apt install -y dh-python
sudo dpkg-buildpackage -b -uc


(4) Install newly built package by following command
Code: [Select]
cd
sudo dpkg -i mlat-client_*.deb 


« Last Edit: July 16, 2022, 11:48:13 PM by abcd567 »

DZpower

  • New Member
  • *
  • Posts: 25
worked like a charm :)
Thank You so much :) Kudos to your expertise

abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto

Glad to know your problem is solved   :)



abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto
When in future any update/upgrade command is run, it will replace healthy mlat-client (which you have built yourself) by the defective mlat-client from RB24 repository.

To prevent this, put your mlat-client on hold by following command
Code: [Select]
sudo apt-mark hold  mlat-client 

The responce to above command will be:

mlat-client set on hold..




Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32243
abcd, have you advised Airnav  of their defective MLAT client?  If not are you aware of the defect and I can advise

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 671
  • CYYZ - Toronto
Alan, no, I have not advised AirNav about the defective mlat client because:
(1) up till now only 2 cases have been reported in forum
(2) I cannot make out what is exactly the defecti, is it because of a corrupted files or because of some changes made by RB24 developers in the source code.

If you like you can inform support with links to the two lates threads  on this issue.

Regards
abcd

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32243
Thanks, will do

Alan