AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: No Data and no aircraft on RB Site - Linux piaware  (Read 685 times)

0 Members and 1 Guest are viewing this topic.

GuruCoz

  • New Member
  • *
  • Posts: 3
No Data and no aircraft on RB Site - Linux piaware
« on: June 07, 2022, 09:03:57 AM »
I am running piaware 5.10.92-v7l+ on PI4 and was successfully feeding data to FA and RB using dump1090-fa and dump978-fa. Three days ago the radarbox.com website indicated "No Data" (yellow line). However, the site is incrementing ADS-b (with position) counters, but not displaying any aircraft. PLease help? More data below.

[email protected]:~ $ sudo piaware-status
PiAware master process (piaware) is running with pid 483.
PiAware ADS-B client (faup1090) is running with pid 583.
PiAware ADS-B UAT client (faup978) is running with pid 9253.
PiAware mlat client (fa-mlat-client) is running with pid 8788.
Local ADS-B receiver (dump1090-fa) is running with pid 473.
Local ADS-B UAT receiver (dump978-fa) is running with pid 9227.

dump1090-fa (pid 473) is listening for ES connections on port 30005.
dump978-fa (pid 9227) is listening for UAT connections on port 30978.
faup1090 is connected to the ADS-B receiver.
faup978 is connected to the ADS-B UAT receiver.
piaware is connected to FlightAware.

dump978 is producing data on localhost:30978.
dump1090 is producing data on localhost:30005.

[email protected]:~ $ more /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=x

sn=EXTRPI014656

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
dump978_enabled=true
dump978_port=30979

● rbfeeder.service - RBFeeder Service
     Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2022-06-06 19:42:07 UTC; 12h ago
    Process: 487 ExecStartPre=/bin/mkdir /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 496 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 497 ExecStartPre=/bin/touch /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 501 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 503 ExecStartPre=/bin/chown rbfeeder:rbfeeder /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
    Process: 504 ExecStartPre=/bin/setfacl -m u:www-data:rwx /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
   Main PID: 506 (rbfeeder)
      Tasks: 10 (limit: 4335)
        CPU: 3min 56.865s
     CGroup: /system.slice/rbfeeder.service
             └─506 /usr/bin/rbfeeder

Jun 07 08:31:01 piaware rbfeeder[506]: [2022-06-07 08:31:01]  Data sent: 4.4 MB
Jun 07 08:31:01 piaware rbfeeder[506]: [2022-06-07 08:31:01]  Data received: 31 B
Jun 07 08:32:02 piaware rbfeeder[506]: [2022-06-07 08:32:02]  ******** Statistics updated every 60 seconds ********
Jun 07 08:32:02 piaware rbfeeder[506]: [2022-06-07 08:32:02]  Packets sent in the last 60 seconds: 41, Total packets sent since startup: 136110
Jun 07 08:32:02 piaware rbfeeder[506]: [2022-06-07 08:32:02]  Data sent: 4.4 MB
Jun 07 08:32:02 piaware rbfeeder[506]: [2022-06-07 08:32:02]  Data received: 31 B
Jun 07 08:33:03 piaware rbfeeder[506]: [2022-06-07 08:33:03]  ******** Statistics updated every 60 seconds ********
Jun 07 08:33:03 piaware rbfeeder[506]: [2022-06-07 08:33:03]  Packets sent in the last 60 seconds: 42, Total packets sent since startup: 136152
Jun 07 08:33:03 piaware rbfeeder[506]: [2022-06-07 08:33:03]  Data sent: 4.4 MB
Jun 07 08:33:03 piaware rbfeeder[506]: [2022-06-07 08:33:03]  Data received: 31 B

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32151
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #1 on: June 07, 2022, 12:03:01 PM »
I note that you have
dump978-fa (pid 9227) is listening for UAT connections on port 30978
and
dump978 is producing data on localhost:30978.
and then

[dump978]
dump978_enabled=true
dump978_port=30979

2 different ports stated, 30978 and 30979

Also see this thread that may help https://forum.radarbox24.com/index.php?topic=106241.0

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 644
  • CYYZ - Toronto
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #2 on: June 07, 2022, 03:56:26 PM »
I note that you have
dump978-fa (pid 9227) is listening for UAT connections on port 30978
and
dump978 is producing data on localhost:30978.
and then

[dump978]
dump978_enabled=true
dump978_port=30979

2 different ports stated, 30978 and 30979


This is correct.
The dump978-fa outputs data on two different ports 30978 & 30979 in two different formats "raw" and "json".

Flightaware's datafeeder "piaware" uses data in "raw" format which is available from port 30978, and that is what "piaware status" output shows.

Radarbox24's datafeeder "rbfeeder" use data in "json" format which is available from port 30979, so it is configured to use port 30979. That is what "file rbfeeder.ini" has.


« Last Edit: June 07, 2022, 04:18:17 PM by abcd567 »

abcd567

  • Hero Member
  • *****
  • Posts: 644
  • CYYZ - Toronto
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #3 on: June 07, 2022, 04:52:54 PM »

     CGroup: /system.slice/rbfeeder.service
             └─506 /usr/bin/rbfeeder

Jun 07 08:31:01 piaware rbfeeder[506]: [2022-06-07 08:31:01]  Data sent: 4.4 MB
Jun 07 08:31:01 piaware rbfeeder[506]: [2022-06-07 08:31:01]  Data received: 31 B
Jun 07 08:32:02 piaware rbfeeder[506]: [2022-06-07 08:32:02]  ******** Statistics updated every 60 seconds ********

In output of command "sudo systemctl status rbfeeder", the 2nd line in "CGroup:" (for mlat) is missing.

Below is my output:

Quote
     CGroup: /system.slice/rbfeeder.service
             ├─564 /usr/bin/rbfeeder
             └─610 /usr/bin/python3.9 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --lat 43>


To restore MLAT, simply REBOOT RPi
This problem is due to a bug in Radarbox24 supplied mlat-client. If you restart rbfeeder by command "sudo systemctl restart rbfeeder", the mlat will not restart, and mlat line will disappear from rbfeeder's status. The only way to restart MLAT it is to Reboot the Pi.

I have solved this problem by purging the mlat-client which I installed by "sudo apt install mlat-client" and built & installed mlat-client from its source-code at https://github.com/mutability/mlat-client
.
« Last Edit: June 07, 2022, 04:58:14 PM by abcd567 »

abcd567

  • Hero Member
  • *****
  • Posts: 644
  • CYYZ - Toronto
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #4 on: June 07, 2022, 05:09:30 PM »
I am running piaware 5.10.92-v7l+ on PI4 and was successfully feeding data to FA and RB using dump1090-fa and dump978-fa. Three days ago the radarbox.com website indicated "No Data" (yellow line). However, the site is incrementing ADS-b (with position) counters, but not displaying any aircraft. PLease help? More data below.


sn=EXTRPI014656


Dont worry, at your setup, everything working OK. The poroblem is with Radarbox24 servers. Just for example, right now my following site, although working OK, is showing YELLOW line in progress:

https://www.radarbox.com/stations/EXTRPI000008
.
« Last Edit: June 07, 2022, 05:13:51 PM by abcd567 »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32151
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #5 on: June 07, 2022, 05:32:38 PM »
Thanks abcd.  While they are both are working and yellow the are not showing aircraft on the map

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 644
  • CYYZ - Toronto
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #6 on: June 07, 2022, 05:37:10 PM »
Yes, yellow line & no aircraft. See attached screenshot of my station EXTRPI000008
Something wrong with RB24 servers. Need to notify support.

My other two sites are showing OK

https://www.radarbox.com/stations/EXTRPI000035

https://www.radarbox.com/stations/EXTRPI000036


« Last Edit: June 07, 2022, 05:42:04 PM by abcd567 »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32151
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #7 on: June 07, 2022, 06:32:15 PM »
Neither of those two are showing either

Alan

GuruCoz

  • New Member
  • *
  • Posts: 3
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #8 on: June 07, 2022, 07:51:48 PM »
This is great info all! Thank you so much for responding. I appreciate it!

I have not spent any cycles getting mlat on RB working, so thanks for that find.

Do I contact RB support, or do they monitor this thread?

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32151
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #9 on: June 07, 2022, 08:00:13 PM »
They dont monitor, contact [email protected]

Alan

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32151
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #10 on: June 08, 2022, 10:56:52 AM »
Stations not showing plots, Airnav advised earlier today

Alan

GuruCoz

  • New Member
  • *
  • Posts: 3
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #11 on: June 08, 2022, 11:03:42 AM »
FYSA
Sent ticket request to support last night and within 5 minutes I was asked to restart rbfeeder and data aircraft appeared on web and green status began.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32151
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #12 on: June 08, 2022, 11:41:34 AM »
Good to know

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 644
  • CYYZ - Toronto
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #13 on: June 08, 2022, 05:15:50 PM »
I did NOT email support,  but have several times restarted rbfeeder and several times rebooted Pi,  but the problem persists.  Please see screenshot I took just now.

This shows that the problem is NOT at the feeder Pi.  When Support was contacted by the user,  they fixed it at their end on RB24 server and after that advised user to restart rbfeeder.

I will now send email to support and see what happens.



Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32151
Re: No Data and no aircraft on RB Site - Linux piaware
« Reply #14 on: June 08, 2022, 05:26:37 PM »
I emailed to advise at 0801 UK time this morning.  They are showing on the global map but not on individual stations

Alan