anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: piaware rbfeeder, no data  (Read 365 times)

0 Members and 1 Guest are viewing this topic.

Dreamglider

  • New Member
  • *
  • Posts: 3
piaware rbfeeder, no data
« on: June 06, 2022, 02:50:18 PM »
i have 3x Rpi's running PiAware feeding data to flightaware, planefinder, Flightradar and adsbexchange.
i also have rbfeeder installed and claimed on all 3 but the website says only "No data" (The other sites are all getting good data)

what am i doing wrong ?

thanks

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32156
Re: piaware rbfeeder, no data
« Reply #1 on: June 06, 2022, 03:06:18 PM »
I would imagine this tread will help

Alan

Dreamglider

  • New Member
  • *
  • Posts: 3
Re: piaware rbfeeder, no data
« Reply #2 on: June 06, 2022, 06:49:15 PM »
what tread would that be ?

edited*

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32156
Re: piaware rbfeeder, no data
« Reply #3 on: June 06, 2022, 06:53:30 PM »

abcd567

  • Hero Member
  • *****
  • Posts: 644
  • CYYZ - Toronto
Re: piaware rbfeeder, no data
« Reply #4 on: June 06, 2022, 10:39:25 PM »
i have 3x Rpi's running PiAware feeding data to flightaware, planefinder, Flightradar and adsbexchange.
i also have rbfeeder installed and claimed on all 3 but the website says only "No data" (The other sites are all getting good data)

what am i doing wrong ?


Please post output of following commands
Note: replace your feeder keys,  latitude and longitude by xxxxx when posting in forum.

Code: [Select]

cat /etc/rbfeeder.ini   

cat /etc/fr24feed.ini   

sudo systemctl status dump1090-fa 
« Last Edit: June 06, 2022, 10:44:26 PM by abcd567 »

Dreamglider

  • New Member
  • *
  • Posts: 3
Re: piaware rbfeeder, no data
« Reply #5 on: June 07, 2022, 01:04:35 AM »
[email protected]:~ $ cat /etc/rbfeeder.ini   
[client]
network_mode=false
log_file=/var/log/rbfeeder.log

key=sdvsdvsdvsdvsdvsdvsdvsdvsdv

sn=sdsdsdsdvsdvvsdvsd

lat=61

lon=-6

alt=35

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true
[email protected]:~ $ cat /etc/fr24feed.ini   
receiver="avr-tcp"
fr24key="wefwefwefwefwef"
host="127.0.0.1:30002"
bs="no"
raw="no"
logmode="2"
logpath="/var/log/fr24feed"
mlat="yes"
mlat-without-gps="yes"
[email protected]:~ $ sudo systemctl status dump1090-fa 
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
     Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2022-06-06 05:17:11 WEST; 20h ago
       Docs: https://flightaware.com/adsb/piaware/
   Main PID: 546 (dump1090-fa)
      Tasks: 1 (limit: 2059)
        CPU: 10min 45.336s
     CGroup: /system.slice/dump1090-fa.service
             └─546 /usr/bin/dump1090-fa --quiet --device-type none --fix --lat 61 --lon -6 --max-range 360 --net-ro-port 30002 --net-sbs-port 300>

Jun 06 05:17:11 piaware systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Jun 06 05:17:13 piaware dump1090-fa[546]: Mon Jun  6 05:17:13 2022 WEST  dump1090-fa 7.2 starting up.
Jun 06 05:17:13 piaware dump1090-fa[546]: Net-only mode, no SDR device or file open.
lines 1-13/13 (END)

abcd567

  • Hero Member
  • *****
  • Posts: 644
  • CYYZ - Toronto
Re: piaware rbfeeder, no data
« Reply #6 on: June 07, 2022, 04:14:45 AM »
==== RB24 FEEDER - Stting is wrong ====

(1) Open file rbfeeder.ini to edit by following command:
Code: [Select]
sudo nano  /etc/rbfeeder.ini   

(2) In file opened, make change as shown in RED
(i.e. change "network_mode=false" to "network_mode=true")

[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=sdvsdvsdvsdvsdvsdvsdvsdvsdv
sn=sdsdsdsdvsdvvsdvsd
lat=61
lon=-6
alt=35
[network]
mode=beast
external_port=30005
external_host=127.0.0.1
[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client
[dump978]
#dump978_enabled=true


(3) Save file  (Ctrl+O) and after saving, close (Ctrl+x)

(4) Restart RB24 feeder
Code: [Select]
sudo systemctl restart rbfeeder   





===== DUMP1090-FA - Setting is wrong =======
Quote
[email protected]:~ $ sudo systemctl status dump1090-fa 
     CGroup: /system.slice/dump1090-fa.service
             └─546 /usr/bin/dump1090-fa --quiet --device-type none --fix --lat 61 --lon -6 --max-range 360 --net-ro-port 30002 --net-sbs-port 300>
Jun 06 05:17:13 piaware dump1090-fa[546]: Net-only mode, no SDR device or file open.


(5) Setting is wrong. Please issue following commands to correct it:

Code: [Select]
sudo piaware-config receiver-type rtlsdr

sudo systemctl restart piaware 

sudo systemctl restart dump1090-fa 

(6) REBOOT PI
Code: [Select]
sudo reboot

« Last Edit: June 07, 2022, 04:29:13 AM by abcd567 »