anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Reinstalled and refuses to work !!!!!  (Read 1398 times)

0 Members and 1 Guest are viewing this topic.

Av8tor_from_Argentina

  • New Member
  • *
  • Posts: 26
Reinstalled and refuses to work !!!!!
« on: March 28, 2022, 01:07:26 PM »
Good morning. As the subject stats, I´ve reinstalled the app again (reformatted SD card, Bullseye OS) and Installed Flightradar, Flightaware (both works fine) but radarbox refuses to work. In previous installation the 3 were working fine...

[email protected]:~ $ sudo systemctl status rbfeeder
● rbfeeder.service - RBFeeder Service
     Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2022-03-25 17:24:07 -03; 2 days ago
    Process: 484 ExecStartPre=/bin/mkdir /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 493 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/run/rbfeeder (code=exited, status=0/SUCCESS)
    Process: 497 ExecStartPre=/bin/touch /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 511 ExecStartPre=/bin/chown rbfeeder:rbfeeder /var/log/rbfeeder.log (code=exited, status=0/SUCCESS)
    Process: 515 ExecStartPre=/bin/chown rbfeeder:rbfeeder /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
    Process: 520 ExecStartPre=/bin/setfacl -m u:www-data:rwx /etc/rbfeeder.ini (code=exited, status=0/SUCCESS)
   Main PID: 528 (rbfeeder)
      Tasks: 9 (limit: 1597)
        CPU: 15min 23.306s
     CGroup: /system.slice/rbfeeder.service
             └─528 /usr/bin/rbfeeder

Mar 28 10:00:39 raspberry rbfeeder[528]: [2022-03-28 10:00:39]  ******** Statistics updated every 60 seconds ********
Mar 28 10:00:39 raspberry rbfeeder[528]: [2022-03-28 10:00:39]  Packets sent in the last 60 seconds: 1, Total packets sent sinc>
Mar 28 10:00:39 raspberry rbfeeder[528]: [2022-03-28 10:00:39]  Data sent: 211.4 KB
Mar 28 10:00:39 raspberry rbfeeder[528]: [2022-03-28 10:00:39]  Data received: 0 B
Mar 28 10:01:26 raspberry rbfeeder[528]: [2022-03-28 10:01:26]  Connection established.
Mar 28 10:01:37 raspberry rbfeeder[528]: [2022-03-28 10:01:37]  Could not start connection. Timeout.
Mar 28 10:01:40 raspberry rbfeeder[528]: [2022-03-28 10:01:40]  ******** Statistics updated every 60 seconds ********
Mar 28 10:01:40 raspberry rbfeeder[528]: [2022-03-28 10:01:40]  Packets sent in the last 60 seconds: 1, Total packets sent sinc>
Mar 28 10:01:40 raspberry rbfeeder[528]: [2022-03-28 10:01:40]  Data sent: 211.5 KB
Mar 28 10:01:40 raspberry rbfeeder[528]: [2022-03-28 10:01:40]  Data received: 0 B


[email protected]:~ $ less /var/log/rbfeeder.log
[2022-03-25 09:18:06]  Starting RBFeeder Version 1.0.7 (build 20220125172500)
[2022-03-25 09:18:06]  Using configuration file: /etc/rbfeeder.ini
[2022-03-25 09:18:06]  Network-mode enabled.
[2022-03-25 09:18:06]           Remote host to fetch data: 127.0.0.1
[2022-03-25 09:18:06]           Remote port: 30005
[2022-03-25 09:18:06]           Remote protocol: BEAST
[2022-03-25 09:18:06]  Using GNSS (when available)
[2022-03-25 09:18:06]  Start date/time: 2022-03-25 09:18:06
[2022-03-25 09:18:06]  Socket for ANRB created. Waiting for connections on port 32088
[2022-03-25 09:18:07]  Connection established.
[2022-03-25 09:18:18]  Could not start connection. Timeout.
[2022-03-25 09:20:36]  Starting RBFeeder Version 1.0.7 (build 20220125172500)
[2022-03-25 09:20:36]  Using configuration file: /etc/rbfeeder.ini
[2022-03-25 09:20:36]  Network-mode enabled.
[2022-03-25 09:20:36]           Remote host to fetch data: 127.0.0.1
[2022-03-25 09:20:36]           Remote port: 30005
[2022-03-25 09:20:36]           Remote protocol: BEAST
[2022-03-25 09:20:36]  Using GNSS (when available)
[2022-03-25 09:20:36]  Starting RBFeeder Version 1.0.7 (build 20220125172500)
[2022-03-25 09:20:36]  Using configuration file: /etc/rbfeeder.ini
[2022-03-25 09:20:36]  Network-mode enabled.
[2022-03-25 09:20:36]           Remote host to fetch data: 127.0.0.1
[2022-03-25 09:20:36]           Remote port: 30005
[2022-03-25 09:20:36]           Remote protocol: BEAST
[2022-03-25 09:20:36]  Using GNSS (when available)
[2022-03-25 09:20:36]  Starting RBFeeder Version 1.0.7 (build 20220125172500)
[2022-03-25 09:20:36]  Using configuration file: /etc/rbfeeder.ini
[2022-03-25 09:20:36]  Network-mode enabled.
[2022-03-25 09:20:36]           Remote host to fetch data: 127.0.0.1
[2022-03-25 09:20:36]           Remote port: 30005
[2022-03-25 09:20:36]           Remote protocol: BEAST
[2022-03-25 09:20:36]  Using GNSS (when available)
[2022-03-25 09:20:36]  Starting RBFeeder Version 1.0.7 (build 20220125172500)
[2022-03-25 09:20:36]  Using configuration file: /etc/rbfeeder.ini
[2022-03-25 09:20:36]  Network-mode enabled.
[2022-03-25 09:20:36]           Remote host to fetch data: 127.0.0.1
[2022-03-25 09:20:36]           Remote port: 30005
[2022-03-25 09:20:36]           Remote protocol: BEAST
[2022-03-25 09:20:36]  Using GNSS (when available)
[2022-03-25 09:20:37]  Starting RBFeeder Version 1.0.7 (build 20220125172500)
[2022-03-25 09:20:37]  Using configuration file: /etc/rbfeeder.ini
[2022-03-25 09:20:37]  Network-mode enabled.
[2022-03-25 09:20:37]           Remote host to fetch data: 127.0.0.1
[2022-03-25 09:20:37]           Remote port: 30005
[2022-03-25 09:20:37]           Remote protocol: BEAST


[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxx

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=false



Regards

abcd567

  • Hero Member
  • *****
  • Posts: 674
  • CYYZ - Toronto
Re: Reinstalled and refuses to work !!!!!
« Reply #1 on: March 28, 2022, 04:07:09 PM »
Check you rbfeeder key you have entered in file /etc/rbfeeder.ini
Code: [Select]
sudo systemctl stop rbfeeder

sudo rbfeeder --setkey ‹your sharing key›

Does last command outputs that "connection accepted by AirNav server", and prints your station number EXTRPIxxxxxx ?

If it does, press Ctrl and C keys togather, then issue following command

Code: [Select]
sudo systemctl restart rbfeeder


.

.
« Last Edit: March 28, 2022, 04:11:29 PM by abcd567 »

zxenith

  • New Member
  • *
  • Posts: 4
Re: Reinstalled and refuses to work !!!!!
« Reply #2 on: March 29, 2022, 01:39:29 AM »
It looks like you are in network mode

If you only want to feed to Rbox then Run

sudo rbfeeder --set-network-mode off --no-start

================================
If you are also running MM2

Then this is an example of the correct formatting (use your own keys, long lat )

[client]
network_mode=false
log_file=/var/log/rbfeeder.log
key=aaaaaaaaaaaaaaaaaaaa
sn=E111111111
lat=11.111111111
lon=-111.1111111111
alt=11

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=false


=========================

For MM2 config example (use your own long lat, and .sqb optional )

--location 11.1111111111:-111.111111111
--inConnectId 127.0.0.1:30004:ADSB
--inConnectId 127.0.0.1:30105:MLAT
--db /home/pi/DATA/BaseStation.sqb <---only if you have
–-db /home/pi/data/flightroute-icao.sqb <----only if you have
--web 8787


 

Av8tor_from_Argentina

  • New Member
  • *
  • Posts: 26
Re: Reinstalled and refuses to work !!!!!
« Reply #3 on: March 29, 2022, 02:06:46 AM »
amazing... now I want to post and get this message...

CleanTalk: *** Forbidden. Please enable JavaScript. Contains contacts. Message seems to be spam. ***

abcd567

  • Hero Member
  • *****
  • Posts: 674
  • CYYZ - Toronto
Re: Reinstalled and refuses to work !!!!!
« Reply #4 on: March 29, 2022, 02:50:08 AM »
It looks like you are in network mode

If you only want to feed to Rbox then Run

sudo rbfeeder --set-network-mode off --no-start

================================
If you are also running MM2

Then this is an example of the correct formatting (use your own keys, long lat )

[client]
network_mode=false
log_file=/var/log/rbfeeder.log
key=aaaaaaaaaaaaaaaaaaaa
sn=E111111111
lat=11.111111111
lon=-111.1111111111
alt=11

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=false


=========================

For MM2 config example (use your own long lat, and .sqb optional )

--location 11.1111111111:-111.111111111
--inConnectId 127.0.0.1:30004:ADSB
--inConnectId 127.0.0.1:30105:MLAT
--db /home/pi/DATA/BaseStation.sqb <---only if you have
–-db /home/pi/data/flightroute-icao.sqb <----only if you have
--web 8787

As I understand, @Av8tor_from_Argentina is already feeding FR24 and Flightaware. That mean either dump1090-fa or dump1090-mutability is installed and running and producing beast format data on port 30005.

In above condition "network_mode=true" is 100% correct setting. With this setting, the rbfeeder will use the beast data at port 30005 of dump1090-fa or dump1090-mutability.

If setting is changed to "network_mode=false", the integral dump1090-rb of rbfeeder will start. Now there will be two dump1090 running, with only one Dongle available. This will cause conflict and failure.

Please do not use network_mode=false if you already have installed dump1090-fa or dump1090-mutability.

.In case you want to run Radarbox24's dump1090-rb, you must first uninstall other dump1090 (fa or mutability) and only after that change setting to "network_mode=false".


.
« Last Edit: March 29, 2022, 03:31:36 AM by abcd567 »

zxenith

  • New Member
  • *
  • Posts: 4
Re: Reinstalled and refuses to work !!!!!
« Reply #5 on: March 29, 2022, 04:49:29 PM »
Thank you for the clarification

Av8tor_from_Argentina

  • New Member
  • *
  • Posts: 26
Re: Reinstalled and refuses to work !!!!!
« Reply #6 on: March 30, 2022, 08:08:35 PM »
Good evening. I only have DUMP1090-fa installed and running. Network mode is false...

What else to try ?

Is there any series of commands in order to see why RB denies to connect?

Why FR and FA works fine ???

IN FR windowed status page:

FR24 Link:   Connected via UDP
FR24 Radar Code:   T-SADP31
Local IP(s):   192.168.1.106, xxxxxxxxxxx
Aircraft Tracked:
(ModeS & ADS-B)   11
Aircraft Uploaded:   8
Receiver:   beast-tcp, Connected
MLAT running:   YES
« Last Edit: March 30, 2022, 08:10:48 PM by Av8tor_from_Argentina »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32252
Re: Reinstalled and refuses to work !!!!!
« Reply #7 on: March 30, 2022, 08:43:00 PM »
abc stated

Please do not use network_mode=false if you already have installed dump1090-fa or dump1090-mutability.

While running dump1090-fa you should have network mode=true

Alan

Av8tor_from_Argentina

  • New Member
  • *
  • Posts: 26
Re: Reinstalled and refuses to work !!!!!
« Reply #8 on: March 31, 2022, 08:15:11 PM »
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=6a8aaxxxxxxxxxxxxxxxe39

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=false


Av8tor_from_Argentina

  • New Member
  • *
  • Posts: 26
Re: Reinstalled and refuses to work !!!!!
« Reply #9 on: April 01, 2022, 12:50:32 AM »
not a single response. Uninstalled and reinstalled again.. NOTHING, NADA, ZERO...

abcd567

  • Hero Member
  • *****
  • Posts: 674
  • CYYZ - Toronto
Re: Reinstalled and refuses to work !!!!!
« Reply #10 on: April 01, 2022, 01:05:16 AM »
not a single response. Uninstalled and reinstalled again.. NOTHING, NADA, ZERO...


Please post output of following commands:

Code: [Select]
apt-cache policy rbfeeder 


Code: [Select]
sudo systemctl stop rbfeeder

sudo rbfeeder --setkey xxxxxxxxxxxxxxxxx
(In above comand, replace xxxxxxxxxxxxx by your actual key)


« Last Edit: April 01, 2022, 06:32:06 AM by abcd567 »

Av8tor_from_Argentina

  • New Member
  • *
  • Posts: 26
Re: Reinstalled and refuses to work !!!!!
« Reply #11 on: April 01, 2022, 11:08:31 AM »
[email protected]:~ $ apt-cache policy rbfeeder
rbfeeder:
  Installed: 1:1.0.7
  Candidate: 1:1.0.7
  Version table:
 *** 1:1.0.7 500
        500 https://apt.rb24.com bullseye/main armhf Packages
        100 /var/lib/dpkg/status

[email protected]:~ $ sudo rbfeeder --setkey "station identifier"
[2022-04-01 08:02:20]  Starting RBFeeder Version 1.0.7 (build 20220125172500)
[2022-04-01 08:02:20]  Using configuration file: /etc/rbfeeder.ini
[2022-04-01 08:02:20]  Network-mode enabled.
[2022-04-01 08:02:20]           Remote host to fetch data: 127.0.0.1
[2022-04-01 08:02:20]           Remote port: 30005
[2022-04-01 08:02:20]           Remote protocol: BEAST
[2022-04-01 08:02:20]  Using GNSS (when available)
[2022-04-01 08:02:20]  Start date/time: 2022-04-01 08:02:20
[2022-04-01 08:02:20]  Socket for ANRB created. Waiting for connections on port 32088
[2022-04-01 08:02:21]  Connection established.
[2022-04-01 08:02:31]  Could not start connection. Timeout.

again same response from system

abcd567

  • Hero Member
  • *****
  • Posts: 674
  • CYYZ - Toronto
Re: Reinstalled and refuses to work !!!!!
« Reply #12 on: April 01, 2022, 05:06:00 PM »
Did you first remove rbfeeder, then install a fresh copy?
OR
Did you install a fresh copy over existing copy?

Seems reinstall did NOT remove some corrupted files of old install.

Please do this to first purge the existing install, then install a fresh copy:

Code: [Select]
sudo apt purge rbfeeder 

sudo rm /etc/rbfeeder.ini 

sudo apt update 

sudo apt install rbfeeder   


« Last Edit: April 01, 2022, 05:10:59 PM by abcd567 »

Av8tor_from_Argentina

  • New Member
  • *
  • Posts: 26
Re: Reinstalled and refuses to work !!!!!
« Reply #13 on: April 02, 2022, 02:25:36 AM »
CleanTalk: *** Forbidden. Please enable JavaScript. Contains contacts. ***

Why I receive this message every time that I try to paste a series of commands and their response... ????

abcd567

  • Hero Member
  • *****
  • Posts: 674
  • CYYZ - Toronto
Re: Reinstalled and refuses to work !!!!!
« Reply #14 on: April 02, 2022, 07:27:39 AM »
CleanTalk: *** Forbidden. Please enable JavaScript. Contains contacts. ***

Why I receive this message every time that I try to paste a series of commands and their response... ????

(1) Which browser you are using? Use another browser.

(2) You keep on saying your OS is bullseye, without telling which bullseye. There are three bullseys

- Raspberry Pi OS Bullseye
- Armbian OS Bullseye
- DietPi OS Bullseye

Your command prompt is "[email protected]:~ $".
This command prompt is not the default command prompt of any of the above OS, and gives no indication which of above OS you are using.

Please note that your rbfeeder is unable to connect to AirNav server. This connection  problem is specific to DietPi OS.

Please tell us which one of above three listed OS is your OS.


.