anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: New Install - Timeout Error  (Read 755 times)

0 Members and 1 Guest are viewing this topic.

kwarner04

  • New Member
  • *
  • Posts: 3
New Install - Timeout Error
« on: February 05, 2022, 04:35:05 AM »
I'm having trouble with a new install where it keeps saying "could not start connection. Timout" when starting the rbfeeder service.

Running on Raspberry Pi Model 3 B+, Fresh Raspbian Lite Install

I've got dump-1090 running in Docker with multiple feeders connected (PiAware, FR24, ADBX) and working so I know it's not an issue with my

Here's what my rbfeeder.ini file looks like (I've mode of beast and raw and get the same result):
Code: [Select]
$ cat /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=XXXXXXXXXXXXXXXXXXXXXXXXXX

[network]
mode=raw
external_port=30005
external_host=192.168.10.11

[mlat]
#autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

Here's the systemctl status output: https://pastebin.com/raw/9atqjRib

The strange thing is, I have rbfeeder running in docker using an old version (RBFeeder Version 0.4.3 (build 20210909231001)) and that connects fine. So it seems like there's some issue with the new build and the connection.

Let me know what other information you need.

abcd567

  • Hero Member
  • *****
  • Posts: 609
  • CYYZ - Toronto
Re: New Install - Timeout Error
« Reply #1 on: February 05, 2022, 08:21:25 PM »
(1) With port 30005, it should be mode=beast

(2) Why are you using setting "external_host=192.168.10.11" instead of "external_host=127.0.0.1"? Is your decoder (dump1090-fa or dump1090-mutability etc) not installed on same Pi on which you have installed rbfeeder?

(3) Please post output of following command
Code: [Select]
sudo journalctl -u rbfeeder -n 20 



(4) For your reference, below is my file /etc/rbfeeder.ini which woks perfectly well
NOTE:
(a) My OS is Raspberry Pi OS Bullseye
(b) I have installed mlat-client and added my latitude, longitude, and altitude for enabling mlat
(c) My rbfeeder version:
[email protected]:~ $ apt-cache policy rbfeeder | grep Installed
  Installed: 1:1.0.7



cat /etc/rbfeeder.ini

[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
sn=EXTRPI000008

lat=43.5xxxx
lon=-79.6xxxxx
alt=1xx

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true



.
« Last Edit: February 05, 2022, 10:04:45 PM by abcd567 »

kwarner04

  • New Member
  • *
  • Posts: 3
Re: New Install - Timeout Error
« Reply #2 on: February 07, 2022, 10:21:30 PM »
Thanks for getting back to me. I've made the changes you recommended but I'm still getting the same errors.

* I've  updated my rbfeeder.ini file to be BEAST (I'm getting the same error using both BEAST and RAW)
* I was using the local IP for the pi as I assumed you needed to  point to the external IP, not localhost. But I changed it to localhost (127.0.0.1). (Still getting error regardless of whether I  use IP of pi or localhost IP.)
* Per your request, here's the output of  systemctl: https://pastebin.com/raw/syg51Dh9
(It's not letting me post the code, keeps flagging as spam. So I've posted a link to the pastebin of the output.)

I know the feeder software is working as I found a windows command program (https://www.satsignal.eu/raspberry-pi/dump1090.html) that reads the data and I'm seeing live data. Of course, that's from Windows, but when I connect to the IP of the pi and port 30005, I can see the ADSB data streaming in.

abcd567

  • Hero Member
  • *****
  • Posts: 609
  • CYYZ - Toronto
Re: New Install - Timeout Error
« Reply #3 on: February 08, 2022, 12:37:03 AM »
(1) Possibly your router's Firewall is blocking connection to Radarbox24 servers. What is output of this command:

ping google.com -c 3



(2) Following output of netstat shows that
rbfeeder is using ports 32004, 32457, 32458, and 32459
dump1090-fa is using ports 30002, 30003, 30004, 30005, 30104, 30105

You can check output by installing netcat (sudo apt install netcat), then check output on port by this command:

nc 127.0.0.1 port-number

For example, to check on port 30003:

nc 127.0.0.1 30003

To break continous stream of data, press Ctrl and c keys together.


Code: [Select]
[email protected]:~ $ sudo netstat -anp | grep -w LISTEN

tcp     0   0 0.0.0.0:30978     0.0.0.0:*   LISTEN   891835/dump978-fa
tcp     0   0 0.0.0.0:30979     0.0.0.0:*   LISTEN   891835/dump978-fa
tcp     0   0 127.0.0.1:32004   0.0.0.0:*   LISTEN   1003/rbfeeder
tcp     0   0 0.0.0.0:30053     0.0.0.0:*   LISTEN   1048/pfclient
tcp     0   0 0.0.0.0:30054     0.0.0.0:*   LISTEN   1048/pfclient
tcp     0   0 127.0.0.1:32457   0.0.0.0:*   LISTEN   1003/rbfeeder
tcp     0   0 127.0.0.1:32458   0.0.0.0:*   LISTEN   1003/rbfeeder
tcp     0   0 127.0.0.1:32459   0.0.0.0:*   LISTEN   1003/rbfeeder
tcp     0   0 0.0.0.0:8080      0.0.0.0:*   LISTEN   1134/lighttpd
tcp     0   0 0.0.0.0:80        0.0.0.0:*   LISTEN   1134/lighttpd
tcp     0   0 0.0.0.0:8978      0.0.0.0:*   LISTEN   1134/lighttpd
tcp     0   0 0.0.0.0:30002     0.0.0.0:*   LISTEN   549/dump1090-fa
tcp     0   0 0.0.0.0:30003     0.0.0.0:*   LISTEN   549/dump1090-fa
tcp     0   0 0.0.0.0:30004     0.0.0.0:*   LISTEN   549/dump1090-fa
tcp     0   0 0.0.0.0:30005     0.0.0.0:*   LISTEN   549/dump1090-fa
tcp     0   0 0.0.0.0:22        0.0.0.0:*   LISTEN   613/sshd: /usr/sbin
tcp     0   0 0.0.0.0:32088     0.0.0.0:*   LISTEN   1003/rbfeeder
tcp     0   0 0.0.0.0:30104     0.0.0.0:*   LISTEN   549/dump1090-fa
tcp6    0   0 :::30978          :::*        LISTEN   891835/dump978-fa
tcp6    0   0 :::30979          :::*        LISTEN   891835/dump978-fa
tcp6    0   0 :::80             :::*        LISTEN   1134/lighttpd
tcp6    0   0 :::8754           :::*        LISTEN   1044/fr24feed
tcp6    0   0 :::30002          :::*        LISTEN   549/dump1090-fa
tcp6    0   0 :::30003          :::*        LISTEN   549/dump1090-fa
tcp6    0   0 :::30004          :::*        LISTEN   549/dump1090-fa
tcp6    0   0 :::30005          :::*        LISTEN   549/dump1090-fa
tcp6    0   0 :::22             :::*        LISTEN   613/sshd: /usr/sbin
tcp6    0   0 :::30104          :::*        LISTEN   549/dump1090-fa
tcp6    0   0 :::30105          :::*        LISTEN   1279/fa-mlat-client
tcp6    0   0 :::30106          :::*        LISTEN   1279/fa-mlat-client
[email protected]:~ $


« Last Edit: February 08, 2022, 12:47:32 AM by abcd567 »

kwarner04

  • New Member
  • *
  • Posts: 3
Re: New Install - Timeout Error
« Reply #4 on: February 08, 2022, 03:28:49 AM »
Ping seems to be working fine:
$ ping google.com -c 3
PING google.com (172.217.1.142) 56(84) bytes of data.
64 bytes from atl14s07-in-f142.1e100.net (172.217.1.142): icmp_seq=1 ttl=117 time=2.43 ms
64 bytes from atl14s07-in-f142.1e100.net (172.217.1.142): icmp_seq=2 ttl=117 time=2.85 ms
64 bytes from atl14s07-in-f142.1e100.net (172.217.1.142): icmp_seq=3 ttl=117 time=3.64 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2004ms
rtt min/avg/max/mdev = 2.433/2.975/3.640/0.500 ms

So I did a little more testing this afternoon. I swapped the repo from bullseye to buster and with that I was able to install version 0.4.3 (build 20210909231001) That version connects just fine with no issues.

https://pastebin.com/raw/Ej8QZ3CR

Thinking maybe there is an issue with the initial handshake to get the sharing key, I put that key in my rbfeeder.ini file and it connected just fine.

Now with a working installation, if I swap the repo back to bullseye and install 1.0.7 and don't change anything else, I'm back to the timeout errors.

abcd567

  • Hero Member
  • *****
  • Posts: 609
  • CYYZ - Toronto
Re: New Install - Timeout Error
« Reply #5 on: February 08, 2022, 11:20:55 PM »
Ping seems to be working fine:
$ ping google.com -c 3
PING google.com (172.217.1.142) 56(84) bytes of data.
64 bytes from atl14s07-in-f142.1e100.net (172.217.1.142): icmp_seq=1 ttl=117 time=2.43 ms
64 bytes from atl14s07-in-f142.1e100.net (172.217.1.142): icmp_seq=2 ttl=117 time=2.85 ms
64 bytes from atl14s07-in-f142.1e100.net (172.217.1.142): icmp_seq=3 ttl=117 time=3.64 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2004ms
rtt min/avg/max/mdev = 2.433/2.975/3.640/0.500 ms

So I did a little more testing this afternoon. I swapped the repo from bullseye to buster and with that I was able to install version 0.4.3 (build 20210909231001) That version connects just fine with no issues.

https://pastebin.com/raw/Ej8QZ3CR

Thinking maybe there is an issue with the initial handshake to get the sharing key, I put that key in my rbfeeder.ini file and it connected just fine.

Now with a working installation, if I swap the repo back to bullseye and install 1.0.7 and don't change anything else, I'm back to the timeout errors.

(1) Install netbase
Code: [Select]
sudo apt install netbase   

sudo reboot 



(2) Uninstall ver 0.4.3, switch to Bullseye repository, and install rbfeeder ver 1.0.7, and reboot RPi.

Hopefully this will solve connection issue. If not, uninstall ver 1.0.7, revert to Buster repo and install ver 0.4.3


.

ramimz

  • New Member
  • *
  • Posts: 33
Re: New Install - Timeout Error
« Reply #6 on: February 09, 2022, 08:56:16 AM »
I Have the same problem, whatever I tried, I could not get it to work  :(

Code: [Select]
[email protected]:~ $ cat /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log
disable_log=0

key=fb29eb95asede4sweh5f9b024dxe
sn=EXTRPI001632

lat=31.xxxxxx
lon=34.xxxxxx
alt=321

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

ramimz

  • New Member
  • *
  • Posts: 33
Re: New Install - Timeout Error
« Reply #7 on: February 09, 2022, 11:00:23 AM »
Code: [Select]
[email protected]:~ $ sudo systemctl status rbfeeder -l
● rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2022-02-09 10:12:06 IST; 8min ago
 Main PID: 431 (rbfeeder)
    Tasks: 12 (limit: 2200)
   Memory: 10.0M
   CGroup: /system.slice/rbfeeder.service
           ├─431 /usr/bin/rbfeeder
           └─566 /usr/bin/python3.7 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --

Feb 09 10:19:43 raspberrypi rbfeeder[431]: [2022-02-09 10:19:43]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Feb 09 10:19:48 raspberrypi rbfeeder[431]: [2022-02-09 10:19:48]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Feb 09 10:19:53 raspberrypi rbfeeder[431]: [2022-02-09 10:19:53]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Feb 09 10:19:58 raspberrypi rbfeeder[431]: [2022-02-09 10:19:58]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Feb 09 10:20:01 raspberrypi rbfeeder[431]: [2022-02-09 10:20:01]  ******** Statistics updated every 30 seconds ********
Feb 09 10:20:01 raspberrypi rbfeeder[431]: [2022-02-09 10:20:01]  Packets sent in the last 30 seconds: 0, Total packets sent since startup: 0
Feb 09 10:20:01 raspberrypi rbfeeder[431]: [2022-02-09 10:20:01]  Data sent: 1.8 KB
Feb 09 10:20:01 raspberrypi rbfeeder[431]: [2022-02-09 10:20:01]  Data received: 1.1 KB
Feb 09 10:20:03 raspberrypi rbfeeder[431]: [2022-02-09 10:20:03]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Feb 09 10:20:08 raspberrypi rbfeeder[431]: [2022-02-09 10:20:08]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...

ramimz

  • New Member
  • *
  • Posts: 33
Re: New Install - Timeout Error
« Reply #8 on: February 09, 2022, 11:26:09 AM »
Running on Raspberry Pi Model 3 B+, Raspberry Pi OS is Buster.
FR24 feeder and ADSBexchange working fine, but RB give me a hard time  :(

abcd567

  • Hero Member
  • *****
  • Posts: 609
  • CYYZ - Toronto
Re: New Install - Timeout Error
« Reply #9 on: February 10, 2022, 12:28:05 AM »
Running on Raspberry Pi Model 3 B+, Raspberry Pi OS is Buster.
FR24 feeder and ADSBexchange working fine, but RB give me a hard time  :(

Your problem is dump978.
Your rbfeeder is trying to connect to dump978, but cannot connect.

Have you installed dump978?
If yes, then which one, flightaware one (dump978-fa) OR Radarbox one (dump978-rb).

Please post output of following commands which will show if any dump978 is installed, and if yes, then which of the two dump978 have been installed on your Pi

Code: [Select]
apt-cache policy dump1090-fa   

apt-cache policy dump1090-rb   



.

anorak

  • Hero Member
  • *****
  • Posts: 974
  • support The Devon Air Ambulance Trust
Re: New Install - Timeout Error
« Reply #10 on: February 10, 2022, 04:40:45 PM »
Sorry to be a pain. I am trying to do a clean install on a Pi 3 and seem to be going round in circles. Is there a script in words of one syllable please similar to the bake a pi thread of 2017 with the latest set up.
Dave.
Dave. Exmoor, North Devon.

ramimz

  • New Member
  • *
  • Posts: 33
Re: New Install - Timeout Error
« Reply #11 on: February 11, 2022, 02:22:12 PM »
Code: [Select]
[email protected]:~ $ apt-cache policy dump1090-fa
N: Unable to locate package dump1090-fa
[email protected]:~ $ apt-cache policy dump1090-rb
N: Unable to locate package dump1090-rb
[email protected]:~ $

ramimz

  • New Member
  • *
  • Posts: 33
Re: New Install - Timeout Error
« Reply #12 on: February 11, 2022, 04:56:28 PM »
I'm really desperate.
I was able to disable the Dump978 that I do not use in my area.
but the dongle is not yet sending data to the server
Maybe it's related to last week's FR24 update.
Since then the problem has also started in RB.

Code: [Select]
[email protected]:~ $ sudo systemctl status rbfeeder -l
● rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2022-02-11 18:49:57 IST; 46s ago
 Main PID: 12202 (rbfeeder)
    Tasks: 10 (limit: 2200)
   Memory: 1.7M
   CGroup: /system.slice/rbfeeder.service
           └─12202 /usr/bin/rbfeeder

Feb 11 18:49:58 raspberrypi rbfeeder[12202]: [2022-02-11 18:49:58]  System: raspberry
Feb 11 18:49:58 raspberrypi rbfeeder[12202]: [2022-02-11 18:49:58]  Start date/time: 2022-02-11 18:49:58
Feb 11 18:49:58 raspberrypi rbfeeder[12202]: [2022-02-11 18:49:58]  Socket for ANRB created. Waiting for connections on port 32088
Feb 11 18:49:59 raspberrypi rbfeeder[12202]: [2022-02-11 18:49:59]  Connection established.
Feb 11 18:49:59 raspberrypi rbfeeder[12202]: [2022-02-11 18:49:59]  Connection with RadarBox24 server OK! Key accepted by server.
Feb 11 18:50:00 raspberrypi rbfeeder[12202]: [2022-02-11 18:50:00]  Your station serial number is: EXTRPI001632
Feb 11 18:50:28 raspberrypi rbfeeder[12202]: [2022-02-11 18:50:28]  ******** Statistics updated every 30 seconds ********
Feb 11 18:50:28 raspberrypi rbfeeder[12202]: [2022-02-11 18:50:28]  Packets sent in the last 30 seconds: 0, Total packets sent since startup: 0
Feb 11 18:50:28 raspberrypi rbfeeder[12202]: [2022-02-11 18:50:28]  Data sent: 1.6 KB
Feb 11 18:50:28 raspberrypi rbfeeder[12202]: [2022-02-11 18:50:28]  Data received: 1.0 KB
[email protected]:~ $

ramimz

  • New Member
  • *
  • Posts: 33
Re: New Install - Timeout Error
« Reply #13 on: February 11, 2022, 06:10:58 PM »
Running on Raspberry Pi Model 3 B+, Raspberry Pi OS is Buster.
FR24 feeder and ADSBexchange working fine.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 32018
Re: New Install - Timeout Error
« Reply #14 on: February 11, 2022, 06:14:38 PM »
Your previous post suggests that the Pi is not able to find dump1090, which version do you have installed in RB

Alan