AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: sudo: rbfeeder: command not found  (Read 4545 times)

0 Members and 2 Guests are viewing this topic.

cloud9surfer

  • New Member
  • *
  • Posts: 13
sudo: rbfeeder: command not found
« on: January 18, 2022, 12:42:42 AM »
Good Day,

first post, setting up my RadarBox ADS-B Flight Stick.   Im using RaspberryPi 4.  Fresh install with Debian Bullseye.

What am I missing??, rbfeeder doesn't want to install.


TIA

pi@raspberrypi:~ $ sudo rbfeeder --showkey --no-start
sudo: rbfeeder: command not found

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33577
Re: sudo: rbfeeder: command not found
« Reply #1 on: January 18, 2022, 09:09:35 AM »
There is no Bullseye package yet but see this thread for a workround https://forum.radarbox24.com/index.php?topic=105631.0

Alan

cloud9surfer

  • New Member
  • *
  • Posts: 13
Re: sudo: rbfeeder: command not found
« Reply #2 on: January 21, 2022, 11:46:54 PM »
I followed the steps without success.

It ends with this :Don't know how to install for a distribution named

regards,

C

abcd567

  • Hero Member
  • *****
  • Posts: 844
  • CYYZ - Toronto
Re: sudo: rbfeeder: command not found
« Reply #3 on: January 22, 2022, 12:00:02 AM »
I followed the steps without success.

It ends with this :Don't know how to install for a distribution named

regards,

C

You made a mistake while editing the install file. 
Instead of typing new line like this:
VERS=buster
(VERS with Capital letters)

You typed like this:
vers=buster
(vers with small letters)

Please correct this typing mistake and re-run the script.


« Last Edit: January 22, 2022, 12:02:48 AM by abcd567 »

cloud9surfer

  • New Member
  • *
  • Posts: 13
Re: sudo: rbfeeder: command not found
« Reply #4 on: January 22, 2022, 12:14:13 AM »
Ah, so I did.   Im up and running now.   Thanks for all the help.

regards,

C

abcd567

  • Hero Member
  • *****
  • Posts: 844
  • CYYZ - Toronto
Re: sudo: rbfeeder: command not found
« Reply #5 on: January 22, 2022, 12:24:55 AM »
Did you enable mlat by two step method:

STEP-1
Set your latitude, longitude and elevation (above sea level)

STEP-2
Install mlat-client for 32-bit Bullseye

https://github.com/abcd567a/mlat-client-package#readme

cloud9surfer

  • New Member
  • *
  • Posts: 13
Re: sudo: rbfeeder: command not found
« Reply #6 on: January 22, 2022, 12:31:14 AM »
Not quite,  I saw a previous post of yours and ran that.
 ## Installed required packages (dependencies and build tools)
sudo apt update -y
sudo apt-get install -y git curl build-essential debhelper python-dev python3-dev

## Downloaded source code
cd /home/pi/ 
git clone https://github.com/mutability/mlat-client.git 

## Built mlat-client's installation package
cd /home/pi/mlat-client 
sudo apt-get install -y dh-python 
sudo dpkg-buildpackage -b -uc 

## Above command took some time to build package. After the package was built, installed it by following command
cd /home/pi/ 
sudo dpkg -i mlat-client_*.deb
 


Should I re-install with  :  https://github.com/abcd567a/mlat-client-package#readme

cloud9surfer

  • New Member
  • *
  • Posts: 13
Re: sudo: rbfeeder: command not found
« Reply #7 on: January 22, 2022, 12:52:20 AM »
Look like mlat is running for me.


abcd567

  • Hero Member
  • *****
  • Posts: 844
  • CYYZ - Toronto
Re: sudo: rbfeeder: command not found
« Reply #8 on: January 22, 2022, 01:00:01 AM »
Not quite,  I saw a previous post of yours and ran that.
 ## Installed required packages (dependencies and build tools)
sudo apt update -y
sudo apt-get install -y git curl build-essential debhelper python-dev python3-dev

## Downloaded source code
cd /home/pi/ 
git clone https://github.com/mutability/mlat-client.git 

## Built mlat-client's installation package
cd /home/pi/mlat-client 
sudo apt-get install -y dh-python 
sudo dpkg-buildpackage -b -uc 

## Above command took some time to build package. After the package was built, installed it by following command
cd /home/pi/ 
sudo dpkg -i mlat-client_*.deb
 


Should I re-install with  :  https://github.com/abcd567a/mlat-client-package#readme

No need to reinstall.

The package I have uploaded at github is same as you have built from source-code, that is why your mlat is running now.

Installation from https://github.com/abcd567a/mlat-client-package#readme is an alternate and easy method if someone does not want to built the mlat-client from source code.


.

cloud9surfer

  • New Member
  • *
  • Posts: 13
Re: sudo: rbfeeder: command not found
« Reply #9 on: January 22, 2022, 02:10:41 AM »
Ok perfect.  Thanks. 

This is off topic and unsure where to find the info.    I can't figure out what the green shaded cones on the map are. 


Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33577
Re: sudo: rbfeeder: command not found
« Reply #10 on: January 22, 2022, 07:51:24 PM »
The green shaded area is your area of coverage built up so far and will fill in further over time

Alan

cloud9surfer

  • New Member
  • *
  • Posts: 13
Re: sudo: rbfeeder: command not found
« Reply #11 on: January 22, 2022, 08:13:23 PM »
I started to think that was the case after I posted, as I see most of of the area out to 200nm is now filled in,  except for a few areas where I assume reception is getting blocked.   

Thanks

teesvalley spotter

  • New Member
  • *
  • Posts: 11
Re: sudo: rbfeeder: command not found
« Reply #12 on: January 23, 2022, 01:49:22 PM »
Hello. I have followed this and came across an error at the end

Can anyone advise what to do?

abcd567

  • Hero Member
  • *****
  • Posts: 844
  • CYYZ - Toronto
Re: sudo: rbfeeder: command not found
« Reply #13 on: January 23, 2022, 11:29:54 PM »
Hello. I have followed this and came across an error at the end

Can anyone advise what to do?

(1) Have you installed any decoder like dump1090-fa, or deump1090-mutability etc? Your output says "Network mode disabled" which is used only if you have not installed a decoder like dump1090-fa or dump1090-mutability.

(2) Please post here the contents of file /etc/rbfeeder.ini
(remove key before posting in forum)
You can see the contents by following command
sudo nano /etc/rbfeeder.ini

See attached screenshot of my file /etc/rbfeeder.ini
I have installed dump1090-fa, and the following setting matches it. Note I have enabled network mode under [client] by making it "true"

[client]
network_mode=true

[network]
mode=beast
external_port=30005
external_host=127.0.0.1
« Last Edit: January 23, 2022, 11:42:39 PM by abcd567 »

teesvalley spotter

  • New Member
  • *
  • Posts: 11
Re: sudo: rbfeeder: command not found
« Reply #14 on: January 23, 2022, 11:38:24 PM »
Hi. Thanks for the reply above. I have piaware SD card latest version installed I haven't got access to my pi at the moment. I can get the picture tomorrow.