anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Logs from sudo rbfeeder status  (Read 781 times)

0 Members and 1 Guest are viewing this topic.

DZpower

  • New Member
  • *
  • Posts: 17
Logs from sudo rbfeeder status
« on: April 28, 2021, 11:35:59 PM »
can someone tell me what seems to be the problem ?
I noticed that my radarbox page is slow and not showing airplanes like on Piaware or FR24
I have a raspbery pie and have Piaware FR24  Radarbox and ADS-B exchange set up  under the RTL-SDR Dongle

[email protected]:~ $ sudo rbfeeder status
[2021-04-28 19:31:33]  Starting RBFeeder Version 0.3.5 (build 20200727132301)
[2021-04-28 19:31:33]  Using configuration file: /etc/rbfeeder.ini
[2021-04-28 19:31:33]  Network-mode enabled.
[2021-04-28 19:31:33]        Remote host to fetch data: 127.0.0.1
[2021-04-28 19:31:33]        Remote port: 30005
[2021-04-28 19:31:33]        Remote protocol: BEAST
Error opening the listening port 32458 (Raw TCP output): bind: Address already in use
[2021-04-28 19:31:33]  Error opening the listening port 32458 (Raw TCP output): bind: Address already in use
Error opening the listening port 32457 (Beast TCP output): bind: Address already in use
[2021-04-28 19:31:33]  Error opening the listening port 32457 (Beast TCP output): bind: Address already in use
Error opening the listening port 32459 (Basestation TCP output): bind: Address already in use
[2021-04-28 19:31:33]  Error opening the listening port 32459 (Basestation TCP output): bind: Address already in use
Error opening the listening port 32008 (Raw TCP input): bind: Address already in use
[2021-04-28 19:31:33]  Error opening the listening port 32008 (Raw TCP input): bind: Address already in use
Error opening the listening port 32004 (Beast TCP input): bind: Address already in use
[2021-04-28 19:31:33]  Error opening the listening port 32004 (Beast TCP input): bind: Address already in use
[2021-04-28 19:31:33]  System: raspberry
[2021-04-28 19:31:33]  Start date/time: 2021-04-28 19:31:33
[2021-04-28 19:31:33] [airnav_main]  Creating dump978 thread...
[2021-04-28 19:31:33]  Bind failed on ANRB channel. Port: 32088
[2021-04-28 19:31:34]  Connection established.
[2021-04-28 19:31:36]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
[2021-04-28 19:31:41]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
[2021-04-28 19:31:45]  Could not start connection. Timeout.
[2021-04-28 19:31:46]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
[2021-04-28 19:31:51]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
[2021-04-28 19:31:56]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
[2021-04-28 19:32:01]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...

abcd567

  • Hero Member
  • *****
  • Posts: 501
  • CYYZ - Toronto
Re: Logs from sudo rbfeeder status
« Reply #1 on: April 28, 2021, 11:48:56 PM »
You are using wrong command, which starts 2nd copy of rbfeeder, and it cant find ports as these are already in use by 1st copy started by system and running in background.

Your wrong command:
sudo rbfeeder status

First reboot Pi to stop 2nd copy.
Then issue correct command to see status of 1st copy started by system at reboot

The correct command is
sudo systemctl status rbfeeder 


DZpower

  • New Member
  • *
  • Posts: 17
Re: Logs from sudo rbfeeder status
« Reply #2 on: April 29, 2021, 12:37:10 AM »
Hi

I did reboot the Pi and ran the 2nd command
is there anything else i need to check?

$ sudo systemctl status rbfeeder
● rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2021-04-28 20:33:09 EDT; 2min 36s ago
 Main PID: 508 (rbfeeder)
    Tasks: 13 (limit: 4915)
   CGroup: /system.slice/rbfeeder.service
           ├─508 /usr/bin/rbfeeder
           └─596 /usr/bin/python3.7 /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900

Apr 28 20:35:19 raspberrypi rbfeeder[508]: [2021-04-28 20:35:19]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Apr 28 20:35:24 raspberrypi rbfeeder[508]: [2021-04-28 20:35:24]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Apr 28 20:35:29 raspberrypi rbfeeder[508]: [2021-04-28 20:35:29]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Apr 28 20:35:29 raspberrypi rbfeeder[508]: [2021-04-28 20:35:29]  ******** Statistics updated every 30 seconds ********
Apr 28 20:35:29 raspberrypi rbfeeder[508]: [2021-04-28 20:35:29]  Packets sent in the last 30 seconds: 82, Total packets sent since startup:
Apr 28 20:35:29 raspberrypi rbfeeder[508]: [2021-04-28 20:35:29]  Data sent: 8.6 KB
Apr 28 20:35:29 raspberrypi rbfeeder[508]: [2021-04-28 20:35:29]  Data received: 1.0 KB
Apr 28 20:35:34 raspberrypi rbfeeder[508]: [2021-04-28 20:35:34]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Apr 28 20:35:39 raspberrypi rbfeeder[508]: [2021-04-28 20:35:39]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
Apr 28 20:35:44 raspberrypi rbfeeder[508]: [2021-04-28 20:35:44]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
lines 1-19/19 (END)

abcd567

  • Hero Member
  • *****
  • Posts: 501
  • CYYZ - Toronto
Re: Logs from sudo rbfeeder status
« Reply #3 on: April 29, 2021, 12:54:25 AM »
The status says:

Apr 28 20:35:34 raspberrypi rbfeeder[508]: [2021-04-28 20:35:34]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second.

Your settings for dump978 need to be modified.

(1) Have you installed dump978?
If yes, which one, Flightaware dump978-fa or Radarbox24 dump978-rb ?

(2) Please copy-paste output of following command

cat /etc/rbfeeder.ini 

Note: remove you feeder key from the post.

.


DZpower

  • New Member
  • *
  • Posts: 17
Re: Logs from sudo rbfeeder status
« Reply #4 on: April 29, 2021, 01:00:32 AM »
I do not have a second RTL connected for Dump978
just one Dongle
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxxxxxxxxxxxxxxx

sn=xxxxxxxxxxxxxxxxxxxxxx

lat=xxxxxxxxx

lon=xxxxxxxxxxxxxxx

alt=110

sat_used=0

sat_visible=0

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

abcd567

  • Hero Member
  • *****
  • Posts: 501
  • CYYZ - Toronto
Re: Logs from sudo rbfeeder status
« Reply #5 on: April 29, 2021, 02:28:56 AM »
This is strange.
Your file rbfeeder.ini has following line commented out (i.e. has # at it's start), so it becomes ineffective.

[dump978]
#dump978_enabled=true

With above setting the rbfeeder should NOT try to connect to dump978, but your status shows it is trying to connect to dump978 and fails. This is strange and abnormal behaviour.


OK, ley us try to tell rbfeeder more positively that dump978 is not enabled by this way:

(2) Remove # from start of the line.
(1) change true to false

The line becomes like this:

[dump978]
dump978_enabled=false

(3) Save file (Ctrl+O) and close (Ctrl+x)

(4) Now restart rbfeeder, then again check status:

sudo systemctl restart rbfeeder 

After few minutes: 
sudo systemctl status rbfeeder 


.



« Last Edit: April 29, 2021, 02:31:23 AM by abcd567 »