anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Dedicated UAT Pi won't feed  (Read 3297 times)

0 Members and 1 Guest are viewing this topic.

thespeedycab

  • New Member
  • *
  • Posts: 3
Dedicated UAT Pi won't feed
« on: March 12, 2021, 04:09:56 PM »
All
I have a dedicated UAT pi, that has dump978-fa running, and feeds FA without a problem. It is a PiAware SD-card 5.0. But I can't get it to feed RB. There is no 1090 and MLAT. On the pi I see the following:
Quote
pi@piaware:~ $ sudo rbfeeder --status
[2021-03-12 08:05:27]  Starting RBFeeder Version 0.3.5 (build 20200727132301)
[2021-03-12 08:05:27]  Using configuration file: /etc/rbfeeder.ini
[2021-03-12 08:05:27]  Network-mode enabled.
[2021-03-12 08:05:27]        Remote host to fetch data: 127.0.0.1
[2021-03-12 08:05:27]        Remote port: 30005
[2021-03-12 08:05:27]        Remote protocol: BEAST
Error opening the listening port 32458 (Raw TCP output): bind: Address already in use
[2021-03-12 08:05:27]  Error opening the listening port 32458 (Raw TCP output): bind: Address already in use
Error opening the listening port 32457 (Beast TCP output): bind: Address already in use
[2021-03-12 08:05:27]  Error opening the listening port 32457 (Beast TCP output): bind: Address already in use
Error opening the listening port 32459 (Basestation TCP output): bind: Address already in use
[2021-03-12 08:05:27]  Error opening the listening port 32459 (Basestation TCP output): bind: Address already in use
Error opening the listening port 32008 (Raw TCP input): bind: Address already in use
[2021-03-12 08:05:27]  Error opening the listening port 32008 (Raw TCP input): bind: Address already in use
Error opening the listening port 32004 (Beast TCP input): bind: Address already in use
[2021-03-12 08:05:27]  Error opening the listening port 32004 (Beast TCP input): bind: Address already in use
[2021-03-12 08:05:27]  System: raspberry
[2021-03-12 08:05:27]  Start date/time: 2021-03-12 08:05:27
[2021-03-12 08:05:27]  Bind failed on ANRB channel. Port: 32088
[2021-03-12 08:05:28]  Connection established.
[2021-03-12 08:05:30]  Can't connect to external source (127.0.0.1:30005). Waiting 5 second...
It just goes on.
I can see AC locally on the Pi. But on the radarbox site, it notes zero message, though the total is 108 (0+0+0=108, apparently).

Any tips appreciated
« Last Edit: March 12, 2021, 04:13:20 PM by thespeedycab »

abcd567

  • Hero Member
  • *****
  • Posts: 864
  • CYYZ - Toronto
Re: Dedicated UAT Pi won't feed
« Reply #1 on: March 12, 2021, 06:15:16 PM »
You need to modify settings under [dump978] in file /etc/rbfeeder.ini

Please see following post for details:

https://forum.radarbox24.com/index.php?topic=103271.msg444091#msg444091


.

thespeedycab

  • New Member
  • *
  • Posts: 3
Re: Dedicated UAT Pi won't feed
« Reply #2 on: March 12, 2021, 06:53:20 PM »
Hey @adcb567
that solves one problem: I now see UAT on RB.  In
Quote
sudo rbfeeder --status
I still have the cannot connect message:
Quote
[2021-03-12 10:51:48]  Can't connect to external source (127.0.0.1:30005). Waiting 5 second...
[2021-03-12 10:51:53]  ******** Statistics updated every 30 seconds ********
[2021-03-12 10:51:53]  Packets sent in the last 30 seconds: 142, Total packets sent since startup: 849
[2021-03-12 10:51:53]  Data sent: 30.1 KB
[2021-03-12 10:51:53]  Data received: 1.1 KB
[2021-03-12 10:51:53]  Can't connect to external source (127.0.0.1:30005). Waiting 5 second...
[2021-03-12 10:51:58]  Can't connect to external source (127.0.0.1:30005). Waiting 5 second...
[2021-03-12 10:52:03]  Can't connect to external source (127.0.0.1:30005). Waiting 5 second...
Thoughts on this one?

Fun fact: UAT feeder also sends TIS-B data!
« Last Edit: March 12, 2021, 07:09:38 PM by thespeedycab »

abcd567

  • Hero Member
  • *****
  • Posts: 864
  • CYYZ - Toronto
Re: Dedicated UAT Pi won't feed
« Reply #3 on: March 12, 2021, 08:33:39 PM »
This message will be there since the setting under [network] in file /etc/rbfeeder.ini are as follows, but there is no dump1090 running to provide data on port 30005

Code: [Select]
[network]
mode=beast
external_port=30005
external_host=127.0.0.1

You may either ignore it, or change "external_port=30005" to "external_port=30979". This may or may not work. Try it, if it creates problem, change port number back to 30005.

Dont forget to save file then restart rbfeeder after every time you make a change in file /etc/rbfeeder.ini

« Last Edit: March 12, 2021, 08:36:45 PM by abcd567 »

thespeedycab

  • New Member
  • *
  • Posts: 3
Re: Dedicated UAT Pi won't feed
« Reply #4 on: March 12, 2021, 09:43:48 PM »
that has done the trick
thx, abcd