AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Unable to install  (Read 323 times)

0 Members and 1 Guest are viewing this topic.

thenashy

  • New Member
  • *
  • Posts: 9
Unable to install
« on: March 12, 2021, 11:02:05 AM »
Hi There,

I'm attempting to install rbfeeder on piaware, and am getting the following;


Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
dirmngr is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 116 not upgraded.
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.H6CbpqdSSa --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/flightaware-archive-keyring.gpg --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 1D043681
gpg: requesting key 1D043681 from hkp server p80.pool.sks-keyservers.net
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error
Don't know how to install for a distribution named


is anyone able to tell me what I'm doing wrong here?

anorak

  • Hero Member
  • *****
  • Posts: 965
  • support The Devon Air Ambulance Trust
Re: Unable to install
« Reply #1 on: March 12, 2021, 11:20:24 AM »
Morning thenashy, have you checked the Pi thread, abcd has all the set ups listed. He will probably answer soon anyway.
Good luck, Dave.
Dave. Exmoor, North Devon.

abcd567

  • Sr. Member
  • ****
  • Posts: 447
  • CYYZ - Toronto
Re: Unable to install
« Reply #2 on: March 12, 2021, 11:47:24 AM »
Quote
Don't know how to install for a distribution named

Seems rbfeeder failed to recognize your OS / Architecture.
Let us find your OS / Architecture. What are the outputs of following two commands?

Code: [Select]
cat /etc/os-release

uname -a   

.
« Last Edit: March 12, 2021, 11:50:24 AM by abcd567 »

thenashy

  • New Member
  • *
  • Posts: 9
Re: Unable to install
« Reply #3 on: March 12, 2021, 02:30:50 PM »


Sorry for the delay.  The forum is giving me a lot of trouble with CleanTalk thinking my IP is bad or my messages are spam.

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian


Linux piaware 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux


abcd567

  • Sr. Member
  • ****
  • Posts: 447
  • CYYZ - Toronto
Re: Unable to install
« Reply #4 on: March 12, 2021, 02:55:13 PM »
You have a very old OS: "Jessie"

The Rdarbox24's rbfeeder and mlat-client were first released when Stretch was the current OS. Their rbfeeder and mlat-client were therefore built for Stretch. Later when Buster was released, they built and made available packages for Buster also.

The rbfeeder's installation script checks the OS version.
If version is Stretch, it installs rbfeeder and mlat-client packages designed for Stretch.

If version is Buster, it installs rbfeeder and mlat-client packages designed for Buster.

If the OS is different from above two, it fails to install rbfeeder and outputs:
rbfeeder: "Dont know how to install for a distribution named "
mlat-client: "Package mlat-client is not available"

You can fool their installer to think that your OS is Stretch in the following way, and it will install packages of Stretch on Jessie.

(1) Download installation script and open it for editing

Code: [Select]
wget http://apt.rb24.com/inst_rbfeeder.sh 

sudo nano inst_rbfeeder.sh


(2) In the editor, scroll down to following line

VERS=`lsb_release -c | awk -F ':' '{print $2}' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*$//'`


(a) Place a # at start of this line
(b) Add new line VERS=stretch


The code will become like this:

#VERS=`lsb_release -c | awk -F ':' '{print $2}' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*$//'`

VERS=stretch

Save file (Ctrl+O) and close editor (Ctrl+X)

(3) Run the installation script
Code: [Select]
sudo bash inst_rbfeeder.sh

Most likely the installation will succeed.
« Last Edit: March 12, 2021, 03:01:47 PM by abcd567 »

thenashy

  • New Member
  • *
  • Posts: 9
Re: Unable to install
« Reply #5 on: March 12, 2021, 03:09:55 PM »
You have a very old OS: "Jessie"

The Rdarbox24's rbfeeder and mlat-client were first released when Stretch was the current OS. Their rbfeeder and mlat-client were therefore built for Stretch. Later when Buster was released, they built and made available packages for Buster also.

The rbfeeder's installation script checks the OS version.
If version is Stretch, it installs rbfeeder and mlat-client packages designed for Stretch.

If version is Buster, it installs rbfeeder and mlat-client packages designed for Buster.

If the OS is different from above two, it fails to install rbfeeder and outputs:
rbfeeder: "Dont know how to install for a distribution named "
mlat-client: "Package mlat-client is not available"

You can fool their installer to think that your OS is Stretch in the following way, and it will install packages of Stretch on Jessie.

(1) Download installation script and open it for editing

Code: [Select]
wget http://apt.rb24.com/inst_rbfeeder.sh 

sudo nano inst_rbfeeder.sh


(2) In the editor, scroll down to following line

VERS=`lsb_release -c | awk -F ':' '{print $2}' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*$//'`


(a) Place a # at start of this line
(b) Add new line VERS=stretch


The code will become like this:

#VERS=`lsb_release -c | awk -F ':' '{print $2}' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*$//'`

VERS=stretch

Save file (Ctrl+O) and close editor (Ctrl+X)

(3) Run the installation script
Code: [Select]
sudo bash inst_rbfeeder.sh

Most likely the installation will succeed.

I got further this time thank you.  Now I have this issue.  I have attempted to install both of these, first one says it installed fine, and the second says I have the most recent version;

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 rbfeeder : Depends: libncurses5 (>= 6) but 5.9+20140913-1+deb8u3 is to be insta                                   lled
            Depends: libtinfo5 (>= 6) but 5.9+20140913-1+deb8u3 is to be install                                   ed
E: Unable to correct problems, you have held broken packages.
Do you wish to install dump978-rb program? (y/n) y
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package soapysdr-module-rtlsdr is not available, but is referred to by another p                                   ackage.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'soapysdr-module-rtlsdr' has no installation candidate

thenashy

  • New Member
  • *
  • Posts: 9
Re: Unable to install
« Reply #6 on: March 12, 2021, 03:44:01 PM »
Looks like it might just be time to upgrade the OS completely.

abcd567

  • Sr. Member
  • ****
  • Posts: 447
  • CYYZ - Toronto
Re: Unable to install
« Reply #7 on: March 12, 2021, 05:57:09 PM »
Looks like it might just be time to upgrade the OS completely.

That is exactly I was going to suggest. Using Jessie instead of current Buster is like using WinXP instead of Win10.

Yesterday Flightaware have released Piaware version 5. Try it, preferably on a spare microSD card, keeping current install intact in case of any issues.

Which model of RPi you have?

.

thenashy

  • New Member
  • *
  • Posts: 9
Re: Unable to install
« Reply #8 on: March 13, 2021, 05:58:59 AM »
Looks like it might just be time to upgrade the OS completely.

That is exactly I was going to suggest. Using Jessie instead of current Buster is like using WinXP instead of Win10.

Yesterday Flightaware have released Piaware version 5. Try it, preferably on a spare microSD card, keeping current install intact in case of any issues.

Which model of RPi you have?

.

I didn't realise how long it had been since I upgraded, so it seemed the obvious choice when I was using 5+ year old software.

On PiAware5 now, everything up and running as it should.  Thanks for your help with this.


abcd567

  • Sr. Member
  • ****
  • Posts: 447
  • CYYZ - Toronto
Re: Unable to install
« Reply #9 on: March 13, 2021, 06:49:43 AM »
On PiAware5 now, everything up and running as it should.

Glad to hear that.