anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Help please!  (Read 757 times)

0 Members and 1 Guest are viewing this topic.

Wiggi001

  • New Member
  • *
  • Posts: 10
Help please!
« on: March 09, 2021, 01:03:12 PM »
I have FR24 and TAR1090 working fine after rebuilding my RasperryPi4. I have reinstalled
RB24 and attempted to reclaim my old key but my station will not go back online.
Please see the attached screen shot.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 31881
Re: Help please!
« Reply #1 on: March 09, 2021, 02:13:06 PM »
I would suggest that you should obtain a new key for a new installation

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 580
  • CYYZ - Toronto
Re: Help please!
« Reply #2 on: March 09, 2021, 07:20:15 PM »
Please do following:
(1) Reboot RPi
(2) After reboot, give following command and post the output (copy-paste from PuTTY to the post):

journalctl -b -u rbfeeder 
« Last Edit: March 09, 2021, 07:24:43 PM by abcd567 »

Wiggi001

  • New Member
  • *
  • Posts: 10
Re: Help please!
« Reply #3 on: March 11, 2021, 06:04:20 PM »
[client]
network_mode=True
log_file=/var/log/rbfeeder.log

key=hidden by me

[network]
mode=Beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=false

Wiggi001

  • New Member
  • *
  • Posts: 10
Re: Help please!
« Reply #4 on: March 11, 2021, 06:09:04 PM »
please see text doc attached

abcd567

  • Hero Member
  • *****
  • Posts: 580
  • CYYZ - Toronto
Re: Help please!
« Reply #5 on: March 11, 2021, 08:30:31 PM »
The rightmost part (which is the most important part) of output of command journalctl -b -u rbfeeder is trunkated because of small width of putty window. Please increase the width as much as you can, tthen give above command.

This time give followind command to limit number of lines too last 20. Dont forget to increase width of putty as much as you can BEFORE issuing the command.

journalctl -e -u rbfeeder.


.

« Last Edit: March 11, 2021, 08:32:19 PM by abcd567 »

Wiggi001

  • New Member
  • *
  • Posts: 10
Re: Help please!
« Reply #6 on: March 11, 2021, 09:33:28 PM »
pleas see attached file.

abcd567

  • Hero Member
  • *****
  • Posts: 580
  • CYYZ - Toronto
Re: Help please!
« Reply #7 on: March 11, 2021, 11:18:35 PM »
I think I now found the bug.

With the "putty at full width" log you have posted now, I see following:

Mar 11 17:22:30 raspberrypi rbfeeder[743]: [2021-03-11 17:22:30]  Network-mode disabled. Using local dongle.

Also in your file /etc/rbfeeder.ini I see following:

[client]
network_mode=True

The cause of failure is that you have written "true" with capital letter T instead of small letter "t".

To fix it do following:
Code: [Select]
sudo nano /etc/rbfeeder.ini

In "True", change "T" by "t" like below,

[client]
network_mode=true

Save file (Ctrl+O) and close it (Ctrl+X)

Restart rbfeeder, and then check status
Code: [Select]
sudo systemctl restart rbfeeder 

sudo systemctl status rbfeeder

.

Wiggi001

  • New Member
  • *
  • Posts: 10
Re: Help please!
« Reply #8 on: March 11, 2021, 11:34:31 PM »
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key======================

[network]
mode=raw
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true


////---------------

see attachment
« Last Edit: March 11, 2021, 11:37:24 PM by Wiggi001 »

Wiggi001

  • New Member
  • *
  • Posts: 10
Re: Help please!
« Reply #9 on: March 11, 2021, 11:36:37 PM »
Should have said still not working!

Thanks for the assistance.

abcd567

  • Hero Member
  • *****
  • Posts: 580
  • CYYZ - Toronto
Re: Help please!
« Reply #10 on: March 11, 2021, 11:46:00 PM »
Seems you checked status too early. When you checked status, It has just connection to RB24 server and not yet started sending data
Check again now

Code: [Select]
sudo systemctl status rbfeeder 




abcd567

  • Hero Member
  • *****
  • Posts: 580
  • CYYZ - Toronto
Re: Help please!
« Reply #11 on: March 12, 2021, 01:31:21 AM »
You log shows all is ok, and your rbfeeder has connected to ANRB software on Windows. Please see last two entries of your log below.

The rbfeeder will also connect to RB24 Server if you would have waited few minutes before checking the status.

Which version of dump1090 you have installed? With network_mode= true you wiil have to install dump1090 to provide data to rbfeeder.

Your status command output

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02]  Starting RBFeeder Version 0.3.5 (build 20200727132301)

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02]  Using configuration file: /etc/rbfeeder.ini

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02] Network-mode enabled.

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02] Remote host to fetch data: 127.0.0.1

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02] Remote port: 30005

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02] Remote protocol: RAW

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02]  System: raspberry

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02]  Start date/time: 2021-03-11 23:33:02

Mar 11 23:33:02 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:02]  Socket for ANRB created. Waiting for connections on port 32088

Mar 11 23:33:03 raspberrypi rbfeeder[9765]: [2021-03-11 23:33:03]  Connection established.

~

~

« Last Edit: March 12, 2021, 01:37:32 AM by abcd567 »

Wiggi001

  • New Member
  • *
  • Posts: 10
Re: Help please!
« Reply #12 on: March 12, 2021, 11:52:29 AM »


Thanks for all the help.

I deleted and reinstalled Dump1090 and Rb24 and hey presto!