AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: UAT Configuration for dump978-fa on Remote Device  (Read 2042 times)

0 Members and 1 Guest are viewing this topic.

cseck1

  • New Member
  • *
  • Posts: 4
UAT Configuration for dump978-fa on Remote Device
« on: February 27, 2021, 12:00:59 AM »
I recently upgraded my tracking setup from a 1090 MHz FlightAware receiver to an Airspy R2 running at 24 MSPS, which doesn't leave enough USB bandwidth to also run a 978 MHz UAT receiver on the same device. My solution was a second RPi running dump978-fa connected directly via an ethernet cable, which works for multiple feeders.

The easy, solved port issue: dump978-fa ports (solution: https://forum.radarbox24.com/index.php?topic=103271.msg444091#msg444091)

My current challenge is that I can't find a similar, undocumented option to set a dump978 host IP. Is there another configuration setting to direct rbfeeder to a dump978-fa instance on another device on the local network?

Or is the solution to use an SSH tunnel (or similar)?

cseck1

  • New Member
  • *
  • Posts: 4
Re: UAT Configuration for dump978-fa on Remote Device
« Reply #1 on: March 03, 2021, 01:56:20 PM »
Update:
I'm now running USBIP to port the UAT SDR's USB traffic from the second RPi to the primary with dump978-fa running on the primary.

My /etc/rbfeeder.ini file has the following config for UAT:

[dump978]
dump978_enabled=true
dump978_port=30979

When I look into the dump978-fa logs, I see a connection closing and reconnecting when rbfeeder is restarted and UAT traffic now on the RadarBox map.
« Last Edit: March 03, 2021, 02:33:50 PM by cseck1 »

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33385
Re: UAT Configuration for dump978-fa on Remote Device
« Reply #2 on: March 03, 2021, 02:24:28 PM »
Hi

Looking at  the later posts on https://forum.radarbox24.com/index.php?topic=103271.msg444091#msg444091 I note the last post states

If you're running piaware with dump978-fa and it is feeding FA UAT correctly, all you need to enable submitting your UAT feed to RB is edit your rbfeeder.ini config with the following:

[dump978]
dump978_enabled=true
dump978_port=30979

sudo systemctl restart rbfeeder

The dump978_port is detailed as 30979 not the 30978 as stated by you

Alan

cseck1

  • New Member
  • *
  • Posts: 4
Re: UAT Configuration for dump978-fa on Remote Device
« Reply #3 on: March 03, 2021, 02:35:53 PM »
Thanks for catching that! Post edited/fixed.