anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: radarbox24 not starting on RPi 4  (Read 197 times)

0 Members and 1 Guest are viewing this topic.

bvb40170

  • New Member
  • *
  • Posts: 5
radarbox24 not starting on RPi 4
« on: February 20, 2021, 11:25:38 AM »
Hi- I have tried to set up RB24 on my RPi4 running PiAaware but with no success.  I have tried many times.  I have used sudo apt-get remove rbfeeder between each attempt and tried to carefully follow the instructions in radarbox.com/raspberry-pi/guide.   The RPi4 has a FlightAware orange dongle attached.  I am successfully running PiAware, FR24 and ADSB Exchange on this RPi.   Why can't I get RadarBox24 to run?
I should also point out that I am running RadarBox24 on an old RPi3 with a generic dongle and this works well except the range is very poor.   I used the same script from above to install on this RPi so I'm mystified as to why it won't run on the RPi4.   Support has been no help.   Perhaps someone here has a better solution.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30362
Re: radarbox24 not starting on RPi 4
« Reply #1 on: February 20, 2021, 02:43:45 PM »
Hi BVB

I would suggest that you have a read at this thread which should help you https://forum.radarbox24.com/index.php?topic=10201.0

Are you using a different varient of Linux, you should get the anser on the above thread

Alan

« Last Edit: February 20, 2021, 02:45:31 PM by Runway 31 »

bvb40170

  • New Member
  • *
  • Posts: 5
Re: radarbox24 not starting on RPi 4
« Reply #2 on: February 20, 2021, 03:01:37 PM »
Many thanks for your reply.   I have tried Option 3 many times, including using a brand new microSD card out of the box but I still cannot get RB24 to run.   I have a sharing key, Support linked my RPi4 to my account but still no joy.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30362
Re: radarbox24 not starting on RPi 4
« Reply #3 on: February 20, 2021, 03:16:44 PM »
As you are running Piaware do you have dump1090-fa installed as the RB feeder uses its own version of dump1090

BTW I know nothing of Linux just looking a later posts on the thread

If you have installed OPTION-3 (piaware image)then both dump1090-fa and flightaware's data feeder (piaware) is installed automatically with it. With dump1090-fa installed, the rbfeeder setting "network_mode=false" is wrong. Change it to "network_mode=true"

See reply 30 onwards on the bake a Pi thread

Hopefully abcd will see the post as he is the wizard you are looking for


Alan
« Last Edit: February 20, 2021, 03:42:23 PM by Runway 31 »

bvb40170

  • New Member
  • *
  • Posts: 5
Re: radarbox24 not starting on RPi 4
« Reply #4 on: February 20, 2021, 06:41:07 PM »
Thanks,Alan.  I had changed the etc/rbfeeder.ini file to =true
and that didn’t help either, so I’m no further forward.  I knew about the potential conflict with PiAware’s dump1090-fa and the inbuilt dump1090 on RB24.
Hopefully ABCD picks this up.🤞

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 30362
Re: radarbox24 not starting on RPi 4
« Reply #5 on: February 20, 2021, 06:59:53 PM »
Hopefully It would have been a lot easier for him to pick it up on the main board page though

Alan