AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: [solved] Can't connect to external source (127.0.0.1:30005)  (Read 6800 times)

0 Members and 1 Guest are viewing this topic.

digidax

  • New Member
  • *
  • Posts: 2
[solved] Can't connect to external source (127.0.0.1:30005)
« on: August 13, 2020, 06:06:55 AM »
Hi, have installed latest FR24 image (pi24-2.2.0.img) on Raspberry and then the Radarbox feeder. Feeding to FR24 is working, to radarbox not. Here are the important outputs:

Code: [Select]
pi@raspberrypi:~ $ cat /etc/fr24feed.ini
bs=no
raw=no
mlat="yes"
mlat-without-gps="yes"
logmode="2"
receiver="dvbt"
procargs="--gain -10"
fr24key=hidden
receiver=dvbt

Code: [Select]
pi@raspberrypi:~ $ cat /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=hidden
sn=EXTRPI007458
[network]
mode=beast
external_port=30005
external_host=127.0.0.1
[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client
[dump978]
#dump978_enabled=true

Code: [Select]
pi@raspberrypi:~ $ sudo rbfeeder --status
[2020-08-13 07:06:42]  Starting RBFeeder Version 0.3.5 (build 20200727132301)
[2020-08-13 07:06:42]  Using configuration file: /etc/rbfeeder.ini
[2020-08-13 07:06:42]  Network-mode enabled.
[2020-08-13 07:06:42]           Remote host to fetch data: 127.0.0.1
[2020-08-13 07:06:42]           Remote port: 30005
[2020-08-13 07:06:42]           Remote protocol: BEAST
Error opening the listening port 32458 (Raw TCP output): bind: Address already in use
[2020-08-13 07:06:42]  Error opening the listening port 32458 (Raw TCP output): bind: Address already in use
Error opening the listening port 32457 (Beast TCP output): bind: Address already in use
[2020-08-13 07:06:42]  Error opening the listening port 32457 (Beast TCP output): bind: Address already in use
Error opening the listening port 32459 (Basestation TCP output): bind: Address already in use
[2020-08-13 07:06:42]  Error opening the listening port 32459 (Basestation TCP output): bind: Address already in use
Error opening the listening port 32008 (Raw TCP input): bind: Address already in use
[2020-08-13 07:06:42]  Error opening the listening port 32008 (Raw TCP input): bind: Address already in use
Error opening the listening port 32004 (Beast TCP input): bind: Address already in use
[2020-08-13 07:06:42]  Error opening the listening port 32004 (Beast TCP input): bind: Address already in use
[2020-08-13 07:06:42]  System: raspberry
[2020-08-13 07:06:42]  Start date/time: 2020-08-13 07:06:42
[2020-08-13 07:06:42]  Bind failed on ANRB channel. Port: 32088
[2020-08-13 07:06:43]  Connection established.
[2020-08-13 07:06:45]  Can't connect to external source (127.0.0.1:30005). Waiting 5 second...
[2020-08-13 07:06:50]  Can't connect to external source (127.0.0.1:30005). Waiting 5 second...
[2020-08-13 07:06:53]  Could not start connection. Timeout.

Any ideas why port 30005 is not available?
Thanks and all the best, Frank
« Last Edit: August 13, 2020, 08:30:42 AM by digidax »

digidax

  • New Member
  • *
  • Posts: 2
Re: Can't connect to external source (127.0.0.1:30005)
« Reply #1 on: August 13, 2020, 08:30:11 AM »
solved, I had to add "--net" in /etc/fr24feed.ini:
Code: [Select]
procargs="--gain -10" --net

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33712
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #2 on: August 13, 2020, 10:53:03 AM »
Well worked out!!

Alan

rettungshasi

  • New Member
  • *
  • Posts: 1
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #3 on: September 14, 2023, 06:19:34 PM »
Hello, I have the same problem. Even if I run RBfeeder alone I don't get any data. I have installed FR24. I have now made the following settings. FR24 data OK. No data arrives at RBFeeder.

can someone help



pi@raspberrypi:~ $ sudo cat /etc/fr24feed.ini
receiver="dvbt"
fr24key="hidden"
bs="no"
raw="no"
logmode="2"
logpath="/var/log/fr24feed"
mlat="no"
mlat-without-gps="no"
procargs="--gain -10" --net



pi@raspberrypi:~ $ sudo cat /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=hidden

sn=hidden

lat=48.687441999999997

lon=12.199349

alt=435

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

abcd567

  • Hero Member
  • *****
  • Posts: 859
  • CYYZ - Toronto
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #4 on: September 15, 2023, 12:38:05 AM »

@rettungshasi
Mistake is in file /etc/fr24feed.ini

In following line, the location of 2nd " is wrong. It excludes --net from procargs, hence makes it ineffective. As a result no data is available at port 30005 for use by rbfeeder.

procargs="--gain -10" --net

The location of 2nd " should be at the end of line, like below:

procargs="--gain -10 --net"

Please correct the mistake in file /etc/fr24feed.ini, and save the file.

After saving file, restart fr24feed by following command

sudo systemctl restart fr24feed 

Now data at port 30005 will be available for rbfeeder to use. Check its status by following command:

sudo systemctl status rbfeeder   

.
« Last Edit: September 15, 2023, 12:41:22 AM by abcd567 »

ajheatwole

  • New Member
  • *
  • Posts: 16
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #5 on: December 16, 2023, 08:20:58 PM »
I have the same probem - rbfeeder not connecting to Dump1090. I've added procargs="--gain -10 --net" to/etc/fr24feed.ini, but it doesn't work. In fact it kills fr24feed without enabling rbfeeder. Any ideas? Thanks.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33712
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #6 on: December 16, 2023, 09:06:08 PM »
Post your ini file with your key details redacted

Alan

ajheatwole

  • New Member
  • *
  • Posts: 16
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #7 on: December 16, 2023, 09:49:37 PM »
Here are my config files:
$ cat /etc/fr24feed.ini
receiver="dvbt"
fr24key=“key“
path="/usr/lib/fr24/dump1090"
#bs="yes"
bs="no"
#raw="yes"
raw="no"
#logmode="1"
logmode="2"
receiver="dvbt"
#procargs="--gain -10"
#procargs="--net"
logpath="/var/log/fr24feed"
mlat="yes"
mlat-without-gps="yes"

$ cat /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=(key)

sn=EXTRPI555963

[network]
#mode=raw
mode=beast
#external_port=30003
external_port=30005
external_host=127.0.0.1
beast_input_port=30005

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client

[dump978]
#dump978_enabled=false
#dump1090_enabled=true
dump1090_port=30005

abcd567

  • Hero Member
  • *****
  • Posts: 859
  • CYYZ - Toronto
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #8 on: December 17, 2023, 05:15:09 AM »
@ajheatwole

STEP-1: Put right Flightradar setup
(1.1) Delete all contents of your file /etc/fr24feed.ini, and cooy-paste following:
(Replace xxxxx by your actual FR24 key)
Code: [Select]
receiver="avr-tcp"
host="127.0.0.1:30002"
fr24key=“xxxxxxxxx“
bs="no"
raw="no"
logmode="1"
logpath="/var/log/fr24feed"
mlat="yes"
mlat-without-gps="yes"

(1.2) Issue following command to edit config of dump1090-mutability:
Code: [Select]
sudo nano /etc/default/dump1090-mutability 

In the file opened, do following 2 changes:
(a) locate following line which will be in the top portion of the file:
START_DUMP1090="no"

Change no to yes, so the line becimes:

START_DUMP1090="yes"

(b) Scroll down till you see following line near the bottom of file:
NET_BIND_ADDRESS="127.0.0.1"

Delete 127.0.0.1 to make it empty, like below
NET_BIND_ADDRESS=""

Save and close file.

STEP-2: Put right Radarbox setup
Delete all contents of your file /etc/rbfeeder.ini, and cooy-paste following:
(Replace xxxxxxxx by your actual RB24 key)
Code: [Select]
[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=xxxxxxxxxxxxxxxxxxxxxxx
sn=EXTRPI555963

[network]
mode=beast
external_port=30005
external_host=127.0.0.1
[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.9 /usr/bin/mlat-client
[dump978]
#dump978_enabled=true

Save and close file

REBOOT PI


That is all
« Last Edit: December 17, 2023, 04:15:12 PM by abcd567 »

ajheatwole

  • New Member
  • *
  • Posts: 16
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #9 on: December 17, 2023, 05:13:34 PM »
That did the trick. Thanks! Can I buy you a drink? I'm in the Washington DC area of the US.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33712
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #10 on: December 17, 2023, 05:21:41 PM »
Well done, looking good

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 859
  • CYYZ - Toronto
Re: [solved] Can't connect to external source (127.0.0.1:30005)
« Reply #11 on: December 17, 2023, 09:46:57 PM »
That did the trick. Thanks! Can I buy you a drink? I'm in the Washington DC area of the US.

Glad to know that the solution I gave worked and your problem is solved.
I live in Toronto, Ontario, Canada.