AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: How to eliminate "Can't connect to 978 source" messages?  (Read 376 times)

0 Members and 1 Guest are viewing this topic.

vantage

  • New Member
  • *
  • Posts: 6
How to eliminate "Can't connect to 978 source" messages?
« on: July 03, 2020, 09:03:41 PM »
I've got my radarbox RPi feeder working running fine but I keep getting these messages in /var/log/rbfeeder.log so the file keeps growing:
[2020-07-03 21:43:11]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
[2020-07-03 21:43:16]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...
[2020-07-03 21:43:21]  Can't connect to 978 source (127.0.0.1:28380). Waiting 5 second...


It's probably because I built the SD card image with the 978 software thinking I might add the dongle in the future but it's not there now. How do I stop those messages?
TIA


abcd567

  • Sr. Member
  • ****
  • Posts: 341
  • CYYZ - Toronto
Re: How to eliminate "Can't connect to 978 source" messages?
« Reply #1 on: July 03, 2020, 10:43:40 PM »
@vantage:

(1) Open file rbfeeder.ini
Code: [Select]
sudo nano /etc/rbfeeder.ini

(2) Scroll down till you see following:

[dump978]
dump978_enabled=true

Change true to false so it becomes:

[dump978]
dump978_enabled=false

(3) Save file (Ctrl+O) and close (Ctrl+x)

(4) Restart rbfeeder
Code: [Select]
sudo systemctl restart rbfeeder

(5) Above is enough to stop irritating warning "Can't connect to 978 source".
However if you are not running dump978-rb, better to disable it, otherwise it unnecessarily keeps running in background, genersting its own log "unable to find the dongle". To stop it do following:

Code: [Select]
sudo systemctl stop dump978-rb 

sudo systemctl disable dump978-rb 

(6) If anytime you get a second dongle for 978, you can enable and start dump978-rb by following commands:

Code: [Select]
sudo systemctl enable dump978-rb 

sudo systemctl start dump978-rb 


vantage

  • New Member
  • *
  • Posts: 6
Re: How to eliminate "Can't connect to 978 source" messages?
« Reply #2 on: July 04, 2020, 02:09:12 AM »
That worked perfectly. The only hiccup was it killed mlat-client too. I cold-started the Pi and everything is running now. The tip on re-enabling 978 is appreciated.

Thanks again.

abcd567

  • Sr. Member
  • ****
  • Posts: 341
  • CYYZ - Toronto
Re: How to eliminate "Can't connect to 978 source" messages?
« Reply #3 on: July 04, 2020, 02:34:22 AM »


The only hiccup was it killed mlat-client too. I cold-started the Pi and everything is running now.

What I understand is that:
(1) When you disabled dump978, mlat also stopped.
(2) After that when you cold started Pi, mlat got restored.

Did I get you right?

.

vantage

  • New Member
  • *
  • Posts: 6
Re: How to eliminate "Can't connect to 978 source" messages?
« Reply #4 on: July 04, 2020, 05:15:17 AM »
I don't know if it was after the 'sudo systemctl restart rbfeeder', 'stop' or the 'disable' but one of them did it. I would have to assume it was the stop. After I was done with the steps you outlined I ran 'top' and mlat-client was missing. So I cold-started the Pi and rbfeeder and mlat-client were both running normally.

abcd567

  • Sr. Member
  • ****
  • Posts: 341
  • CYYZ - Toronto
Re: How to eliminate "Can't connect to 978 source" messages?
« Reply #5 on: July 04, 2020, 05:32:14 AM »
Great! Glad that your system is finally runnung normally. Does not matter what happened during fixing the trouble, it was only a temporary thing.