AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: dump978-rb not running  (Read 188 times)

0 Members and 1 Guest are viewing this topic.

nigelj65

  • New Member
  • *
  • Posts: 17
dump978-rb not running
« on: March 11, 2020, 05:05:52 PM »
Hello all,

I checked to see if there was a thread that would help me get dump978-rb up and running but no joy. abcd567's thread dump978-rb Failure Due to Missing SoapySDR [S O L V E D] is for a different OS?

Tried running package updates but all seem up to date. Maybe the config is wrong somewhere, possibly a port number? dump1090-fa is running and feeding RB and FA. I've attached an extract from the daemon log which is growing with error messages. As ever any help appreciated.
« Last Edit: March 11, 2020, 07:10:00 PM by nigelj65 »

abcd567

  • Sr. Member
  • ****
  • Posts: 296
  • CYYZ - Toronto
Re: dump978-rb not running
« Reply #1 on: March 12, 2020, 03:02:51 AM »
Thanks for posting the files of ouyputs.
The logs show that dump978-rb could not find a dongle to use. Have you plugged two dongles in RPi? One dongle is needed for 1090mhz and other for 978mhz. If you have two dongles, did you serialize them?


(1) First install test tool
Code: [Select]
sudo apt install rtl-sdr

(2) Next give these commands, and post output
Code: [Select]
rtl_test -t -d 0
rtl_test -t -d 1

(3) Post output of this command
Code: [Select]
cat /etc/default/dump978-rb
« Last Edit: March 12, 2020, 03:08:50 AM by abcd567 »

nigelj65

  • New Member
  • *
  • Posts: 17
Re: dump978-rb not running
« Reply #2 on: March 12, 2020, 10:03:15 AM »
Hi abcd567,

I have two dongles but it isn't practical to run two antennas, unless one of them is the original version that came with the MicroRB? I had very poor coverage with that. Is there an other option or is it better to disable dump978-rb?

Thanks

abcd567

  • Sr. Member
  • ****
  • Posts: 296
  • CYYZ - Toronto
Re: dump978-rb not running
« Reply #3 on: March 12, 2020, 03:05:11 PM »
It is OK to use MicroRB's mag-mount antenna for dump978, provided you place it:
(1) Near a window, or in attic
(2) Above a metallic plate or can

I am using Flightaware 66cm 1090 Mhz antenna for dump1090 and the MicroRB's mag-mount antenna for 978 Mhz. Both antennas are indoor, placed near a large window. The mag-mount antenna is placed over a cookie-can


Your logs show that problem is not the antenna, problem is that dump978 does not connect to the dongle. You said you have two dongles. Are both dongles plugged into RPi? one dongle is used by dump1090 and second by dump978.

Please install test-tool "rtl-sdr', then perform the test, and post the output.

Code: [Select]
sudo apt install rtl-sdr

rtl_test -t -d 0

rtl_test -t -d 1


abcd567

  • Sr. Member
  • ****
  • Posts: 296
  • CYYZ - Toronto
Re: dump978-rb not running
« Reply #4 on: March 12, 2020, 05:19:06 PM »
Further checks show you have enabled BOTH dump978-fa AND dump978-rb. Each one needs a dongle, so you will need 3 dongles
-first one for dump1090-fa
-second one for dump978-fa
-third one for dump978-rb

If you want to disable RadarBox's dump978-rb

STEP-1
Code: [Select]
sudo nano /etc/rbfeeder.ini

In the file opened scroll down. You will see last line ase follows:

#dump978_enabled=true


Remove # at start of line
change true to false
the line will become like this:

dump978_enabled=false

Save file (Ctrl+o) and close (Ctrl+x)


STEP-2
Code: [Select]
sudo nano /etc/default/dump978-rb

locate the line which is only this:
ENABLED=yes

Change yes to no.
The line will become like this
ENABLED=no

Save file (Ctrl+o) and close (Ctrl+x)

REBOOT RPI

Now check logs, you should find that all error messages have stopped.


« Last Edit: March 12, 2020, 05:21:09 PM by abcd567 »

nigelj65

  • New Member
  • *
  • Posts: 17
Re: dump978-rb not running
« Reply #5 on: March 13, 2020, 08:04:26 PM »
Excellent advice, thank you. Once I've sorted out the dongle/antenna situation I'll come back to this.