anything
AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY  (Read 25894 times)

0 Members and 2 Guests are viewing this topic.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33039
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #45 on: March 27, 2019, 02:49:34 PM »
Add the IP address of the receiver on your network onto your browser

Alan

medlege

  • Jr. Member
  • **
  • Posts: 50
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #46 on: March 27, 2019, 02:53:21 PM »
Hello !

No it is not working I have this page, surely miss the ports ?
See attached file pls.

Thanks

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33039
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #47 on: March 27, 2019, 03:03:31 PM »
Ok will leave it to one of the Pi gurus to advise as I don't know if it is possible to access that info or even if it is available

I only know the map is available here https://www.radarbox24.com/stations/EXTRPI001353

Alan

abcd567

  • Hero Member
  • *****
  • Posts: 759
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #48 on: March 27, 2019, 03:04:37 PM »

Now I would like to install Flightaware feeder so I just go on their website and install the just the feeder ?
I would like to have the 3 working on the same Pi.

With PI24's dump1090-mutability ver 1.14:
1) You wont be able to see Flightaware's MLAT planes on the map.

2) If you use "-net-bi-port 30104" to receive FA mlat feedback, it will be fedback to Flightaware as well as as all other sites as planes received by your antenna & receiver.

You have to:
1) Change setting of fr24feed from "receiver=dvbt" to "receiver=beast-tcp", "host=127.0.0.1:30005"

2) Purge version 1.14
Code: [Select]
sudo dpkg --purge dump1090-mutability 
3) Install dump1090-mutability version 1.15 (see steps for dump1090  in bake a pi option 1).

The settings in this case will be as the screenshot I am attaching below.


Alternatively you can make a fresh install by reimaging your microSD card, usin option 1, 2 or 3 of "Bake A Pi" thread.


medlege

  • Jr. Member
  • **
  • Posts: 50
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #49 on: March 27, 2019, 03:15:28 PM »
Hi abcd567 and thanks for your help !
I appreciate !

Why everything with linux is soooo complicated LOL !!!!!
I saw your thread https://forum.flightradar24.com/threads/11137-How-to-Feed-Data-to-Multiple-Sites-A-Brief-Guide
I taught that with OPTION (A) Pi24 image from Flightradar24.com I could now install Flightaware  as I am concerned by the (A) section.

But know I'm lost !
So I just can't install Flightaware on my Pi24 containing also Radarbox24 at the moment ?

But on this thread I can install it !

Thanks for your help.
Regards.


abcd567

  • Hero Member
  • *****
  • Posts: 759
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #50 on: March 27, 2019, 03:17:57 PM »
Excuse me but do you know how to reach the Radarbox24 browser Pi setting page like for FR24 → piaddress:8754 ?
And how do you acces the map page with radarbox24 like FR24 → Piaddress/dump1090/gmap.html ?

Please can you help me with this ?

Thanks.

(1) Radarbox feeder does NOT have a Browser setting page. You have to SSH to Pi, and edit following file, but I dont think you need to do that after you have once made the settings.

Code: [Select]
sudo nano /etc/rbfeeder.ini 
The above command will open nano editor

Code: [Select]

[client]
network_mode=true
log_file=/var/log/rbfeeder.log

key=xxxxxxxxxxxxxxxxxxxxxxxx

sn=EXTRPI000xxx

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]


(2) Radarbox Pi feeder does NOT display a map page. Use Pi24's  at "ip-of-pi/dump1090/gmap.html"


.

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33039
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #51 on: March 27, 2019, 03:20:04 PM »
I see that you are not using the latest version and don't have it set for MLAT on RB24

Alan

wiedehopf

  • Jr. Member
  • **
  • Posts: 66
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #52 on: March 27, 2019, 03:22:43 PM »
This forum is infuriating.

Go over to the flightaware or flightradar24 forum and ask there it's not allowing me to post links here.
That's just stupid.

Anyway you will have to upgrade to Stretch to install piaware i believe.
Don't know if that even works on the pi24 image.

(I had all the upgrading to stretch and installation stuff typed out but there are of course links in there)

abcd567

  • Hero Member
  • *****
  • Posts: 759
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #53 on: March 27, 2019, 03:25:29 PM »
But know I'm lost !
So I just can't install Flightaware on my Pi24 containing also Radarbox24 at the moment ?

But on this thread I can install it !

You CAN install Flightaware feeder on PI24, but the mlat planes wont be displayed on map as mlat plane due to limitation of ver 1.14. Also it will create a mess to the sites by sending mlat data as data received by your antenna & dongle. In this case do NOT feedback mlat to dump1090 (i.e. do not use process argument  --net-bi-port 30104).

medlege

  • Jr. Member
  • **
  • Posts: 50
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #54 on: March 27, 2019, 03:32:17 PM »
Ah OK !!
So I will take some time to think about it and see what is the better thing to do !!! It is very complicated Linux !!

I also wanted to know something...
To avoid all that is it possible to use a VHF splitter 1/2 to split the coaxial cable coming from the antenna in 2 and then connect each site with his own Pi ?

Is it technically possible or we must avoid that ?

Thanks.

wiedehopf

  • Jr. Member
  • **
  • Posts: 66
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #55 on: March 27, 2019, 03:34:37 PM »
Don't do that.

It's not that hard to install all feed sites.
Just don't start with a pi24 image.

Start with a normal Rasbpian Stretch Lite or piaware sd-card image.
(And follow the guide, for example OPTION 2 in this thread: http://www.airnavsystems.com/forum/index.php?topic=10201.msg187831#msg187831)

abcd567

  • Hero Member
  • *****
  • Posts: 759
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #56 on: March 27, 2019, 03:35:55 PM »

Anyway you will have to upgrade to Stretch to install piaware i believe.
Don't know if that even works on the pi24 image.


Flightaware feeder (Piaware) works on PI24 latest image. I haveprepared a microSD card with PI24 image 2 weeks ago, and Piaware imstalled on it. However the latest Pi24 is based on Stretch, and Piaware 3.6.3 installs ok on Strerch, but gives problem on Jessie.

Upgrading @medlege's current Pi24 to Stretch is not a smooth solution.

Easiest solution is to write Piaware image, and install FR24 & RB24 on it (Bake A Pi, Option 3).

I personally prefer the suggestion of @wiedehpof to use generic Raspbian instead of Piaware image or Pi24 image and use dump1090-fa which has a better looking map (option 2 of Bake A Pi)
« Last Edit: March 27, 2019, 03:47:47 PM by abcd567 »

wiedehopf

  • Jr. Member
  • **
  • Posts: 66
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #57 on: March 27, 2019, 03:46:57 PM »
Oh so they did update their pi24 image. (I should be nicer to FR24 :) )

Is the updated image the one where it mounts read-only?
Or was that one of the past iterations?

medlege

  • Jr. Member
  • **
  • Posts: 50
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #58 on: March 27, 2019, 03:49:15 PM »
Ok thank you all for those explanations !

I definitively won't use the splitter option and save multiple raspberry price also !!!
So the best solution is to start from a new fresh installation containing stretch.
This will need some time and energy !!! Linux gives serious headache LOL !!!
Ok I will think and see what is the best solution to do ! I wanted to install Flightaware on it but know I hesitate a bit.

I thought that each site provides a raspian update with their official updates but it is only the feeder that receive the updates !

A very very big Thank you again to all you for your kindness and support !
Best regards !

abcd567

  • Hero Member
  • *****
  • Posts: 759
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #59 on: March 27, 2019, 03:51:39 PM »
Oh so they did update their pi24 image. (I should be nicer to FR24 :) )

Is the updated image the one where it mounts read-only?
Or was that one of the past iterations?

Yes, the latest Pi24 image has problem of occassionaly behaving  "read-only file system".

Best option is to use generic Raspbian image (options 1 or 2 of bake a pi)