AirNav RadarBox
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY  (Read 34829 times)

0 Members and 2 Guests are viewing this topic.

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #60 on: March 27, 2019, 03:51:48 PM »
Oh so they did update their pi24 image. (I should be nicer to FR24 :) )

Is the updated image the one where it mounts read-only?
Or was that one of the past iterations?

It was the version I installed in 2016 the day I activated my feeder

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #61 on: March 27, 2019, 03:59:25 PM »
I see that you are not using the latest version and don't have it set for MLAT on RB24

Alan

Hi!

How do you see that ?
How to have it set for MLAT please ?

Thanks

abcd567

  • Hero Member
  • *****
  • Posts: 859
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #62 on: March 27, 2019, 04:02:08 PM »
So the best solution is to start from a new fresh installation containing stretch.

Best option is option 2 of bake a pi thread: Raspbian image with dump1090-fa (due to its very nice map).

I have Raspbian Stretch + dump1090-mut 1.15~dev on RasPi, and  Armbian Stretch + dump1090-fa on OrangePi. Both Pis have following feeders installed:

- Radarbox24
- Flightradar24
- Flightaware
- Planefinder
- OpenSky network



Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 33712
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #63 on: March 27, 2019, 04:09:59 PM »
I am advised to get the latest build of the RB24 feeder and set it for MLAT

run "apt-get update -y; apt-get install mlat-client -y; reboot" then setup the Lon and Lat in your station id profile and then will be MLAT ready

Alan

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #64 on: March 27, 2019, 04:21:10 PM »
So the best solution is to start from a new fresh installation containing stretch.

Best option is option 2 of bake a pi thread: Raspbian image with dump1090-fa (due to its very nice map).

I have Raspbian Stretch + dump1090-mut 1.15~dev on RasPi, and  Armbian Stretch + dump1090-fa on OrangePi. Both Pis have following feeders installed:

- Radarbox24
- Flightradar24
- Flightaware
- Planefinder
- OpenSky network

Yes abcd567 !! You are right !!

If I choose option 2 I will have to follow all the steps strictly for each feeder also concerning FR24 for example to be sure to set all the good parameters !!
I will read carefully all the thread before I do anything.
I've been on Flightaware site. There is a link for jessie users but it is clearly advised to:
"It is highly recommended that you upgrade to the latest Raspbian Stretch OS to gain the full benefits of PiAware"

OK we will see !
Regards !

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #65 on: March 27, 2019, 04:47:49 PM »

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #66 on: March 28, 2019, 10:21:26 AM »
Good morning to everyone !

Please can you help me to free some space on my Pi ?
Prior to install Planefinder this morning, I add a message error no free space on disk.
What package can I remove to free some space on the Pi ?
I already made:
sudo apt-get autoremove
sudo apt-get clean

Here attached a screenshot.
I really don't understand why I have those poor results ! I have a 8G micro sd card although...
Or Pi24 do not consider the size of the micro SD ?!?!

Thanks again a lot.

abcd567

  • Hero Member
  • *****
  • Posts: 859
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #67 on: March 28, 2019, 10:38:55 AM »
Code: [Select]
sudo raspi-config

This will open a window with options. Scroll down to "Advance options" and press Enter key. Then choose "Expand file system" and press Enter key

This is what my PI24 (latest pi24-2.1.0.img, Stretch) shows on 8 Gb microSD card:

Code: [Select]

pi@raspberrypi:~ $ df -h

Filesystem      Size  Used Avail Use% Mounted on
/dev/root       7.2G  1.5G  5.4G  22% /
devtmpfs        460M     0  460M   0% /dev
tmpfs           464M  192K  464M   1% /dev/shm
tmpfs           464M   17M  448M   4% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           464M     0  464M   0% /sys/fs/cgroup
tmpfs           200M  8.0K  200M   1% /tmp
tmpfs            10M  272K  9.8M   3% /var/log
/dev/mmcblk0p1   44M   22M   22M  51% /boot
tmpfs            93M     0   93M   0% /run/user/1000
« Last Edit: March 28, 2019, 11:07:02 AM by abcd567 »

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #68 on: March 28, 2019, 10:57:15 AM »
Thank you sooo much abcd567 !!!

You are really a master !!!

I'm installing planefinder now !!!
Thanks again and best regards !
--------
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       7.2G  582M  6.4G   9% /
devtmpfs        459M     0  459M   0% /dev
tmpfs           463M   44K  463M   1% /dev/shm
tmpfs           463M  6.3M  457M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           463M     0  463M   0% /sys/fs/cgroup
tmpfs           100M  164K  100M   1% /var/log
/dev/mmcblk0p1   60M   20M   41M  34% /boot

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #69 on: September 23, 2019, 03:52:59 PM »
Hello to all of you.
Please I need your help.

In March I successfully installed Radarbox24 / Flightaware / Planefinder on my Flightradar24 Raspberry Pi and it was working really so great without any trouble !
But since a few days now I have a big problem but only with Radarbox24...
Indeed, if Radarbox24 is online then all the 3 others (Flightradar24 / Flightaware / Planefinder) are not working any more (0 planes tracked or uploaded).
And if Flightradar24 / Flightaware / Planefinder are working fine, then Radarbox24 is offline. I don't know why it suddenly happened like this.

So please can you help me to just uninstall Radarbox24 and after that to re-install it again on the Pi.

I will then re-enter my mail in order to keep my radar name and code reloaded again.
Maybe it will fix this issue and work again fine as it use to...

Thanks a lot in advance for your kind help.
Waiting for your instructions please...

abcd567

  • Hero Member
  • *****
  • Posts: 859
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #70 on: September 23, 2019, 08:32:47 PM »
Open file rbfeeder.ini

Code: [Select]
sudo nano /etc/rbfeeder.ini


Check that network_mode is set to true
See below in red color

Quote
[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
sn=EXTRPI000nnn

[network]
mode=beast
external_port=30005
external_host=127.0.0.1


 

medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #71 on: September 24, 2019, 07:22:32 AM »
Hello abcd567,

Here is a screenshot when I type the code:
sudo nano /etc/rbfeeder.ini
I can't find the network mode...

What should I do ?

Thanks a lot.
Regards.

wiedehopf

  • Jr. Member
  • **
  • Posts: 66
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #72 on: September 24, 2019, 07:38:14 AM »
copy and save your SN and key

Then use the configuration abcd posted above.
Adjust SN and key so it's yours.


medlege

  • Jr. Member
  • **
  • Posts: 53
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #73 on: September 24, 2019, 10:07:15 AM »
Hello wiedehopf !

Excuse me I did not understand...
As I told you, when I type the code "sudo nano /etc/rbfeeder.ini" as abcd567 said, I can't find the network mode...
My rbfeeder is still not working...

Thanks in advance for your help.

abcd567

  • Hero Member
  • *****
  • Posts: 859
  • CYYZ - Toronto
Re: I CAN'T INSTALL RBFEEDER ON MY Pi24 RASPBERRY
« Reply #74 on: September 24, 2019, 03:20:32 PM »
What wiedehopf has told you is to copy-paste the missing lines into the window whose screenshot you have posted. That is an easy thing to do.

Alternatively you can add the missing lines by following method also:

Give following 4 commands one by one:

Code: [Select]
sudo rbfeeder --set-network-mode on --no-start   

sudo rbfeeder --set-network-host 127.0.0.1 --no-start   

sudo rbfeeder --set-network-port 30005 --no-start   

sudo rbfeeder --set-network-protocol beast --no-start   


After above 4 commands you must restart rbfeeder by following command:
Code: [Select]
sudo systemctl restart rbfeeder   



After restart, give following command and post what you see.

Code: [Select]
sudo nano /etc/rbfeeder.ini   


« Last Edit: September 24, 2019, 06:41:21 PM by abcd567 »