AirNav Systems Forum

AirNav RadarBox and RadarBox24.com => AirNav RadarBox and RadarBox24.com Discussion => Topic started by: tgo on October 02, 2020, 09:02:27 PM

Title: This might sound strange but I need to disable mlat (but keep everything else)
Post by: tgo on October 02, 2020, 09:02:27 PM
How do I do this, RB mlat doesn't play nice with other feeders so I need to lose the RB mlat and reinstall the more friendly one.


my rbfeeder.ini shows this

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

How would I go about just uninstalling/removing RB mlat?
Title: Re: This might sound strange but I need to disable mlat (but keep everything else)
Post by: Runway 31 on October 03, 2020, 04:49:06 PM
I dont see why the mlat client causes issue, plenty of users have it working and are feeding other trackers without issues, hopefully some one familiar with Pi's will come along and assist

In the meantime have a read at https://forum.radarbox24.com/index.php?topic=101771.0

Alan
Title: Re: This might sound strange but I need to disable mlat (but keep everything else)
Post by: abcd567 on October 08, 2020, 01:05:14 AM
Change true by false as shown below

[mlat]
autostart_mlat=true  false
#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

Save file.
Restart rbfeeder

sudo systemctl resrart rbfeeder 
Title: Re: This might sound strange but I need to disable mlat (but keep everything else)
Post by: tgo on October 08, 2020, 08:28:36 AM
Thanks, although I notice that this seems to think I'm on python 3.5, when I'm on 3.7 (or whatever the latest is)
Title: Re: This might sound strange but I need to disable mlat (but keep everything else)
Post by: abcd567 on October 09, 2020, 02:46:36 AM
Thanks, although I notice that this seems to think I'm on python 3.5, when I'm on 3.7 (or whatever the latest is)

#mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client

The above line of code is commented-out (it starts with # ).
This means this line will be ignored during execution.

I also have raspbian buster which has python 3.7
To use this command, I did two things:
(1) Deleted #
(2) changed 3.5 to 3.7
(3) Saved file /etc/rbfeeder.ini
(4) Restarted rbfeeder
sudo systemctl restart rbfeeder





Title: Re: This might sound strange but I need to disable mlat (but keep everything else)
Post by: tgo on October 09, 2020, 08:01:47 AM
Thanks for that, so if it's commented out, what function does it serve when it's not, and what runs in its place when it's commented out.