AirNav Systems Forum

AirNav RadarBox and RadarBox24.com => AirNav RadarBox and RadarBox24.com Discussion => Topic started by: beeyev on May 24, 2019, 04:07:19 PM

Title: Radarbox24 - RBFeeder error during install on raspberry pi [SOLVED!]
Post by: beeyev on May 24, 2019, 04:07:19 PM
User abcd567 solved the problem
Need to install netbase package.

Code: [Select]
sudo apt update
sudo apt install netbase
sudo systemctl restart rbfeeder

Post with solution (https://www.airnavsystems.com/forum/index.php?topic=101981.msg400661#msg400661)


------------------------------------

I am using DietPi distro for Raspberry Pi 3, it's based on raspbian stretch, i like this distro and have no issues with feeding FR24 or FA.
I need your help to solve the problem, why RBFeeder does not work.

Service crashes with this error:
Code: [Select]
May 24 18:38:56 DietPi systemd[1]: rbfeeder.service: Service RestartSec=100ms expired, scheduling restart.
May 24 18:38:56 DietPi systemd[1]: rbfeeder.service: Scheduled restart job, restart counter is at 5.
May 24 18:38:56 DietPi systemd[1]: Stopped RBFeeder Service.
May 24 18:38:56 DietPi systemd[1]: rbfeeder.service: Start request repeated too quickly.
May 24 18:38:56 DietPi systemd[1]: rbfeeder.service: Failed with result 'exit-code'.
May 24 18:38:56 DietPi systemd[1]: Failed to start RBFeeder Service.

if i try to start it with key: rbfeeder --setkey fffffff322323323
i got this error:
Code: [Select]
getaddrinfo: Servname not supported for ai_socktype
[2019-05-24 19:03:02]  Could not resolve host name specified in 'external_host'.

Logs are empty.

How can i fix this? Have you got any ideas?

Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 24, 2019, 09:45:11 PM
Please post output of this command
Code: [Select]
cat /etc/rbfeeder.ini

Note: Replace your actual key by xxxxxxx when posting the output

For your guidance, output of above command on my RPi is given below.
Note: I have replaced actual key by xxxxxxxxxx and station number sn by nnnn
Code: [Select]

[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=xxxxxxxxxx
sn=EXTRPI00nnnn


[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: beeyev on May 25, 2019, 03:37:21 PM
it's ok, i have already checked
Code: [Select]
[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=xxxxxxxxxx

[network]
mode=beast
external_port=30005
external_host=127.0.0.1
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 25, 2019, 04:49:11 PM
Let us try this and see if it solves the problem:

In file rbfeeder.ini, change
external_host=127.0.0.1
 To
 external_host=localhost


Save file, then restart rbfeeder

sudo systemctl restart rbfeeder
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: beeyev on May 25, 2019, 05:04:11 PM
i tried, still same error.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: wiedehopf on May 25, 2019, 05:14:18 PM
For testing, start it on the console:

sudo systemctl stop rbfeeder
sudo rbfeeder

Please post the output.

Also show the output of:
ping 127.0.0.1 -c2
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: beeyev on May 25, 2019, 05:15:07 PM
same
Code: [Select]
[email protected]:~# sudo rbfeeder
[2019-05-25 20:14:04]  Compiled with arch=raspberry
getaddrinfo: Servname not supported for ai_socktype
[2019-05-25 20:14:04]  Could not resolve host name specified in 'external_host'.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: wiedehopf on May 25, 2019, 05:17:59 PM
How did you create /etc/rbfeeder.ini?

Show the output of:

ls -l /etc/rbfeeder.ini


Also show the output of:

 cat -v /etc/rbfeeder.ini

ping 127.0.0.1
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: wiedehopf on May 25, 2019, 05:25:29 PM
Just as a test use localhost instead of 127.0.0.1

Best delete the old line and past this one:

external_host=localhost
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: beeyev on May 25, 2019, 05:41:18 PM
it did not help, unfortunately.

here is an strace
https://pastebin.com/wz67d9tZ

or in attch, could you please look at it, maybe you will find smth.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 25, 2019, 05:45:20 PM
What is the output of following command:

Code: [Select]
cat /etc/hosts
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: beeyev on May 25, 2019, 05:46:20 PM
Code: [Select]
127.0.0.1    localhost
127.0.1.1 DietPi
#::1 localhost ip6-localhost ip6-loopback
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters

enabling ipv6 does not change anything
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: wiedehopf on May 25, 2019, 05:53:13 PM
Either you overlooked one of my posts or one of yours got moderated:

I'll just ask again :)

Show the output of:

ls -l /etc/rbfeeder.ini


Also show the output of:

cat -v /etc/rbfeeder.ini

ping 127.0.0.1 -c1

rbfeeder -v

Maybe there is some library version issue in regards to internet protocols.
But not sure what the exact problem is.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 25, 2019, 05:56:12 PM
May be some files got corrupted during install of rbfeeder.
Purge and reistall rbfeeder.
NOTE: You must copy and save your key in a text file on your desktop/Laptop before purging.

Code: [Select]
sudo apt-get purge rbfeeder
sudo reboot
sudo apt-get install rbfeeder

After the apt-get install command, you may get "certificate not authenticated" warning. Ignore it by pressing y key then Enter key

When installation of rbfeeder is completed, do this:
Code: [Select]
# Restart and check status
sudo systemctl restart rbfeeder
sudo systemctl status rbfeeder

# Is it working OK now?

#Replace the new key in this file by the key you have saved
sudo nano /etc/rbfeeder.ini

# Restart rbfeeder and check status
sudo systemctl restart rbfeeder
sudo systemctl status rbfeeder


Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: beeyev on May 25, 2019, 08:53:49 PM
wiedehopf sorry.

Code: [Select]
ls -l /etc/rbfeeder.ini
-rw-r--r-- 1 root root 124 May 25 20:29 /etc/rbfeeder.ini

Code: [Select]
cat -v /etc/rbfeeder.ini
[client]
network_mode=true
log_file=/var/log/rbfeeder.log

[network]
mode=beast
external_port=30005
external_host=127.0.0.1


Code: [Select]
ping 127.0.0.1 -c1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.125 ms

--- 127.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.125/0.125/0.125/0.000 ms


Code: [Select]
rbfeeder -v
[2019-05-25 23:51:19]  Compiled with arch=raspberry
RBFeeder v0.2.19 (build 20190226175114)

Code: [Select]
nc -zv 127.0.0.1 30005
localhost [127.0.0.1] 30005 (?) open


abcd567, reinstalling does not help at all, i tried several times different ways.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 25, 2019, 10:03:00 PM
abcd567, reinstalling does not help at all, i tried several times different ways.
OK I have now downloaded DietPi_RPi-ARMv6-Stretch.img.
Will write it to spare microSD card, slip into RPi 2, and install dump1090-fa (do you have dump1090-fa or mutability???), then install fr24feed, piaware, and rbfeeder and see if the issue is specific to DietPi
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 25, 2019, 11:30:42 PM
SOMETHING WRONG WITH DIETPI

Quote

 ─────────────────────────────────────────────────────
 DietPi v6.24.1 : 00:20 - Sun 26/05/19
 ─────────────────────────────────────────────────────
 - Device model : RPi 2 Model B (armv7l)
 - CPU temp : 51'C : 123'F (Running warm, but safe)
 - LAN IP : 192.168.0.21 (eth0)
 - MOTD : Check out our new RPi Buster image: https://dietpi.com/downloads/testing/
   NB: For testing only, or if you like to stay on bleeding edge ;).
 ─────────────────────────────────────────────────────

 DietPi Team     : MichaIng (lead), Daniel Knight (founder)
 Image           : DietPi Core Team (pre-image: Raspbian Lite)
 Web             : https://DietPi.com | https://twitter.com/dietpi_
 Patreon Legends : PINE64 community
 Donate          : https://DietPi.com/#donate
 DietPi Hosting  : Powered by https://MyVirtualServer.com

 dietpi-launcher : All the DietPi programs in one place.
 dietpi-config   : Feature rich configuration tool for your device.
 dietpi-software : Select optimized software for installation.
 htop            : Resource monitor.
 cpu             : Shows CPU information and stats.

[email protected]:~# rbfeeder
[2019-05-26 00:20:41]  Compiled with arch=raspberry
getaddrinfo: Servname not supported for ai_socktype
[2019-05-26 00:20:41]  Could not resolve host name specified in 'external_host'.



OTHER FEEDERS OK
Quote

[email protected]:~# fr24feed-status
[ ok ] FR24 Feeder/Decoder Process: running.
[ ok ] FR24 Stats Timestamp: 2019-05-25 23:20:12.
[ ok ] FR24 Link: connected [UDP].
[ ok ] FR24 Radar: T-CYYZ9.
[ ok ] FR24 Tracked AC: 33.
[ ok ] Receiver: connected (40162 MSGS/0 SYNC).
[ ok ] FR24 MLAT: ok [UDP].
[ ok ] FR24 MLAT AC seen: 30.


Quote
[email protected]:~# systemctl status piaware
● piaware.service - FlightAware ADS-B uploader
   Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-05-26 00:16:40 BST; 14min ago
     Docs: https://flightaware.com/adsb/piaware/
 Main PID: 523 (piaware)
   CGroup: /system.slice/piaware.service
           ├─ 523 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json
           ├─ 731 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 43.xxx --lon -79.xxx
           └─1326 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30
005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.254:5503:2988728769

May 26 00:17:39 DietPi piaware[523]: mlat-client(1326): fa-mlat-client 0.2.10 starting up
May 26 00:17:39 DietPi piaware[523]: mlat-client(1326): Using UDP transport to 70.42.6.254 port 5503
May 26 00:17:39 DietPi piaware[523]: mlat-client(1326): Listening for Beast-format results connection on port 30105
May 26 00:17:39 DietPi piaware[523]: mlat-client(1326): Listening for Extended Basestation-format results connection on port 30106
May 26 00:17:39 DietPi piaware[523]: mlat-client(1326): Input connected to localhost:30005
May 26 00:17:39 DietPi piaware[523]: mlat-client(1326): Input format changed to BEAST, 12MHz clock
May 26 00:17:39 DietPi piaware[523]: mlat-client(1326): Beast-format results connection with ::1:30104: connection established
May 26 00:17:41 DietPi piaware[523]: piaware has successfully sent several msgs to FlightAware!
May 26 00:22:16 DietPi piaware[523]: 1030 msgs recv'd from dump1090-mutabi (915 in last 5m); 827 msgs sent to FlightAware
May 26 00:27:16 DietPi piaware[523]: 1901 msgs recv'd from dump1090-mutabi (871 in last 5m); 1698 msgs sent to FlightAware


Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 26, 2019, 02:39:41 AM
THE BUG
Code: [Select]
[email protected]:~# rbfeeder
[2019-05-26 00:20:41]  Compiled with arch=raspberry
getaddrinfo: Servname not supported for ai_socktype
[2019-05-26 00:20:41]  Could not resolve host name specified in 'external_host'.


FOUND REASON: Missing package netbase


SOLUTION: Installed package netbase
Code: [Select]
sudo apt update
sudo apt install netbase
sudo systemctl restart rbfeeder

Checked status
Code: [Select]
[email protected]:~# sudo systemctl status rbfeeder
● rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-05-26 03:31:03 BST; 5min ago
 Main PID: 503 (rbfeeder)
   CGroup: /system.slice/rbfeeder.service
           └─503 /usr/bin/rbfeeder

May 26 03:33:45 DietPi rbfeeder[503]: [2019-05-26 03:33:45]  ******** Statistics updated every 30 se
conds ********
May 26 03:33:45 DietPi rbfeeder[503]: [2019-05-26 03:33:45]  Packets sent in the last 30 seconds: 33
0, Total packets sent since startup: 1341
May 26 03:34:16 DietPi rbfeeder[503]: [2019-05-26 03:34:16]  ******** Statistics updated every 30 se
conds ********
May 26 03:34:16 DietPi rbfeeder[503]: [2019-05-26 03:34:16]  Packets sent in the last 30 seconds: 36
4, Total packets sent since startup: 1705


OPTIONAL ENHANCEMENTS

(1) Enable MLAT
https://www.airnavsystems.com/forum/index.php?topic=101771.msg389571#msg389571

(2) Install Graphs
https://github.com/wiedehopf/graphs1090/blob/master/README.md

.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: beeyev on May 26, 2019, 02:56:28 PM
abcd567, you even installed DietPi, to help me solve my problem, thank you so much! It works now!
Could you please tell me, how did you find the solution?
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi
Post by: abcd567 on May 26, 2019, 04:31:53 PM
Could you please tell me, how did you find the solution?

By lot of Google search, and trying lot of different solutions found in the search.
All solutions failed, but finally netbase one worked. :)

Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi [SOLVED!]
Post by: beeyev on May 26, 2019, 04:33:25 PM
Thanks again man, you are the best!
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi [SOLVED!]
Post by: abcd567 on May 26, 2019, 04:35:35 PM
By the way did you enable MLAT and did you install Graphs?
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi [SOLVED!]
Post by: beeyev on May 26, 2019, 04:37:14 PM
Nop, but i am going to enable it. I just did not know that RB24 supports this feature.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi [SOLVED!]
Post by: abcd567 on May 26, 2019, 04:43:46 PM
I just did not know that RB24 supports this feature.

It is still in beta stage so not yet announced officially.
Remember that Flightaware provides mlat feedback, but RB24 does not (yet) provide mlat feedback.

Do install Graphs. These are easy to install, and are very handy and useful tool.
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi [SOLVED!]
Post by: Runway 31 on May 26, 2019, 04:57:08 PM
I don't have a clue about all that coding but very well done.  Depending on where you are and the type of feeders around you, MLAT is available  See for example https://www.radarbox24.com/stations/PGANRB500005 7 stations synced.

Alan
Title: Re: Radarbox24 - RBFeeder error during install on raspberry pi [SOLVED!]
Post by: abcd567 on May 26, 2019, 11:54:15 PM
The screenshot shows the Graphs on my RPi

Installed by method given here:
https://github.com/wiedehopf/graphs1090/blob/master/README.md