I have an odd one here.
My rbfeeder setup went smoothly, and airplane positions show up in /var/log/rbfeeder.log, but my Sharing Key is not found in RadarBox, and according to rbfeeder.log no packets are sent.
A snapshot from rbfeeder.log:
2021-05-21 16:44:07] Starting RBFeeder Version 0.4.1 (build 20210414164501)
[2021-05-21 16:44:07] Using configuration file: /etc/rbfeeder.ini
[2021-05-21 16:44:07] Network-mode enabled.
[2021-05-21 16:44:07] Remote host to fetch data: 127.0.0.1
[2021-05-21 16:44:07] Remote port: 30005
[2021-05-21 16:44:07] Remote protocol: BEAST
[2021-05-21 16:44:07] System: rblc2
[2021-05-21 16:44:07] Start date/time: 2021-05-21 16:44:07
[2021-05-21 16:44:07] Socket for ANRB created. Waiting for connections on port 32088
[2021-05-21 16:44:09] Connection established.
[2021-05-21 16:44:10] [471F6E] P: 20620.646 vtas: 456.000 vias: 245.000 Alt: 38025 mach: 0.776 VTAS: 456.000 VTAS2: 234.586 Temp: 227.401 (-45.749 C) Temp 2: -50.377 Temp 3: -25.084
[2021-05-21 16:44:13] [471F6E] P: 20620.646 vtas: 456.000 vias: 245.000 Alt: 38025 mach: 0.776 VTAS: 456.000 VTAS2: 234.586 Temp: 227.401 (-45.749 C) Temp 2: -50.377 Temp 3: -25.084
[2021-05-21 16:44:16] [471F6E] P: 20620.646 vtas: 456.000 vias: 245.000 Alt: 38025 mach: 0.776 VTAS: 456.000 VTAS2: 234.586 Temp: 227.401 (-45.749 C) Temp 2: -50.377 Temp 3: -25.084
[2021-05-21 16:44:19] Could not start connection. Timeout.
[2021-05-21 16:44:19] [471F6E] P: 20620.646 vtas: 456.000 vias: 245.000 Alt: 38025 mach: 0.776 VTAS: 456.000 VTAS2: 234.586 Temp: 227.401 (-45.749 C) Temp 2: -50.377 Temp 3: -25.084
[...]
[2021-05-21 16:44:37] ******** Statistics updated every 30 seconds ********
[2021-05-21 16:44:37] Packets sent in the last 30 seconds: 0, Total packets sent since startup: 0
[2021-05-21 16:44:37] Data sent: 50 B
[2021-05-21 16:44:37] Data received: 0 B
[...]
This "Connection established" and "Could not start connection. Timeout." happens in regular intervals, and each 30s the statistics are shown that there are 0 packets sent.
So to me it looks dump1090 is working fine, rbfeeder is receiving its data but no packets are sent to RB.
Any clues where I should be looking? The RPi resolves radarbox24.com and radarbox.com
Did you claim your station?
If not, then to claim, please follow instructions here:
https://www.radarbox.com/raspberry-pi/claim
.
When trying to claim, I get the error "Sharing Key not found".
I assume this is because rpfeeder hasn't been able to connect to RadarBox yet to publish the key.
Reboot the Pi and check if key has been obtained.
The latest version of rbfeeder (0.4.1-20210414164501), fails to start/restart by systemd command "sudo systemctl restart rbfeeder", and and hence fails to obtain the key. The only way left to restart rbfeeder is to Reboot the Pi (sudo reboot).
.
I'm sorry, but that didn't do anything either.
I keep seeing these messages, even after rebooting:
[2021-05-22 10:01:13] Connection established.
[..]
[2021-05-22 10:01:18] ******** Statistics updated every 30 seconds ********
[2021-05-22 10:01:18] Packets sent in the last 30 seconds: 0, Total packets sent since startup: 0
[2021-05-22 10:01:18] Data sent: 29.4 KB
[2021-05-22 10:01:18] Data received: 0 B
[..]
[2021-05-22 10:01:23] Could not start connection. Timeout.
And the Sharing Key is still not found to claim my RPi.
Any other ideas? :)
Try contacting
[email protected] for advice
Alan
Quote from: wooter on May 22, 2021, 09:02:41 AM
And the Sharing Key is still not found to claim my RPi.
Does the output of this command not show the key?
sudo rbfeeder --showkey --no-start
You can find the key by following command also:
cat /etc/rbfeeder.ini
That command shows the key.
But the key is not recognised on the Radarbox website.
Try this:
First delete the file /etc/rbfeeder.ini and purge the installed rbfeeder by following commands
sudo rm /etc/rbfeeder.ini
sudo apt-get purge rbfeeder
sudo reboot
After reboot Install rbfeeder again, and get new key.
sudo apt-get install rbfeeder
sudo rbfeeder --showkey --no-start
Now try to claim using new key.
.
Followed that, no change. Still the same behaviour, and the new key is also not recognised by Radarbox.
As already suggested by Alan, try contacting
[email protected] for advice
There is some sharing key issues that have been escalated to our development team.
I'm +1 with this issue, my setup seems ok (with 1090-fa feeds FA, Fr24, PlaneFinder) but the key is not accepted by the radarbox claim page. Lost count of how many abcd567's troubleshooting posts I read after so many google searches. Following up with the thread.
See previous post, there is an issue with keys which has been passed to the developers for correction
Alan
Any updates on this bug?
Still unable to upload my data and finish the claim process.
[2021-05-27 09:14:09] [A38C95] P: 47039617051387033513099264.000 vtas: 440.000 vias: 250.000 Alt: 35850 mach: 0.756 VTAS: 440.000 VTAS2: 226.355 Temp: 223.074 (-50.076 C) Temp 2: -50.377 Temp 3: -1.008
[2021-05-27 09:14:09] [A57A1D] P: 71549210994628537612238848.000 vtas: 484.000 vias: 323.000 Alt: 26750 mach: 0.796 VTAS: 484.000 VTAS2: 248.991 Temp: 243.473 (-29.677 C) Temp 2: -50.377 Temp 3: 136.617
[2021-05-27 09:14:10] Could not start connection. Timeout.
As far as I am aware it is fixed on a new RB feeder see https://forum.radarbox24.com/index.php?topic=105021.15
Alan
Indeed, this fixed it for me.